summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-06-02 00:13:57 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-06-02 00:13:57 +0000
commit1cb72caae45f4ed0bb04d91cc00b35b434462bf3 (patch)
tree42351b4cfcaa830b47962b1141202b66e3a0c777 /gnome-base/libbonobo
parentfinally. STABLE (diff)
downloadhistorical-1cb72caae45f4ed0bb04d91cc00b35b434462bf3.tar.gz
historical-1cb72caae45f4ed0bb04d91cc00b35b434462bf3.tar.bz2
historical-1cb72caae45f4ed0bb04d91cc00b35b434462bf3.zip
stable libbonobo
Diffstat (limited to 'gnome-base/libbonobo')
-rw-r--r--gnome-base/libbonobo/ChangeLog6
-rw-r--r--gnome-base/libbonobo/files/digest-libbonobo-2.0.01
-rw-r--r--gnome-base/libbonobo/libbonobo-2.0.0.ebuild53
3 files changed, 59 insertions, 1 deletions
diff --git a/gnome-base/libbonobo/ChangeLog b/gnome-base/libbonobo/ChangeLog
index 62f826d325e9..4dc70f34c842 100644
--- a/gnome-base/libbonobo/ChangeLog
+++ b/gnome-base/libbonobo/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for gnome-base/libbonobo
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libbonobo/ChangeLog,v 1.3 2002/05/28 00:48:35 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libbonobo/ChangeLog,v 1.4 2002/06/02 00:13:57 spider Exp $
+*libbonobo-2.0.0 (1 Jun 2002)
+ 1 Jun 2002; Spider <spider@gentoo.org> libbonobo-2.0.0.ebuild:
+ Gnome2 stable closing in rapidly. this is the stable version
+
*libbonobo-1.117.1 (27 May 2002)
27 May 2002; Spider <spider@gentoo.org> libbonobo-1.117.1.ebuild:
New version
diff --git a/gnome-base/libbonobo/files/digest-libbonobo-2.0.0 b/gnome-base/libbonobo/files/digest-libbonobo-2.0.0
new file mode 100644
index 000000000000..a64bedf5af6b
--- /dev/null
+++ b/gnome-base/libbonobo/files/digest-libbonobo-2.0.0
@@ -0,0 +1 @@
+MD5 fee1e4af2e5f04a7f6bcce6c066de957 libbonobo-2.0.0.tar.bz2 470293
diff --git a/gnome-base/libbonobo/libbonobo-2.0.0.ebuild b/gnome-base/libbonobo/libbonobo-2.0.0.ebuild
new file mode 100644
index 000000000000..fce7565d891a
--- /dev/null
+++ b/gnome-base/libbonobo/libbonobo-2.0.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libbonobo/libbonobo-2.0.0.ebuild,v 1.1 2002/06/02 00:13:57 spider Exp $
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="a CORBA framework "
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/pre-gnome2/sources/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="0"
+LICENSE="LGPL-2.1 GPL-2"
+
+RDEPEND=">=dev-libs/glib-2.0.0
+ >=gnome-base/ORBit2-2.4.0
+ >=gnome-base/bonobo-activation-1.0.0"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ >=dev-util/intltool-0.17
+ doc? ( >=dev-util/gtk-doc-0.9-r2 )"
+
+
+src_compile() {
+ local myconf
+ libtoolize --copy --force
+ use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} \
+ --enable-debug=yes || die "configure failure"
+ emake || die "compile failure"
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog INSTALL NEWS README TODO
+}
+
+