summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-12-19 21:52:43 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-12-19 21:52:43 +0000
commit7c3f4653f379f37bbd79cb0197c6dd2968e3acc1 (patch)
tree723df5f0e230e86f0b3e4bd0bd242d2d8d51d433 /games-util
parentStable on hppa. (diff)
downloadhistorical-7c3f4653f379f37bbd79cb0197c6dd2968e3acc1.tar.gz
historical-7c3f4653f379f37bbd79cb0197c6dd2968e3acc1.tar.bz2
historical-7c3f4653f379f37bbd79cb0197c6dd2968e3acc1.zip
Added gcc4 patch to 20050324 version since the newer one breaks on older patch files. Closing bug #114920.
Package-Manager: portage-2.1_pre1
Diffstat (limited to 'games-util')
-rw-r--r--games-util/loki_patch/ChangeLog7
-rw-r--r--games-util/loki_patch/Manifest5
-rw-r--r--games-util/loki_patch/files/loki_patch-20050324-gcc4.patch12
-rw-r--r--games-util/loki_patch/loki_patch-20050324.ebuild3
4 files changed, 23 insertions, 4 deletions
diff --git a/games-util/loki_patch/ChangeLog b/games-util/loki_patch/ChangeLog
index aeb4de2c9443..cf5b176db309 100644
--- a/games-util/loki_patch/ChangeLog
+++ b/games-util/loki_patch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-util/loki_patch
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/loki_patch/ChangeLog,v 1.6 2005/12/09 20:18:38 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/loki_patch/ChangeLog,v 1.7 2005/12/19 21:52:43 wolf31o2 Exp $
+
+ 19 Dec 2005; Chris Gianelloni <wolf31o2@gentoo.org>
+ +files/loki_patch-20050324-gcc4.patch, loki_patch-20050324.ebuild:
+ Added gcc4 patch to 20050324 version since the newer one breaks on older
+ patch files. Closing bug #114920.
*loki_patch-20051209 (09 Dec 2005)
diff --git a/games-util/loki_patch/Manifest b/games-util/loki_patch/Manifest
index ff4d134ccd2f..f4ea04455315 100644
--- a/games-util/loki_patch/Manifest
+++ b/games-util/loki_patch/Manifest
@@ -1,7 +1,8 @@
-MD5 65d065438ee47a69b3f897a53590b4cb ChangeLog 1323
+MD5 140a9126143ac10c6fd0be4ead2688cb ChangeLog 1558
MD5 0cd086d2e6b2df8cfe7b41fbf0a9f20e files/digest-loki_patch-20050324 72
MD5 c4debd478b2666f20fc737fddfdd4bf3 files/digest-loki_patch-20051209 71
MD5 6db02d05d799f5f6eed6dd15cc91869a files/loki_patch-20050324-amd64.patch 398
-MD5 57974546ccc86579fcc8116adcbae935 loki_patch-20050324.ebuild 1008
+MD5 2a24cfb6fa756dfd7ce23444a5476fd3 files/loki_patch-20050324-gcc4.patch 375
+MD5 55ba8bb28c5afb4b076b43bfa6756a99 loki_patch-20050324.ebuild 1044
MD5 17a36ce9dd3e888551893b9efcd0c57c loki_patch-20051209.ebuild 942
MD5 11a7e1491b1ac042ac7216b26b4ad1fb metadata.xml 254
diff --git a/games-util/loki_patch/files/loki_patch-20050324-gcc4.patch b/games-util/loki_patch/files/loki_patch-20050324-gcc4.patch
new file mode 100644
index 000000000000..37468c53cc28
--- /dev/null
+++ b/games-util/loki_patch/files/loki_patch-20050324-gcc4.patch
@@ -0,0 +1,12 @@
+diff -uNr loki_patch-old/loki_xdelta.c loki_patch/loki_xdelta.c
+--- loki_patch-20050324-old/loki_xdelta.c 2005-12-09 00:03:15.000000000 +0100
++++ loki_patch-20050324/loki_xdelta.c 2005-12-09 00:03:51.000000000 +0100
+@@ -51,7 +51,7 @@
+
+ #include "xdelta.h"
+
+-extern HandleFuncTable xd_handle_table;
++static HandleFuncTable xd_handle_table;
+
+ #define XD_PAGE_SIZE (1<<20)
+
diff --git a/games-util/loki_patch/loki_patch-20050324.ebuild b/games-util/loki_patch/loki_patch-20050324.ebuild
index 51da53ba421a..6d2918c9bda6 100644
--- a/games-util/loki_patch/loki_patch-20050324.ebuild
+++ b/games-util/loki_patch/loki_patch-20050324.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/loki_patch/loki_patch-20050324.ebuild,v 1.2 2005/04/11 12:32:59 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/loki_patch/loki_patch-20050324.ebuild,v 1.3 2005/12/19 21:52:43 wolf31o2 Exp $
inherit eutils
@@ -20,6 +20,7 @@ RDEPEND="games-util/loki_setupdb"
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${P}-amd64.patch
+ epatch ${FILESDIR}/${P}-gcc4.patch
}
src_compile() {