summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-09-01 18:21:32 +0000
committerMike Frysinger <vapier@gentoo.org>2009-09-01 18:21:32 +0000
commit5342c3cf1cc9bb8c54ffb3ab057715ae2c39452b (patch)
treea8c3fd7a4aad3f041543faec7f6be2d7d538e035 /games-util/linux-wbfs-manager
parentVersion bump, remove old unstable. Keep 3 stable version branches .10 .12 (diff)
downloadhistorical-5342c3cf1cc9bb8c54ffb3ab057715ae2c39452b.tar.gz
historical-5342c3cf1cc9bb8c54ffb3ab057715ae2c39452b.tar.bz2
historical-5342c3cf1cc9bb8c54ffb3ab057715ae2c39452b.zip
Initial version by me.
Package-Manager: portage-2.2_rc40/cvs/Linux x86_64
Diffstat (limited to 'games-util/linux-wbfs-manager')
-rw-r--r--games-util/linux-wbfs-manager/ChangeLog10
-rw-r--r--games-util/linux-wbfs-manager/Manifest14
-rw-r--r--games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.10.ebuild37
-rw-r--r--games-util/linux-wbfs-manager/metadata.xml5
4 files changed, 66 insertions, 0 deletions
diff --git a/games-util/linux-wbfs-manager/ChangeLog b/games-util/linux-wbfs-manager/ChangeLog
new file mode 100644
index 000000000000..0ff2c4a01fdc
--- /dev/null
+++ b/games-util/linux-wbfs-manager/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-util/linux-wbfs-manager
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/linux-wbfs-manager/ChangeLog,v 1.1 2009/09/01 18:21:32 vapier Exp $
+
+*linux-wbfs-manager-0.1.10 (01 Sep 2009)
+
+ 01 Sep 2009; Mike Frysinger <vapier@gentoo.org>
+ +linux-wbfs-manager-0.1.10.ebuild, +metadata.xml:
+ Initial version by me.
+
diff --git a/games-util/linux-wbfs-manager/Manifest b/games-util/linux-wbfs-manager/Manifest
new file mode 100644
index 000000000000..5956ad84ce15
--- /dev/null
+++ b/games-util/linux-wbfs-manager/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST linux-wbfs-manager-0.1.10.tar.gz 33980 RMD160 4e54faf950fb6b40e6c02e7bec1f713a8fae60d6 SHA1 f8cc2b0030d68142f37044dbaa655baaa1a8cd8f SHA256 18994953124592b5f0e8297190d27e9afaf16af3a8452f7697884371aa7d04a3
+EBUILD linux-wbfs-manager-0.1.10.ebuild 789 RMD160 bef2bac7bbd79ea163df6cdd35e98d5e6a94fb78 SHA1 6c1236a66eeec305ed444709c69c57adc6313e72 SHA256 75b5e728d5b98b7b1147d11ad4b620bc3e5feb7f68d8ffe714344dcb74acbe4c
+MISC ChangeLog 401 RMD160 61236109d2abde300388656e7b9c82e33d533352 SHA1 fe11b0defb359795f34151f9d373787e861f2b9f SHA256 5fcab59f6f1bb362b9b452d8aeab3edfb8d2d8c9f241f9dc13cbbc5003de222a
+MISC metadata.xml 158 RMD160 cbd9984bb6b426c8c9cee5022fe0a26261612fea SHA1 be5251fa1dacef5c41b74761bb1c8c54fb633b9e SHA256 1423a4fdd4a79b1728a2056d9e300f7e1074253095d82726218d9e9b953888a3
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.11 (GNU/Linux)
+
+iEYEARECAAYFAkqdZI8ACgkQlPl3HsVfCDpSIwCdFakcW8uY8Sx6iIfn3s/mSco8
+Lu4Aniw+RzP78KWaAaFRSqcq8R94ZQQE
+=ehp2
+-----END PGP SIGNATURE-----
diff --git a/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.10.ebuild b/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.10.ebuild
new file mode 100644
index 000000000000..c57523357ecb
--- /dev/null
+++ b/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.10.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.10.ebuild,v 1.1 2009/09/01 18:21:32 vapier Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="WBFS manager for Linux using GTK+"
+HOMEPAGE="http://code.google.com/p/linux-wbfs-manage/"
+SRC_URI="http://linux-wbfs-manager.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/glib:2
+ gnome-base/libglade:2.0"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -i \
+ -e '/^CFLAGS/s:= -O2:+= $(CPPFLAGS):' \
+ -e '/^LDFLAGS/d' \
+ Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin wbfs_gtk || die
+ dodoc README
+}
diff --git a/games-util/linux-wbfs-manager/metadata.xml b/games-util/linux-wbfs-manager/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-util/linux-wbfs-manager/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>