summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-30 05:11:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-30 05:11:32 +0000
commit5930af81589bcebf10199a9f6abe7ce3211d7b2d (patch)
tree89649a24c53243c513f8be5f93abf612de191328 /games-sports/foobillard
parentVersion bump, thanks to David Pufer (bug # 52371) (diff)
downloadhistorical-5930af81589bcebf10199a9f6abe7ce3211d7b2d.tar.gz
historical-5930af81589bcebf10199a9f6abe7ce3211d7b2d.tar.bz2
historical-5930af81589bcebf10199a9f6abe7ce3211d7b2d.zip
tidy; error messages
Diffstat (limited to 'games-sports/foobillard')
-rw-r--r--games-sports/foobillard/ChangeLog7
-rw-r--r--games-sports/foobillard/Manifest4
-rw-r--r--games-sports/foobillard/foobillard-2.9.ebuild14
3 files changed, 15 insertions, 10 deletions
diff --git a/games-sports/foobillard/ChangeLog b/games-sports/foobillard/ChangeLog
index 5dc0319d453e..3d58e34eb1c4 100644
--- a/games-sports/foobillard/ChangeLog
+++ b/games-sports/foobillard/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-sports/foobillard
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/ChangeLog,v 1.3 2003/11/10 04:25:54 vapier Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/ChangeLog,v 1.4 2004/05/30 05:11:32 mr_bones_ Exp $
+
+ 29 May 2004; Michael Sterrett <mr_bones_@gentoo.org> foobillard-2.9.ebuild:
+ tidy; error messages
*foobillard-2.9 (09 Nov 2003)
diff --git a/games-sports/foobillard/Manifest b/games-sports/foobillard/Manifest
index 1fa447a26bb5..f6507e9e2370 100644
--- a/games-sports/foobillard/Manifest
+++ b/games-sports/foobillard/Manifest
@@ -1,6 +1,6 @@
-MD5 6d2636f0a30906121189092240740d47 ChangeLog 1548
+MD5 c1cc52687a835521e3a3453a7e5fb36c ChangeLog 1653
MD5 49a1fe460078eade9e98a62a908e3a48 foobillard-2.8.ebuild 1128
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 c965ceda5a016c368d073d754f2660f5 foobillard-2.9.ebuild 1134
+MD5 a1087a1c3190b4771a25cfede5dd551f foobillard-2.9.ebuild 1181
MD5 7e9ec0cee63a42f327ed7d5de7127028 files/digest-foobillard-2.8 67
MD5 4827c3043c229b4ec77086d4554e7a7a files/digest-foobillard-2.9 67
diff --git a/games-sports/foobillard/foobillard-2.9.ebuild b/games-sports/foobillard/foobillard-2.9.ebuild
index 04a86f14d527..ec154ea0d22d 100644
--- a/games-sports/foobillard/foobillard-2.9.ebuild
+++ b/games-sports/foobillard/foobillard-2.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/foobillard-2.9.ebuild,v 1.3 2004/03/20 12:59:58 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/foobillard-2.9.ebuild,v 1.4 2004/05/30 05:11:32 mr_bones_ Exp $
inherit games
@@ -19,15 +19,17 @@ DEPEND="virtual/x11
>=media-libs/libpng-1.2.1
|| (
sdl? ( media-libs/libsdl )
- ( virtual/glu virtual/glut )
+ (
+ virtual/glu
+ virtual/glut )
)"
src_compile() {
local myconf=""
- [ "`ls /usr/include/GL/gl.h -al | awk '{print $NF}' | cut -d/ -f5`" == "nvidia" ] \
+ [ "$(ls /usr/include/GL/gl.h -al | awk '{print $NF}' | cut -d/ -f5)" == "nvidia" ] \
&& myconf="--enable-nvidia" \
|| myconf="--disable-nvidia"
- myconf="${myconf} `use_enable sdl SDL`"
+ myconf="${myconf} $(use_enable sdl SDL)"
use sdl \
&& myconf="${myconf} --disable-glut" \
|| myconf="${myconf} --enable-glut"
@@ -36,11 +38,11 @@ src_compile() {
--enable-sound \
${myconf} \
|| die
- emake || die
+ emake || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die "make install failed"
dodoc README README.FONTS AUTHORS NEWS ChangeLog
prepgamesdirs
}