summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-02 21:16:20 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-02 21:16:20 +0000
commitffba9639111e96ad858a03091a8ee2cdd9e926b2 (patch)
tree82f0e4f8b9982ffbc50d2b0a536a9c634b1f4950 /games-simulation
parentRemoving obsolete ebuild (diff)
downloadhistorical-ffba9639111e96ad858a03091a8ee2cdd9e926b2.tar.gz
historical-ffba9639111e96ad858a03091a8ee2cdd9e926b2.tar.bz2
historical-ffba9639111e96ad858a03091a8ee2cdd9e926b2.zip
Fix a traceback from using wrong var name #97762 by Peter Roozemaal.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/qct/ChangeLog8
-rw-r--r--games-simulation/qct/Manifest15
-rw-r--r--games-simulation/qct/files/qct-0.7-constant.patch21
-rw-r--r--games-simulation/qct/qct-0.7.ebuild16
4 files changed, 51 insertions, 9 deletions
diff --git a/games-simulation/qct/ChangeLog b/games-simulation/qct/ChangeLog
index 7583bc50b612..37cb98eaa1ca 100644
--- a/games-simulation/qct/ChangeLog
+++ b/games-simulation/qct/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/qct
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/qct/ChangeLog,v 1.4 2004/12/16 15:58:49 josejx Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/qct/ChangeLog,v 1.5 2005/07/02 21:16:20 vapier Exp $
+
+ 02 Jul 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/qct-0.7-constant.patch, qct-0.7.ebuild:
+ Fix a traceback from using wrong var name #97762 by Peter Roozemaal.
16 Dec 2004; Joseph Jezak <josejx@gentoo.org> qct-0.7.ebuild:
Marked ppc stable.
diff --git a/games-simulation/qct/Manifest b/games-simulation/qct/Manifest
index 9eaa311d22df..c1cc3b8d33c9 100644
--- a/games-simulation/qct/Manifest
+++ b/games-simulation/qct/Manifest
@@ -1,4 +1,15 @@
-MD5 d4f8df6136b4e30aa371898826cafadc ChangeLog 558
-MD5 3e059a24126429b64cc7f6e3e05648df qct-0.7.ebuild 789
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 33b56a74f2bd9ea5227031f75039b4e1 qct-0.7.ebuild 877
+MD5 1bb7190f85a47be2db1ce8e9a8226e9b ChangeLog 729
+MD5 7daeff4db5ed966d68fe4d944aa247b1 files/qct-0.7-constant.patch 712
MD5 987c0051916a2bfe70b434fcdaec006f files/digest-qct-0.7 58
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCxwRAgIKl8Uu19MoRAtPOAKCClQV5z2f1JiVbxnWMk5mtrhIlkACdFSZf
+Rz/U72lMQHDtgCS5moF6QZ4=
+=h99/
+-----END PGP SIGNATURE-----
diff --git a/games-simulation/qct/files/qct-0.7-constant.patch b/games-simulation/qct/files/qct-0.7-constant.patch
new file mode 100644
index 000000000000..43a01ea1a4a9
--- /dev/null
+++ b/games-simulation/qct/files/qct-0.7-constant.patch
@@ -0,0 +1,21 @@
+Fix traceback from using wrong name.
+
+Patch by Peter `MathFox' Roozemaal.
+
+http://bugs.gentoo.org/97762
+http://sourceforge.net/tracker/index.php?func=detail&aid=801329&group_id=74836&atid=542163
+
+--- qct/specializations.py
++++ qct/specializations.py
+@@ -131,9 +131,9 @@
+ mods = self.getModsFor('incomeMod', employer)
+ if resident:
+ if resident.job == trainer:
+- return prospect.level * INCOMEMULT * mods
++ return prospect.level * constants.INCOMEMULT * mods
+ else:
+- return prospect.level * INCOMEMULT / 2 * mods
++ return prospect.level * constants.INCOMEMULT / 2 * mods
+ else:
+ return 0
+
diff --git a/games-simulation/qct/qct-0.7.ebuild b/games-simulation/qct/qct-0.7.ebuild
index cd704e1c70f7..ae62e359b55b 100644
--- a/games-simulation/qct/qct-0.7.ebuild
+++ b/games-simulation/qct/qct-0.7.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/qct/qct-0.7.ebuild,v 1.5 2004/12/16 15:58:49 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/qct/qct-0.7.ebuild,v 1.6 2005/07/02 21:16:20 vapier Exp $
-inherit games
+inherit games eutils
DESCRIPTION="Quiet Console Town puts you in the place of the mayor of a budding new console RPG city"
HOMEPAGE="http://sourceforge.net/projects/qct/"
@@ -10,13 +10,19 @@ SRC_URI="mirror://sourceforge/qct/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc ~amd64"
+KEYWORDS="amd64 ppc x86"
IUSE=""
RDEPEND=">=dev-lang/python-2.2.1
>=dev-python/pygame-1.5.5"
-S="${WORKDIR}/${PN}"
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-constant.patch
+}
src_install() {
local destdir="${GAMES_DATADIR}/${PN}"