summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-10-05 17:52:07 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-10-05 17:52:07 +0000
commitca3a8a36138274eb3757165163a3e5e1aecd7370 (patch)
tree6f5fb0462eded05db60e92ad7b50e9ff4e514607 /games-rpg/nwn-cep/nwn-cep-1.68.ebuild
parentFix gettext dependency (diff)
downloadhistorical-ca3a8a36138274eb3757165163a3e5e1aecd7370.tar.gz
historical-ca3a8a36138274eb3757165163a3e5e1aecd7370.tar.bz2
historical-ca3a8a36138274eb3757165163a3e5e1aecd7370.zip
Version bump to 1.68 and closing bug #147017.
Package-Manager: portage-2.1.2_pre1-r4
Diffstat (limited to 'games-rpg/nwn-cep/nwn-cep-1.68.ebuild')
-rw-r--r--games-rpg/nwn-cep/nwn-cep-1.68.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/games-rpg/nwn-cep/nwn-cep-1.68.ebuild b/games-rpg/nwn-cep/nwn-cep-1.68.ebuild
new file mode 100644
index 000000000000..2c1671130f08
--- /dev/null
+++ b/games-rpg/nwn-cep/nwn-cep-1.68.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn-cep/nwn-cep-1.68.ebuild,v 1.1 2006/10/05 17:52:07 wolf31o2 Exp $
+
+inherit eutils games
+
+DESCRIPTION="a high quality custom content addon for Neverwinter Nights"
+HOMEPAGE="http://nwn.bioware.com/players/cep.html"
+SRC_URI="cepv152_man.zip cepv153.zip CEP168.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="fetch"
+
+DEPEND="app-arch/unzip"
+RDEPEND="~games-rpg/nwn-1.68"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please visit http://nwvault.ign.com/cep/downloads/"
+ einfo "and download the .zip versions of ${A}."
+ einfo "Then move the files you downloaded to:"
+ einfo "${DISTDIR}"
+}
+
+pkg_setup() {
+ games_pkg_setup
+ if ! built_with_use games-rpg/nwn-data sou || ! built_with_use games-rpg/nwn-data hou
+ then
+ eerror "${P} requires NWN v1.68, Shadows of Undrentide, and Hordes of"
+ eerror "the Underdark. Please make sure you have all three before using"
+ eerror "this patch."
+ die "Requirements not met"
+ fi
+}
+
+src_install() {
+ dodir "${GAMES_PREFIX_OPT}"/nwn/{hak,tlk,modules,cep}
+ cp *.hak "${D}/${GAMES_PREFIX_OPT}"/nwn/hak/ || die "hak failed"
+
+ local hak
+ if use hou ; then
+ hak=HotU
+ elif use sou ; then
+ hak=SoU
+ else
+ hak=Live
+ fi
+
+ cp ${hak}/* "${D}/${GAMES_PREFIX_OPT}"/nwn/hak/ || die "hak2 failed"
+ cp cep.tlk "${D}/${GAMES_PREFIX_OPT}"/nwn/tlk/ || die "tlk failed"
+ cp *.mod "${D}/${GAMES_PREFIX_OPT}"/nwn/modules/ || die "mod failed"
+ cp *.pdf *.txt "${D}/${GAMES_PREFIX_OPT}"/nwn/cep/ || die "docs failed"
+ prepgamesdirs
+}