summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-19 06:41:27 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-19 06:41:27 +0000
commitc6ffb37691cb3a9345d4657fcacee5eb4d691e21 (patch)
tree467ce7815e55f06967c770b856323fafb2de616c /games-puzzle
parentversion bump #29016 (diff)
downloadhistorical-c6ffb37691cb3a9345d4657fcacee5eb4d691e21.tar.gz
historical-c6ffb37691cb3a9345d4657fcacee5eb4d691e21.tar.bz2
historical-c6ffb37691cb3a9345d4657fcacee5eb4d691e21.zip
fix permissions for log file
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/tetrix/tetrix-1.13.16.1.40c-r2.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/games-puzzle/tetrix/tetrix-1.13.16.1.40c-r2.ebuild b/games-puzzle/tetrix/tetrix-1.13.16.1.40c-r2.ebuild
index d0190f61a1f3..39e4fc108d41 100644
--- a/games-puzzle/tetrix/tetrix-1.13.16.1.40c-r2.ebuild
+++ b/games-puzzle/tetrix/tetrix-1.13.16.1.40c-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tetrix/tetrix-1.13.16.1.40c-r2.ebuild,v 1.1 2003/09/18 03:35:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tetrix/tetrix-1.13.16.1.40c-r2.ebuild,v 1.2 2003/09/19 06:41:27 vapier Exp $
inherit games gcc
@@ -48,7 +48,10 @@ src_install() {
newexe ${FILESDIR}/tetrix.rc tetrix
keepdir ${GAMES_STATEDIR}/${PN}
+ dodir ${GAMES_LOGDIR}
+ touch ${GAMES_LOGDIR}/${PN}.log
prepgamesdirs
- fowners ${GAMES_USER_DED} ${GAMES_STATEDIR}/${PN}
+ fowners ${GAMES_USER_DED}:${GAMES_GROUP} ${GAMES_STATEDIR}/${PN}
+ fowners ${GAMES_USER_DED}:${GAMES_GROUP} ${GAMES_LOGDIR}/${PN}.log
}