summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-11-03 00:29:29 +0000
committerMike Frysinger <vapier@gentoo.org>2004-11-03 00:29:29 +0000
commita572d87777d6a2785a4302a0e00d694d51647c76 (patch)
tree02e20a2e406c96dc56003b4e3e92a3771352dfd0 /games-fps
parentmask directfb (diff)
downloadhistorical-a572d87777d6a2785a4302a0e00d694d51647c76.tar.gz
historical-a572d87777d6a2785a4302a0e00d694d51647c76.tar.bz2
historical-a572d87777d6a2785a4302a0e00d694d51647c76.zip
needs unzip #69831
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/aaquake2/aaquake2-0.1.ebuild6
-rw-r--r--games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild8
-rw-r--r--games-fps/cube/cube-20031223.ebuild90
-rw-r--r--games-fps/cube/cube-20040522.ebuild5
-rw-r--r--games-fps/cube/files/20031223-gentoo-paths.patch43
-rw-r--r--games-fps/cube/files/cube-20021020-add-custom-paths.patch43
-rw-r--r--games-fps/cube/files/digest-cube-200312231
-rw-r--r--games-fps/freedoom/freedoom-0.2.ebuild7
-rw-r--r--games-fps/quake1/quake1-2.40.ebuild6
-rw-r--r--games-fps/red-blue-quake2/red-blue-quake2-0.1.ebuild6
-rw-r--r--games-fps/tenebrae/tenebrae-1.04.ebuild6
-rw-r--r--games-fps/transfusion-bin/transfusion-bin-1.01.ebuild6
-rw-r--r--games-fps/unreal-tournament-strikeforce/files/digest-unreal-tournament-strikeforce-1.753
-rw-r--r--games-fps/unreal-tournament-strikeforce/unreal-tournament-strikeforce-1.75.ebuild37
-rw-r--r--games-fps/unreal-tournament-strikeforce/unreal-tournament-strikeforce-1.81.ebuild10
15 files changed, 38 insertions, 239 deletions
diff --git a/games-fps/aaquake2/aaquake2-0.1.ebuild b/games-fps/aaquake2/aaquake2-0.1.ebuild
index ea784a0fb99a..a4299cd84da5 100644
--- a/games-fps/aaquake2/aaquake2-0.1.ebuild
+++ b/games-fps/aaquake2/aaquake2-0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/aaquake2/aaquake2-0.1.ebuild,v 1.4 2004/06/24 22:39:58 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/aaquake2/aaquake2-0.1.ebuild,v 1.5 2004/11/03 00:18:59 vapier Exp $
inherit games eutils
@@ -16,7 +16,9 @@ SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND="media-libs/aalib"
+RDEPEND="media-libs/aalib"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
S="${WORKDIR}/quake2-3.21/linux"
diff --git a/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild b/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild
index f3a9377f8d9d..1b6f534f4244 100644
--- a/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild
+++ b/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild,v 1.7 2004/08/28 09:43:03 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild,v 1.8 2004/11/03 00:19:16 vapier Exp $
inherit games gcc eutils
@@ -11,12 +11,14 @@ SRC_URI="http://home.iprimus.com.au/crbean/zip/3dGLQuake_SRC_${PV}.zip
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~amd64"
+KEYWORDS="amd64 x86"
IUSE=""
-DEPEND="virtual/x11
+RDEPEND="virtual/x11
virtual/opengl
media-libs/libsdl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
S="${WORKDIR}/WinQuake"
diff --git a/games-fps/cube/cube-20031223.ebuild b/games-fps/cube/cube-20031223.ebuild
deleted file mode 100644
index bbc3068c3fda..000000000000
--- a/games-fps/cube/cube-20031223.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/cube/cube-20031223.ebuild,v 1.8 2004/08/15 09:18:26 vapier Exp $
-
-inherit eutils games
-
-MY_P="cube_2003_12_23"
-
-DESCRIPTION="open source multiplayer and singleplayer first person shooter game"
-HOMEPAGE="http://www.cubeengine.com/"
-SRC_URI="mirror://sourceforge/cube/${MY_P}.zip"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="x86 ppc hppa"
-IUSE=""
-
-RDEPEND="virtual/opengl
- virtual/glu
- media-libs/libsdl
- media-libs/sdl-mixer
- media-libs/sdl-image
- sys-libs/zlib
- media-libs/libpng"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
-
-S="${WORKDIR}/cube"
-CUBE_DATADIR="${GAMES_DATADIR}/${PN}/"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}/source
- unzip -qn ${MY_P}_src.zip || die
-
- cd ${MY_P}_src/src
- epatch ${FILESDIR}/${PV}-gentoo-paths.patch
- echo "#define GAMES_DATADIR \"${CUBE_DATADIR}\"" >> tools.h
- echo "#define GAMES_DATADIR_LEN ${#CUBE_DATADIR}" >> tools.h
- sed -i \
- -e "s:packages/:${CUBE_DATADIR}packages/:" \
- renderextras.cpp rendermd2.cpp sound.cpp worldio.cpp \
- || die "fixing data path failed"
- # enable parallel make
- sed -i \
- -e 's/make -C/$(MAKE) -C/' Makefile \
- || die "sed Makefile failed"
- edos2unix *.cpp
-}
-
-src_compile() {
- cd source/${MY_P}_src/src
- emake CXXOPTFLAGS="${CXXFLAGS}" || die "emake failed"
-}
-
-src_install() {
- dogamesbin source/${MY_P}_src/src/cube_{client,server} \
- || die "dogamesbin failed"
- exeinto "${GAMES_LIBDIR}/${PN}"
- if [ "${ARCH}" == "x86" ] ; then
- newexe bin_unix/linux_client cube_client
- newexe bin_unix/linux_server cube_server
- elif [ "${ARCH}" == "ppc" ] ; then
- newexe bin_unix/ppc_linux_client cube_client
- newexe bin_unix/ppc_linux_server cube_server
- fi
- dogamesbin ${FILESDIR}/cube_{client,server}-bin \
- || die "dogamesbin failed (bin)"
- sed -i \
- -e "s:GENTOO_DATADIR:${CUBE_DATADIR}:" \
- -e "s:GENTOO_LIBDIR:${GAMES_LIBDIR}/${PN}:" \
- ${D}/${GAMES_BINDIR}/cube_{client,server}-bin
-
- dodir ${CUBE_DATADIR}
- cp -r *.cfg data packages ${D}/${CUBE_DATADIR} \
- || die "cp failed"
-
- dodoc source/${MY_P}_src/src/CUBE_TODO.txt
- dohtml -r docs/
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- einfo "You now have 2 clients and 2 servers:"
- einfo "cube_client-bin prebuilt version (needed to play on public multiplayer servers)"
- einfo "cube_client custom client built from source"
- einfo "Parallel versions of the server have been installed"
-}
diff --git a/games-fps/cube/cube-20040522.ebuild b/games-fps/cube/cube-20040522.ebuild
index 581e6989d6ee..23ac4f22776c 100644
--- a/games-fps/cube/cube-20040522.ebuild
+++ b/games-fps/cube/cube-20040522.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/cube/cube-20040522.ebuild,v 1.4 2004/08/17 06:20:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/cube/cube-20040522.ebuild,v 1.5 2004/11/03 00:20:41 vapier Exp $
inherit eutils games
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/cube/${MY_P}.tar.gz"
LICENSE="ZLIB"
SLOT="0"
-KEYWORDS="x86 ppc hppa"
+KEYWORDS="hppa ppc x86"
IUSE=""
RDEPEND="virtual/opengl
@@ -23,6 +23,7 @@ RDEPEND="virtual/opengl
sys-libs/zlib
media-libs/libpng"
DEPEND="${RDEPEND}
+ app-arch/unzip
>=sys-apps/sed-4"
S="${WORKDIR}/cube"
diff --git a/games-fps/cube/files/20031223-gentoo-paths.patch b/games-fps/cube/files/20031223-gentoo-paths.patch
deleted file mode 100644
index 594a0714e5fb..000000000000
--- a/games-fps/cube/files/20031223-gentoo-paths.patch
+++ /dev/null
@@ -1,43 +0,0 @@
---- tools.cpp.orig 2002-12-17 09:35:55.000000000 -0500
-+++ tools.cpp 2002-12-17 09:39:28.000000000 -0500
-@@ -100,8 +100,19 @@
-
- ///////////////////////// misc tools ///////////////////////
-
-+char *addfullpath(char *s) {
-+ static char ret[256]; // choose a reasonable max buffer size
-+ if (s[0] == '/') { return s; }
-+ int slen = strlen(s);
-+ memset(ret, 0x00, 256);
-+ memcpy(ret, GAMES_DATADIR, GAMES_DATADIR_LEN);
-+ memcpy(ret+GAMES_DATADIR_LEN, s, slen);
-+ return ret;
-+}
-+
- char *path(char *s)
- {
-+ s = addfullpath(s);
- for(char *t = s; t = strpbrk(t, "/\\"); *t++ = PATHDIV);
- return s;
- };
---- rendergl.cpp.orig 2002-12-17 09:48:00.000000000 -0500
-+++ rendergl.cpp 2002-12-17 09:50:19.000000000 -0500
-@@ -59,6 +59,7 @@
-
- bool installtex(int tnum, char *texname, int &xs, int &ys, bool clamp)
- {
-+ texname = addfullpath(texname);
- SDL_Surface *s = IMG_Load(texname);
- if(!s) { conoutf("couldn't load texture %s", (int)texname); return false; };
- if(s->format->BitsPerPixel!=24) { conoutf("texture must be 24bpp: %s", (int)texname); return false; };
---- tools.h.orig 2002-12-17 09:51:06.000000000 -0500
-+++ tools.h 2002-12-17 09:50:59.000000000 -0500
-@@ -96,7 +96,7 @@
- #endif
-
-
--
-+extern char *addfullpath(char *s);
- extern char *path(char *s);
- extern char *loadfile(char *fn, int *size);
- extern void endianswap(void *, int, int);
diff --git a/games-fps/cube/files/cube-20021020-add-custom-paths.patch b/games-fps/cube/files/cube-20021020-add-custom-paths.patch
deleted file mode 100644
index 594a0714e5fb..000000000000
--- a/games-fps/cube/files/cube-20021020-add-custom-paths.patch
+++ /dev/null
@@ -1,43 +0,0 @@
---- tools.cpp.orig 2002-12-17 09:35:55.000000000 -0500
-+++ tools.cpp 2002-12-17 09:39:28.000000000 -0500
-@@ -100,8 +100,19 @@
-
- ///////////////////////// misc tools ///////////////////////
-
-+char *addfullpath(char *s) {
-+ static char ret[256]; // choose a reasonable max buffer size
-+ if (s[0] == '/') { return s; }
-+ int slen = strlen(s);
-+ memset(ret, 0x00, 256);
-+ memcpy(ret, GAMES_DATADIR, GAMES_DATADIR_LEN);
-+ memcpy(ret+GAMES_DATADIR_LEN, s, slen);
-+ return ret;
-+}
-+
- char *path(char *s)
- {
-+ s = addfullpath(s);
- for(char *t = s; t = strpbrk(t, "/\\"); *t++ = PATHDIV);
- return s;
- };
---- rendergl.cpp.orig 2002-12-17 09:48:00.000000000 -0500
-+++ rendergl.cpp 2002-12-17 09:50:19.000000000 -0500
-@@ -59,6 +59,7 @@
-
- bool installtex(int tnum, char *texname, int &xs, int &ys, bool clamp)
- {
-+ texname = addfullpath(texname);
- SDL_Surface *s = IMG_Load(texname);
- if(!s) { conoutf("couldn't load texture %s", (int)texname); return false; };
- if(s->format->BitsPerPixel!=24) { conoutf("texture must be 24bpp: %s", (int)texname); return false; };
---- tools.h.orig 2002-12-17 09:51:06.000000000 -0500
-+++ tools.h 2002-12-17 09:50:59.000000000 -0500
-@@ -96,7 +96,7 @@
- #endif
-
-
--
-+extern char *addfullpath(char *s);
- extern char *path(char *s);
- extern char *loadfile(char *fn, int *size);
- extern void endianswap(void *, int, int);
diff --git a/games-fps/cube/files/digest-cube-20031223 b/games-fps/cube/files/digest-cube-20031223
deleted file mode 100644
index fd37e49321a0..000000000000
--- a/games-fps/cube/files/digest-cube-20031223
+++ /dev/null
@@ -1 +0,0 @@
-MD5 22555b87ef16c403198a6f378c048c6f cube_2003_12_23.zip 18587017
diff --git a/games-fps/freedoom/freedoom-0.2.ebuild b/games-fps/freedoom/freedoom-0.2.ebuild
index ae6b1a8f9733..1619863e3c05 100644
--- a/games-fps/freedoom/freedoom-0.2.ebuild
+++ b/games-fps/freedoom/freedoom-0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/freedoom/freedoom-0.2.ebuild,v 1.2 2004/07/21 18:45:10 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/freedoom/freedoom-0.2.ebuild,v 1.3 2004/11/03 00:20:22 vapier Exp $
inherit games
@@ -17,10 +17,11 @@ SRC_URI="mirror://sourceforge/freedoom/doom1.zip
LICENSE="BSD"
SLOT="0"
-KEYWORDS="x86 ~ppc"
+KEYWORDS="ppc x86"
IUSE=""
-DEPEND="!games-fps/doom-data"
+RDEPEND="!games-fps/doom-data"
+DEPEND="app-arch/unzip"
src_install() {
insinto ${GAMES_DATADIR}/doom-data
diff --git a/games-fps/quake1/quake1-2.40.ebuild b/games-fps/quake1/quake1-2.40.ebuild
index f4885ad6ea33..0ab7351cfe33 100644
--- a/games-fps/quake1/quake1-2.40.ebuild
+++ b/games-fps/quake1/quake1-2.40.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1/quake1-2.40.ebuild,v 1.5 2004/06/24 22:43:09 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1/quake1-2.40.ebuild,v 1.6 2004/11/03 00:24:33 vapier Exp $
inherit games eutils gcc
@@ -13,10 +13,12 @@ SLOT="0"
KEYWORDS="x86"
IUSE="X opengl svga 3dfx"
-DEPEND="X? ( virtual/x11 )
+RDEPEND="X? ( virtual/x11 )
opengl? ( virtual/opengl )
svga? ( media-libs/svgalib )
3dfx? ( media-libs/glide-v3 )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
S=${WORKDIR}
diff --git a/games-fps/red-blue-quake2/red-blue-quake2-0.1.ebuild b/games-fps/red-blue-quake2/red-blue-quake2-0.1.ebuild
index e248b68a2e2d..5387f5e576dd 100644
--- a/games-fps/red-blue-quake2/red-blue-quake2-0.1.ebuild
+++ b/games-fps/red-blue-quake2/red-blue-quake2-0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/red-blue-quake2/red-blue-quake2-0.1.ebuild,v 1.4 2004/06/24 22:46:23 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/red-blue-quake2/red-blue-quake2-0.1.ebuild,v 1.5 2004/11/03 00:24:45 vapier Exp $
inherit games eutils
@@ -16,7 +16,9 @@ SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND="virtual/x11"
+RDEPEND="virtual/x11"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
S=${WORKDIR}/quake2-3.21/linux
diff --git a/games-fps/tenebrae/tenebrae-1.04.ebuild b/games-fps/tenebrae/tenebrae-1.04.ebuild
index 8bb93061c361..4e776361e153 100644
--- a/games-fps/tenebrae/tenebrae-1.04.ebuild
+++ b/games-fps/tenebrae/tenebrae-1.04.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/tenebrae/tenebrae-1.04.ebuild,v 1.5 2004/06/24 22:47:07 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/tenebrae/tenebrae-1.04.ebuild,v 1.6 2004/11/03 00:28:19 vapier Exp $
#ECVS_SERVER="cvs.tenebrae.sourceforge.net:/cvsroot/tenebrae"
#ECVS_MODULE="tenebrae_0"
@@ -17,11 +17,13 @@ SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND="virtual/opengl
+RDEPEND="virtual/opengl
virtual/x11
media-libs/libpng
sys-libs/zlib"
# sdl? ( media-libs/libsdl )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
S=${WORKDIR}
diff --git a/games-fps/transfusion-bin/transfusion-bin-1.01.ebuild b/games-fps/transfusion-bin/transfusion-bin-1.01.ebuild
index 40e378a25eec..0dab90bcbdf4 100644
--- a/games-fps/transfusion-bin/transfusion-bin-1.01.ebuild
+++ b/games-fps/transfusion-bin/transfusion-bin-1.01.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/transfusion-bin/transfusion-bin-1.01.ebuild,v 1.6 2004/07/01 11:18:19 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/transfusion-bin/transfusion-bin-1.01.ebuild,v 1.7 2004/11/03 00:28:33 vapier Exp $
inherit games
@@ -17,7 +17,9 @@ IUSE=""
RESTRICT="nostrip"
RDEPEND="virtual/libc"
-DEPEND=">=sys-apps/sed-4"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ >=sys-apps/sed-4"
S="${WORKDIR}/${MY_PN}"
diff --git a/games-fps/unreal-tournament-strikeforce/files/digest-unreal-tournament-strikeforce-1.75 b/games-fps/unreal-tournament-strikeforce/files/digest-unreal-tournament-strikeforce-1.75
deleted file mode 100644
index 51b89d1449a1..000000000000
--- a/games-fps/unreal-tournament-strikeforce/files/digest-unreal-tournament-strikeforce-1.75
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 e4aae05175f5e039a265d2068f5a7ee3 SF175.zip 115436985
-MD5 2c376557565baea9342b3e848a2cd430 sf175_mappack1.zip 35767354
-MD5 622c20248cc678791f790923532af50f sf175_mappack2.zip 59315718
diff --git a/games-fps/unreal-tournament-strikeforce/unreal-tournament-strikeforce-1.75.ebuild b/games-fps/unreal-tournament-strikeforce/unreal-tournament-strikeforce-1.75.ebuild
deleted file mode 100644
index 73196585aee3..000000000000
--- a/games-fps/unreal-tournament-strikeforce/unreal-tournament-strikeforce-1.75.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-strikeforce/unreal-tournament-strikeforce-1.75.ebuild,v 1.5 2004/07/14 14:45:53 agriffis Exp $
-
-inherit games
-
-MY_PV=${PV/./}
-DESCRIPTION="A UT addon where you fight terrorists as part of an elite strikeforce"
-HOMEPAGE="http://www.strikeforcecenter.com/"
-SRC_URI="http://www.zvdk.nl/downloads/server/SF${MY_PV}.zip
- http://www.zvdk.nl/downloads/client/sf${MY_PV}_mappack1.zip
- http://www.zvdk.nl/downloads/client/sf${MY_PV}_mappack2.zip"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="x86"
-IUSE=""
-
-DEPEND="|| ( games-fps/unreal-tournament games-fps/unreal-tournament-goty )"
-
-S="${WORKDIR}"
-
-src_unpack() {
- # we gotta do this cause there is a duplicate file across these zip's ...
- unpack SF${MY_PV}.zip
- unpack sf${MY_PV}_mappack1.zip
- rm -rf SF_Sounds/urbansnds.uax
- unpack sf${MY_PV}_mappack2.zip
-}
-
-src_install() {
- local dir=${GAMES_PREFIX_OPT}/unreal-tournament
- dodir ${dir}/Help
- mv *.txt ${D}/${dir}/Help/
- mv * ${D}/${dir}/
- prepgamesdirs
-}
diff --git a/games-fps/unreal-tournament-strikeforce/unreal-tournament-strikeforce-1.81.ebuild b/games-fps/unreal-tournament-strikeforce/unreal-tournament-strikeforce-1.81.ebuild
index 2d74b9f84def..d739bf8426ff 100644
--- a/games-fps/unreal-tournament-strikeforce/unreal-tournament-strikeforce-1.81.ebuild
+++ b/games-fps/unreal-tournament-strikeforce/unreal-tournament-strikeforce-1.81.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-strikeforce/unreal-tournament-strikeforce-1.81.ebuild,v 1.7 2004/06/24 22:48:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-strikeforce/unreal-tournament-strikeforce-1.81.ebuild,v 1.8 2004/11/03 00:29:29 vapier Exp $
inherit games
@@ -18,9 +18,11 @@ SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND="|| (
- games-fps/unreal-tournament
- games-fps/unreal-tournament-goty )"
+RDEPEND="|| (
+ games-fps/unreal-tournament
+ games-fps/unreal-tournament-goty
+ )"
+DEPEND="app-arch/unzip"
S="${WORKDIR}"