summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2007-07-22 13:10:50 +0000
committerTristan Heaven <tristan@gentoo.org>2007-07-22 13:10:50 +0000
commit632f3abaea7fd7e1855d15c80ed69609da7459d4 (patch)
treebe59cb01f7690d575dac97b9a50055bf4f812675 /games-fps/rott/rott-1.0.ebuild
parentNew package for glossaries (or list of acronyms). (diff)
downloadhistorical-632f3abaea7fd7e1855d15c80ed69609da7459d4.tar.gz
historical-632f3abaea7fd7e1855d15c80ed69609da7459d4.tar.bz2
historical-632f3abaea7fd7e1855d15c80ed69609da7459d4.zip
Add demo USE flag, bug #178443
Package-Manager: portage-2.1.3_rc8
Diffstat (limited to 'games-fps/rott/rott-1.0.ebuild')
-rw-r--r--games-fps/rott/rott-1.0.ebuild29
1 files changed, 17 insertions, 12 deletions
diff --git a/games-fps/rott/rott-1.0.ebuild b/games-fps/rott/rott-1.0.ebuild
index 184070098613..265b8440629a 100644
--- a/games-fps/rott/rott-1.0.ebuild
+++ b/games-fps/rott/rott-1.0.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/rott/rott-1.0.ebuild,v 1.9 2007/03/12 15:08:23 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/rott/rott-1.0.ebuild,v 1.10 2007/07/22 13:10:49 nyhm Exp $
inherit eutils games
DESCRIPTION="Rise of the Triad for Linux!"
HOMEPAGE="http://www.icculus.org/rott/"
SRC_URI="http://www.icculus.org/rott/releases/${P}.tar.gz
- http://filesingularity.timedoctor.org/swdata.zip"
+ demo? ( http://filesingularity.timedoctor.org/swdata.zip )"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~ppc x86"
-IUSE=""
+IUSE="demo"
RDEPEND="media-libs/libsdl
media-libs/sdl-mixer"
@@ -24,12 +24,14 @@ S=${WORKDIR}/${P}/rott
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${PV}-custom-datapath.patch \
- "${FILESDIR}/${P}"-gcc41.patch
+ epatch \
+ "${FILESDIR}"/${PV}-custom-datapath.patch \
+ "${FILESDIR}"/${P}-gcc41.patch
+ use demo || epatch "${FILESDIR}"/${P}-full-version.patch
}
src_compile() {
- make clean || die
+ emake clean || die
emake -j1 EXTRACFLAGS="${CFLAGS} -DDATADIR=\\\"${GAMES_DATADIR}/${PN}/\\\"" \
|| die "emake failed"
}
@@ -37,15 +39,18 @@ src_compile() {
src_install() {
dogamesbin rott || die "dogamesbin failed"
dodoc *.txt ../{README,readme.txt}
- cd "${WORKDIR}"
- insinto "${GAMES_DATADIR}"/${PN}
- doins *.dmo huntbgin.* remote1.rts || die "doins failed"
+ if use demo ; then
+ cd "${WORKDIR}"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins *.dmo huntbgin.* remote1.rts || die "doins failed"
+ fi
prepgamesdirs
}
pkg_postinst() {
games_pkg_postinst
- elog "The shareware version has been installed."
- elog "To play the full version, just copy the"
- elog "data files to ${GAMES_DATADIR}/${PN}/"
+ if ! use demo ; then
+ elog "To play the full version, just copy the"
+ elog "data files to ${GAMES_DATADIR}/${PN}/"
+ fi
}