summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-11-01 15:29:52 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-11-01 15:29:52 +0000
commite5e31262b62b3242a9ab1a758f0767a92ce70536 (patch)
treef60266c0b633b1975d7737c3c0d39ca340ce49be /games-fps/doom3-dungeon/doom3-dungeon-8.01.ebuild
parentAdd ~x86-fbsd keyword, with patch from bug #153680. (diff)
downloadhistorical-e5e31262b62b3242a9ab1a758f0767a92ce70536.tar.gz
historical-e5e31262b62b3242a9ab1a758f0767a92ce70536.tar.bz2
historical-e5e31262b62b3242a9ab1a758f0767a92ce70536.zip
Initial import. Original ebuild by Paul Bredbury <brebs@sent.com> and ported to the games-mods eclass by me. Closing bug #127147.
Package-Manager: portage-2.1.2_rc1-r1
Diffstat (limited to 'games-fps/doom3-dungeon/doom3-dungeon-8.01.ebuild')
-rw-r--r--games-fps/doom3-dungeon/doom3-dungeon-8.01.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-fps/doom3-dungeon/doom3-dungeon-8.01.ebuild b/games-fps/doom3-dungeon/doom3-dungeon-8.01.ebuild
new file mode 100644
index 000000000000..9da7423caed0
--- /dev/null
+++ b/games-fps/doom3-dungeon/doom3-dungeon-8.01.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3-dungeon/doom3-dungeon-8.01.ebuild,v 1.1 2006/11/01 15:29:52 wolf31o2 Exp $
+
+MOD_DESC="rogue-like 3D mod"
+MOD_NAME="Dungeon"
+MOD_DIR="dungeon"
+
+inherit versionator eutils games games-mods
+
+MY_PV=$(delete_all_version_separators)
+
+HOMEPAGE="http://dungeondoom.d3files.com/"
+SRC_URI="mirror://filefront/Doom_III/Hosted_Mods/Final_Releases/DungeonDOOM/${MOD_DIR}doom${MY_PV}xplinux.zip"
+
+# See bottom of /opt/doom3/dungeondoom/readme.txt
+LICENSE="as-is"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="games-fps/doom3-roe
+ games-fps/doom3"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ if ! built_with_use games-fps/doom3 roe
+ then
+ eerror "You need to install games-fps/doom3 with the roe USE flag."
+ die "Needs USE=roe games-fps/doom3"
+ fi
+}
+
+src_unpack() {
+ games-mods_src_unpack
+ # Standardize directory name.
+ local dir=$(find . -maxdepth 1 -name "dungeon*" -type d)
+ mv "${dir}" "${MOD_DIR}" || die "mv ${dir} failed"
+}