summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-04-23 06:51:49 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-04-23 06:51:49 +0000
commit3a2b588181f525d7a0360eef955fd7f4f302c499 (patch)
tree9d0594afc60903be42aebc0c298365aa4dd10732 /games-board
parentquoting (diff)
downloadhistorical-3a2b588181f525d7a0360eef955fd7f4f302c499.tar.gz
historical-3a2b588181f525d7a0360eef955fd7f4f302c499.tar.bz2
historical-3a2b588181f525d7a0360eef955fd7f4f302c499.zip
touchups
Package-Manager: portage-2.1_pre9-r3
Diffstat (limited to 'games-board')
-rw-r--r--games-board/xfrisk/xfrisk-1.2.ebuild15
-rw-r--r--games-board/xgammon/xgammon-0.98.ebuild16
2 files changed, 17 insertions, 14 deletions
diff --git a/games-board/xfrisk/xfrisk-1.2.ebuild b/games-board/xfrisk/xfrisk-1.2.ebuild
index ca828441908e..11353ab986e7 100644
--- a/games-board/xfrisk/xfrisk-1.2.ebuild
+++ b/games-board/xfrisk/xfrisk-1.2.ebuild
@@ -1,16 +1,15 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/xfrisk/xfrisk-1.2.ebuild,v 1.5 2006/01/29 21:28:01 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/xfrisk/xfrisk-1.2.ebuild,v 1.6 2006/04/23 06:48:57 mr_bones_ Exp $
inherit games
-S="${WORKDIR}/XFrisk"
DESCRIPTION="The RISK board game"
-SRC_URI="http://morphy.iki.fi/xfrisk/files/${P}.tar.gz"
HOMEPAGE="http://morphy.iki.fi/xfrisk/"
+SRC_URI="http://morphy.iki.fi/xfrisk/files/${P}.tar.gz"
-KEYWORDS="x86 ppc sparc amd64"
LICENSE="GPL-2"
+KEYWORDS="amd64 ppc sparc x86"
SLOT="0"
IUSE=""
@@ -20,16 +19,18 @@ DEPEND="${RDEPEND}
|| ( x11-libs/libXaw virtual/x11 )
>=sys-apps/sed-4"
+S=${WORKDIR}/XFrisk
+
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
sed -i \
-e "s:/usr/local:${GAMES_PREFIX}:" Makefile \
- || die "sed Makefile failed"
+ || die "sed failed"
}
src_install() {
make PREFIX="${D}/${GAMES_PREFIX}" install || die "make install failed"
- dodoc BUGS ChangeLog FAQ TODO || die "dodoc failed"
+ dodoc BUGS ChangeLog FAQ TODO
prepgamesdirs
}
diff --git a/games-board/xgammon/xgammon-0.98.ebuild b/games-board/xgammon/xgammon-0.98.ebuild
index 63fbfe2fb3ad..577e48751230 100644
--- a/games-board/xgammon/xgammon-0.98.ebuild
+++ b/games-board/xgammon/xgammon-0.98.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/xgammon/xgammon-0.98.ebuild,v 1.8 2006/01/29 21:28:01 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/xgammon/xgammon-0.98.ebuild,v 1.9 2006/04/23 06:51:49 mr_bones_ Exp $
inherit eutils
-S="${WORKDIR}/${P}a"
DESCRIPTION="very nice backgammon game for X"
HOMEPAGE="http://fawn.unibw-hamburg.de/steuer/xgammon/xgammon.html"
SRC_URI="http://fawn.unibw-hamburg.de/steuer/xgammon/Downloads/${P}a.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc sparc ~amd64"
+KEYWORDS="~amd64 ppc sparc x86"
IUSE=""
RDEPEND="|| ( x11-libs/libXaw virtual/x11 )"
@@ -20,13 +19,16 @@ DEPEND="${RDEPEND}
x11-misc/imake )
virtual/x11 )"
+S=${WORKDIR}/${P}a
+
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
- epatch "${FILESDIR}/${P}-broken.patch"
- epatch "${FILESDIR}/${P}-config.patch"
- epatch "${FILESDIR}/gcc33.patch"
+ epatch \
+ "${FILESDIR}/${P}-broken.patch" \
+ "${FILESDIR}/${P}-config.patch" \
+ "${FILESDIR}/gcc33.patch"
}
src_compile() {