summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-09-10 08:36:11 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-09-10 08:36:11 +0000
commit0c75bdfc3d5632289603abaf6f14ca791513b7bd (patch)
tree02786a8f8b9c87c2839f9a304b413fcd517e73a8 /games-board/xgammon/xgammon-0.98.ebuild
parentRevision bump - remove pointless dependency on dev-python/libgnomeprint-pytho... (diff)
downloadhistorical-0c75bdfc3d5632289603abaf6f14ca791513b7bd.tar.gz
historical-0c75bdfc3d5632289603abaf6f14ca791513b7bd.tar.bz2
historical-0c75bdfc3d5632289603abaf6f14ca791513b7bd.zip
Respect CFLAGS. Bug #430776
Package-Manager: portage-2.1.11.14/cvs/Linux i686
Diffstat (limited to 'games-board/xgammon/xgammon-0.98.ebuild')
-rw-r--r--games-board/xgammon/xgammon-0.98.ebuild19
1 files changed, 15 insertions, 4 deletions
diff --git a/games-board/xgammon/xgammon-0.98.ebuild b/games-board/xgammon/xgammon-0.98.ebuild
index 22a72e208e37..a3b5098ffac7 100644
--- a/games-board/xgammon/xgammon-0.98.ebuild
+++ b/games-board/xgammon/xgammon-0.98.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/xgammon/xgammon-0.98.ebuild,v 1.14 2010/09/06 08:54:07 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/xgammon/xgammon-0.98.ebuild,v 1.15 2012/09/10 08:36:11 tupone Exp $
EAPI=2
-inherit eutils
+inherit toolchain-funcs eutils
DESCRIPTION="very nice backgammon game for X"
HOMEPAGE="http://fawn.unibw-hamburg.de/steuer/xgammon/xgammon.html"
@@ -33,9 +33,20 @@ src_configure() {
}
src_compile() {
- env PATH=".:${PATH}" emake EXTRA_LDOPTIONS="${LDFLAGS}" || die "emake failed"
+ env PATH=".:${PATH}" emake \
+ EXTRA_LDOPTIONS="${LDFLAGS}" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ CC=$(tc-getCC) \
+ || die "emake failed"
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo "xgammon need helvetica fonts"
+ einfo "They can be loaded emerging media-fonts/font-adobe-100dpi"
+ einfo "or similar. Remember to restart X after loading fonts"
+}