summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 17:46:27 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 17:46:27 +0000
commitfb8c4cf310fc6a66ecddbe48c1b77a183baa6141 (patch)
tree179b6d7697d589a3888e34ab007a4d76082e89ee /games-board/r-katro/r-katro-0.7.0.ebuild
parentChanges to make the eclass more flexible (diff)
downloadhistorical-fb8c4cf310fc6a66ecddbe48c1b77a183baa6141.tar.gz
historical-fb8c4cf310fc6a66ecddbe48c1b77a183baa6141.tar.bz2
historical-fb8c4cf310fc6a66ecddbe48c1b77a183baa6141.zip
board board games
Diffstat (limited to 'games-board/r-katro/r-katro-0.7.0.ebuild')
-rw-r--r--games-board/r-katro/r-katro-0.7.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/games-board/r-katro/r-katro-0.7.0.ebuild b/games-board/r-katro/r-katro-0.7.0.ebuild
new file mode 100644
index 000000000000..2648528c717f
--- /dev/null
+++ b/games-board/r-katro/r-katro-0.7.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/r-katro/r-katro-0.7.0.ebuild,v 1.1 2003/09/10 17:46:27 vapier Exp $
+
+inherit games
+
+DESCRIPTION="3D puzzle game"
+HOMEPAGE="http://f.rodrigo.free.fr/games/r-katro/r-katro.php"
+SRC_URI="http://f.rodrigo.free.fr/r-tech/cmp/addon-module/link/link.php?games/r-katro/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE="nls"
+SLOT="0"
+
+DEPEND=">=x11-libs/qt-3
+ virtual/glut"
+
+src_compile() {
+ egamesconf `use_enable nls` || die
+ emake CXXFLAGS="${CXXFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS NEWS README TODO
+ prepgamesdirs
+}