summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-02-02 09:02:35 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-02-02 09:02:35 +0000
commitc13e9960afb1dde2414ce23d35c799b4779dfbd4 (patch)
tree3c0dcf15952dc077190d0ff8ffc7c6379687025f /games-arcade
parentVersion bump (diff)
downloadhistorical-c13e9960afb1dde2414ce23d35c799b4779dfbd4.tar.gz
historical-c13e9960afb1dde2414ce23d35c799b4779dfbd4.tar.bz2
historical-c13e9960afb1dde2414ce23d35c799b4779dfbd4.zip
Fix --as-needed bug #247300
Package-Manager: portage-2.1.6.4/cvs/Linux 2.6.27-gentoo-r8 x86_64
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/conveysdl/ChangeLog7
-rw-r--r--games-arcade/conveysdl/Manifest4
-rw-r--r--games-arcade/conveysdl/conveysdl-1.3.ebuild12
3 files changed, 12 insertions, 11 deletions
diff --git a/games-arcade/conveysdl/ChangeLog b/games-arcade/conveysdl/ChangeLog
index 4afdc46fcfec..4a60d2097221 100644
--- a/games-arcade/conveysdl/ChangeLog
+++ b/games-arcade/conveysdl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/conveysdl
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/conveysdl/ChangeLog,v 1.6 2007/04/09 21:55:52 welp Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/conveysdl/ChangeLog,v 1.7 2009/02/02 09:02:35 tupone Exp $
+
+ 02 Feb 2009; Alfredo Tupone <tupone@gentoo.org> conveysdl-1.3.ebuild:
+ Fix --as-needed bug #247300 by flameeyes@gentoo.org
09 Apr 2007; Peter Weller <welp@gentoo.org> conveysdl-1.3.ebuild:
Keyworded ~x86-fbsd wrt bug 173405
diff --git a/games-arcade/conveysdl/Manifest b/games-arcade/conveysdl/Manifest
index 0677e9ec2d69..c625e508dbd4 100644
--- a/games-arcade/conveysdl/Manifest
+++ b/games-arcade/conveysdl/Manifest
@@ -1,4 +1,4 @@
DIST conveysdl.1.3.tar 429568 RMD160 dc214567c3d5dd349c03d02005a9b50bc52901e9 SHA1 b4d406b9c837457c3da488c8bae0e3ea6254bf94 SHA256 d0de3f8435b6189d2f40fbe5a28f903fbd46d94b53daf10efa53b879346c81cf
-EBUILD conveysdl-1.3.ebuild 1368 RMD160 f3febea875565f3f56a1325bf72d78ebd5c0f2e7 SHA1 4edbf21a164dd781776e6881d2cc345013c0da13 SHA256 5f5fd0fd1a2804412cf960c5b114212c610f11d53b766110cc11fc11118bb936
-MISC ChangeLog 986 RMD160 514e9f50b7fe8edfe1aea21247b0e1822af59ece SHA1 7f5fe05992d361524893778749e54b6b235d5256 SHA256 058374bb58372136d78210771915359f8049993df7e03c4400a79cd342f6f7fc
+EBUILD conveysdl-1.3.ebuild 1341 RMD160 f50b7ca4239bd9c4864d86333d3d42412f9ac93c SHA1 e1298132b9b5ab4980952daf6d3813f0be90bad3 SHA256 2087c12ea5010bf18d93ded1973e6ff5a2892e471eefc443dffa0e084dc47970
+MISC ChangeLog 1115 RMD160 32fc17ae238d4e9b24ac8bac023392fc6c4833ae SHA1 c835144e0cf64f297ee31d532d9b5a9ea726f584 SHA256 e69596637d883f648887089785d3c63f8ed0e59699f44f7d5454a1b7ad518eed
MISC metadata.xml 158 RMD160 cbd9984bb6b426c8c9cee5022fe0a26261612fea SHA1 be5251fa1dacef5c41b74761bb1c8c54fb633b9e SHA256 1423a4fdd4a79b1728a2056d9e300f7e1074253095d82726218d9e9b953888a3
diff --git a/games-arcade/conveysdl/conveysdl-1.3.ebuild b/games-arcade/conveysdl/conveysdl-1.3.ebuild
index 3b4b1ef6fee5..89a75c7c9dd9 100644
--- a/games-arcade/conveysdl/conveysdl-1.3.ebuild
+++ b/games-arcade/conveysdl/conveysdl-1.3.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/conveysdl/conveysdl-1.3.ebuild,v 1.4 2007/04/09 21:55:52 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/conveysdl/conveysdl-1.3.ebuild,v 1.5 2009/02/02 09:02:35 tupone Exp $
+EAPI=2
inherit eutils toolchain-funcs games
DESCRIPTION="Guide the blob along the conveyer belt collecting the red blobs"
@@ -18,10 +19,7 @@ DEPEND="media-libs/libsdl
S=${WORKDIR}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# Incomplete readme
sed -i \
-e 's:I k:use -nosound to disable sound\n\nI k:' \
@@ -40,7 +38,7 @@ src_compile() {
CFLAGS="${CFLAGS} $(sdl-config --cflags) \
-DDATA_PREFIX=\\\"${GAMES_DATADIR}/${PN}/\\\" \
-DENABLE_SOUND" \
- LDFLAGS="${LDFLAGS} -lSDL_mixer $(sdl-config --libs)" \
+ LDLIBS="-lSDL_mixer $(sdl-config --libs)" \
|| die "emake failed"
}