summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-18 04:39:31 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-18 04:39:31 +0000
commitce9ad3f7f82b24add4d4fbcf4dc55cd3417f00c2 (patch)
treee82588da9ecb556720036d0aa22cff213ff5705b /games-arcade/viruskiller
parentver bump #38523 (diff)
downloadhistorical-ce9ad3f7f82b24add4d4fbcf4dc55cd3417f00c2.tar.gz
historical-ce9ad3f7f82b24add4d4fbcf4dc55cd3417f00c2.tar.bz2
historical-ce9ad3f7f82b24add4d4fbcf4dc55cd3417f00c2.zip
initial ebuild #37642
Diffstat (limited to 'games-arcade/viruskiller')
-rw-r--r--games-arcade/viruskiller/ChangeLog8
-rw-r--r--games-arcade/viruskiller/files/digest-viruskiller-0.11
-rw-r--r--games-arcade/viruskiller/viruskiller-0.1.ebuild46
3 files changed, 55 insertions, 0 deletions
diff --git a/games-arcade/viruskiller/ChangeLog b/games-arcade/viruskiller/ChangeLog
new file mode 100644
index 000000000000..70099d38ad1f
--- /dev/null
+++ b/games-arcade/viruskiller/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-arcade/viruskiller
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/viruskiller/ChangeLog,v 1.1 2004/01/18 04:39:31 vapier Exp $
+
+*viruskiller-0.1 (17 Jan 2004)
+
+ 17 Jan 2004; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Daniel Fullmer <lsmod@hotmail.com> #37642.
diff --git a/games-arcade/viruskiller/files/digest-viruskiller-0.1 b/games-arcade/viruskiller/files/digest-viruskiller-0.1
new file mode 100644
index 000000000000..71fe42a7192a
--- /dev/null
+++ b/games-arcade/viruskiller/files/digest-viruskiller-0.1
@@ -0,0 +1 @@
+MD5 86547ae2e59787f526408c87ca0f9895 viruskiller-0.1-1.tar.gz 2169783
diff --git a/games-arcade/viruskiller/viruskiller-0.1.ebuild b/games-arcade/viruskiller/viruskiller-0.1.ebuild
new file mode 100644
index 000000000000..7e0c7aa44fda
--- /dev/null
+++ b/games-arcade/viruskiller/viruskiller-0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/viruskiller/viruskiller-0.1.ebuild,v 1.1 2004/01/18 04:39:31 vapier Exp $
+
+inherit games
+
+DESCRIPTION="Simple arcade game, shoot'em up style, where you must defend your file system from invading viruses"
+HOMEPAGE="http://www.parallelrealities.co.uk/virusKiller.php"
+SRC_URI="${P}-1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+RESTRICT="fetch"
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ media-libs/sdl-ttf
+ dev-libs/zziplib"
+
+pkg_nofetch() {
+ einfo "Please download ${A} from"
+ einfo "http://www.parallelrealities.co.uk/virusKiller.php#Downloads"
+ einfo "and save the file in ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "/^BINDIR = /s:/$:/bin/:" \
+ -e "/^DOCDIR = /s:doc/.*:doc/${PF}/html/:" \
+ makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR=${D} || die
+ rm ${D}/usr/share/doc/${PF}/html/{README,LICENSE}
+ dodoc doc/README
+ prepgamesdirs
+}