summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-30 08:20:59 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-30 08:20:59 +0000
commit58e33c4b80925dec5f869591752aeba899926fa2 (patch)
tree94bd0fd9e7a357c21a526c28ba69445fba81e6e4 /games-arcade/tuxracer-demo/tuxracer-demo-1.1.ebuild
parentAdded metadata.xml, clarified DESCRIPTION (diff)
downloadhistorical-58e33c4b80925dec5f869591752aeba899926fa2.tar.gz
historical-58e33c4b80925dec5f869591752aeba899926fa2.tar.bz2
historical-58e33c4b80925dec5f869591752aeba899926fa2.zip
initial ebuild
Diffstat (limited to 'games-arcade/tuxracer-demo/tuxracer-demo-1.1.ebuild')
-rw-r--r--games-arcade/tuxracer-demo/tuxracer-demo-1.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-arcade/tuxracer-demo/tuxracer-demo-1.1.ebuild b/games-arcade/tuxracer-demo/tuxracer-demo-1.1.ebuild
new file mode 100644
index 000000000000..5ee15e0ea767
--- /dev/null
+++ b/games-arcade/tuxracer-demo/tuxracer-demo-1.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/tuxracer-demo/tuxracer-demo-1.1.ebuild,v 1.1 2003/10/30 08:20:59 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="race downhill as different artic characters (including Tux!)"
+HOMEPAGE="http://www.tuxracer.com/"
+SRC_URI="tuxracer-demo-${PV}-linux-i386.sh"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* x86"
+RESTRICT="nofetch"
+
+DEPEND="virtual/opengl
+ virtual/glu
+ virtual/x11"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please visit http://www.tuxracer.com/?page=downloads.php"
+ einfo "and download ${A}"
+ einfo "and put the files in ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack_makeself tuxracer-demo-${PV}-linux-i386.sh
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ dodir ${dir}
+
+ exeinto ${dir}
+ doexe bin/x86/glibc-2.1/*
+ insinto ${dir}
+ doins EULA GPL LGPL README Tcl_license language *.tcl
+ cp -r characters courses fonts models music tcllib textures ${D}/${dir}
+
+ dodir ${GAMES_BINDIR}
+ dosym ${dir}/tuxracer-demo ${GAMES_BINDIR}/tuxracer-demo
+
+ prepgamesdirs
+}