summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
commit6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3 (patch)
tree5578c0bf4dcb7768e6bc8e22c99c359d60cb6c8e /games-action/orbz-demo
parentgames action and arcade (diff)
downloadhistorical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.tar.gz
historical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.tar.bz2
historical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.zip
action games !
Diffstat (limited to 'games-action/orbz-demo')
-rw-r--r--games-action/orbz-demo/ChangeLog8
-rw-r--r--games-action/orbz-demo/Manifest3
-rw-r--r--games-action/orbz-demo/files/digest-orbz-demo-2.001
-rw-r--r--games-action/orbz-demo/orbz-demo-2.00.ebuild40
4 files changed, 52 insertions, 0 deletions
diff --git a/games-action/orbz-demo/ChangeLog b/games-action/orbz-demo/ChangeLog
new file mode 100644
index 000000000000..2e65d3517733
--- /dev/null
+++ b/games-action/orbz-demo/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-games/orbz-demo
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/orbz-demo/ChangeLog,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+*orbz-demo-2.00 (07 Jul 2003)
+
+ 07 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me for #22751.
diff --git a/games-action/orbz-demo/Manifest b/games-action/orbz-demo/Manifest
new file mode 100644
index 000000000000..66d4b5d3d3d7
--- /dev/null
+++ b/games-action/orbz-demo/Manifest
@@ -0,0 +1,3 @@
+MD5 495bbe2f48e4f019786236fec699e14d orbz-demo-2.00.ebuild 913
+MD5 273cefc870c3f6d307c114b4385f75d3 files/digest-orbz-demo-2.00 68
+MD5 1abc7c2cb0ccc90ff33756cf12f9197f ChangeLog 357
diff --git a/games-action/orbz-demo/files/digest-orbz-demo-2.00 b/games-action/orbz-demo/files/digest-orbz-demo-2.00
new file mode 100644
index 000000000000..7b5a187dcb6b
--- /dev/null
+++ b/games-action/orbz-demo/files/digest-orbz-demo-2.00
@@ -0,0 +1 @@
+MD5 0f910c9400dcf425738244613daeaf5c orbz_demo_2_00.sh.bin 13591479
diff --git a/games-action/orbz-demo/orbz-demo-2.00.ebuild b/games-action/orbz-demo/orbz-demo-2.00.ebuild
new file mode 100644
index 000000000000..03ed823f3fb0
--- /dev/null
+++ b/games-action/orbz-demo/orbz-demo-2.00.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/orbz-demo/orbz-demo-2.00.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="action/arcade game set in colorful 3D environments"
+HOMEPAGE="http://www.21-6.com/orbz.asp"
+SRC_URI="ftp://ftp5.homelan.com/public/21-6/orbz_demo_${PV/./_}.sh.bin"
+
+LICENSE="ORBZ"
+SLOT="0"
+KEYWORDS="-* x86"
+
+DEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ dodir ${dir} ${GAMES_BINDIR}
+
+ tar -zxf Orbz.tar.gz -C ${D}/${dir} || die "extracting orbz.tar.gz"
+
+ exeinto ${dir}
+ doexe bin/Linux/x86/*
+ dosym ${dir}/orbzdemo ${GAMES_BINDIR}/orbzdemo
+ dosym ${dir}/orbzdemodedicated ${GAMES_BINDIR}/orbzdemodedicated
+
+ insinto ${dir}
+ doins icon.xpm
+
+ dodoc README.txt
+
+ prepgamesdirs
+}