summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-08-26 09:49:54 +0000
committerDan Armak <danarmak@gentoo.org>2002-08-26 09:49:54 +0000
commitde1dc32cd17348c856f249a88e3cc6ae6d2e6e93 (patch)
tree48a4e17e22583852a638d0a7cd2e83d0972c5501 /eclass
parentCleanups (diff)
downloadhistorical-de1dc32cd17348c856f249a88e3cc6ae6d2e6e93.tar.gz
historical-de1dc32cd17348c856f249a88e3cc6ae6d2e6e93.tar.bz2
historical-de1dc32cd17348c856f249a88e3cc6ae6d2e6e93.zip
a few minor fixes and the new kde-new-admin() support (preliminary, in testing but can't break anything unless an ebuild calls it explicitly so i'm committing it)
Diffstat (limited to 'eclass')
-rw-r--r--eclass/kde-functions.eclass20
-rw-r--r--eclass/kde.eclass20
2 files changed, 34 insertions, 6 deletions
diff --git a/eclass/kde-functions.eclass b/eclass/kde-functions.eclass
index c16626d2f5c1..c88ec5582d57 100644
--- a/eclass/kde-functions.eclass
+++ b/eclass/kde-functions.eclass
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde-functions.eclass,v 1.25 2002/08/18 23:54:59 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde-functions.eclass,v 1.26 2002/08/26 09:49:54 danarmak Exp $
# This contains everything except things that modify ebuild variables and functions (e.g. $P, src_compile() etc.)
ECLASS=kde-functions
INHERITED="$INHERITED $ECLASS"
@@ -206,9 +206,11 @@ need-qt() {
debug-print-function $FUNCNAME $*
QTVER="$1"
+ QT=qt
+
case $QTVER in
- 2*) newdepend "=x11-libs/qt-2.3*" ;;
- 3*) newdepend ">=x11-libs/qt-3" ;;
+ 2*) newdepend "=x11-libs/${QT}-2.3*" ;;
+ 3*) newdepend ">=x11-libs/${QT}-3" ;;
*) echo "!!! error: $FUNCNAME() called with invalid parameter: \"$QTVER\", please report bug" && exit 1;;
esac
@@ -220,6 +222,7 @@ set-qtdir() {
debug-print-function $FUNCNAME $*
+
# select 1st element in dot-separated string
IFSBACKUP=$IFS
IFS="."
@@ -231,6 +234,7 @@ set-qtdir() {
export QTDIR="/usr/qt/$QTMAJORVER"
+
}
# returns minimal qt version needed for specified kde version
@@ -315,6 +319,8 @@ kde_sandbox_patch() {
# $2: flag to remove
kde_remove_flag() {
+ debug-print-function $FUNCNAME $*
+
cd ${S}/${1} || die
[ -n "$2" ] || die
@@ -325,3 +331,11 @@ kde_remove_flag() {
cd $OLDPWD
}
+
+
+# get new admin/ files
+kde-new-admin() {
+
+ SRC_URI="$SRC_URI mirror://gentoo/admin-new-20020826.tar.gz"
+
+}
diff --git a/eclass/kde.eclass b/eclass/kde.eclass
index 709af03e94af..b0c26f851b2c 100644
--- a/eclass/kde.eclass
+++ b/eclass/kde.eclass
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.53 2002/08/14 19:45:05 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.54 2002/08/26 09:49:54 danarmak Exp $
# The kde eclass is inherited by all kde-* eclasses. Few ebuilds inherit straight from here.
inherit base kde-functions
ECLASS=kde
@@ -45,7 +45,7 @@ kde_src_compile() {
case $1 in
myconf)
debug-print-section myconf
- myconf="$myconf --prefix=${PREFIX} --host=${CHOST} --with-x --enable-mitshm --with-xinerama --with-qt-dir=${QTDIR}"
+ myconf="$myconf --host=${CHOST} --prefix=${PREFIX} --with-x --enable-mitshm --with-xinerama --with-qt-dir=${QTDIR}"
# calculate dependencies separately from compiling, enables ccache to work on kde compiles
myconf="$myconf --disable-dependency-tracking"
use qtmt && myconf="$myconf --enable-mt"
@@ -56,6 +56,18 @@ kde_src_compile() {
debug-print-section configure
debug-print "$FUNCNAME::configure: myconf=$myconf"
+ # fix the infamous kde-widget problem group and other stuff
+ # by getting a new admin/ dir
+ if [ -d "$WORKDIR/admin-new" ]; then
+
+ cd $S/admin
+ patch -p0 < $WORKDIR/admin-new/*
+ # stop make from regenerating stuff
+ touch -t 199001010000 acinclude.m4.in
+ cd $S
+
+ fi
+
# This can happen with e.g. a cvs snapshot
if [ ! -f "./configure" ]; then
for x in Makefile.cvs admin/Makefile.common; do
@@ -67,12 +79,14 @@ kde_src_compile() {
fi
export PATH="${KDEDIR}/bin:${PATH}"
+
+ cd $S
./configure ${myconf} || die "died running ./configure, $FUNCNAME:configure"
;;
make)
export PATH="${KDEDIR}/bin:${PATH}"
debug-print-section make
- emake || die "died running emake, $FUNCNAME:make"
+ emake || die "died running emake, $FUNCNAME:make"
;;
all)
debug-print-section all