summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2014-11-16 14:37:33 +0000
committerDirkjan Ochtman <djc@gentoo.org>2014-11-16 14:37:33 +0000
commit21339b0c52ae9268e40a9a6cacd846dcb33b036f (patch)
treea3a51d4179a10b8a2ae74e8b509a0d67258a9a1e /dev-vcs
parentFix HOMEPAGE. See bug #501500. (diff)
downloadhistorical-21339b0c52ae9268e40a9a6cacd846dcb33b036f.tar.gz
historical-21339b0c52ae9268e40a9a6cacd846dcb33b036f.tar.bz2
historical-21339b0c52ae9268e40a9a6cacd846dcb33b036f.zip
Version bump hgsubversion to 1.7
Package-Manager: portage-2.2.14/cvs/Linux x86_64 Manifest-Sign-Key: 0x30380381
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/hgsubversion/ChangeLog7
-rw-r--r--dev-vcs/hgsubversion/hgsubversion-1.7.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-vcs/hgsubversion/ChangeLog b/dev-vcs/hgsubversion/ChangeLog
index 169b9979601e..ae18a5458d23 100644
--- a/dev-vcs/hgsubversion/ChangeLog
+++ b/dev-vcs/hgsubversion/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/hgsubversion
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hgsubversion/ChangeLog,v 1.35 2014/08/18 20:07:35 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hgsubversion/ChangeLog,v 1.36 2014/11/16 14:37:33 djc Exp $
+
+*hgsubversion-1.7 (16 Nov 2014)
+
+ 16 Nov 2014; Dirkjan Ochtman <djc@gentoo.org> +hgsubversion-1.7.ebuild:
+ Version bump hgsubversion to 1.7
18 Aug 2014; Dirkjan Ochtman <djc@gentoo.org> -hgsubversion-1.3.ebuild:
Remove old version
diff --git a/dev-vcs/hgsubversion/hgsubversion-1.7.ebuild b/dev-vcs/hgsubversion/hgsubversion-1.7.ebuild
new file mode 100644
index 000000000000..a29ddcf9fb74
--- /dev/null
+++ b/dev-vcs/hgsubversion/hgsubversion-1.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hgsubversion/hgsubversion-1.7.ebuild,v 1.1 2014/11/16 14:37:33 djc Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="hgsubversion is a Mercurial extension for working with Subversion repositories"
+HOMEPAGE="https://bitbucket.org/durin42/hgsubversion/wiki/Home http://pypi.python.org/pypi/hgsubversion"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="test"
+
+# although any ref absent in the source, tests fail badly with >=mercurial-2.8.1
+RDEPEND=">=dev-vcs/mercurial-1.4[${PYTHON_USEDEP}]
+ dev-vcs/mercurial[${PYTHON_USEDEP}]
+ || (
+ >=dev-python/subvertpy-0.7.4[${PYTHON_USEDEP}]
+ >=dev-vcs/subversion-1.5[python] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+DOCS=( README )
+
+#python_test() {
+# "${PYTHON}" tests/run.py || die "Tests failed under ${EPYTHON}"
+#}