summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <jcallen@gentoo.org>2010-06-19 00:31:55 +0000
committerJonathan Callen <jcallen@gentoo.org>2010-06-19 00:31:55 +0000
commitaef52b968ed0fdf1a803fe77d3c307a2ee103987 (patch)
treed0daea00252393bf95a1a4bace6fd643e47b4846 /dev-vcs/cvsps/cvsps-2.1-r1.ebuild
parentMove package from dev-util/cvsgraph to dev-vcs/cvsgraph (diff)
downloadhistorical-aef52b968ed0fdf1a803fe77d3c307a2ee103987.tar.gz
historical-aef52b968ed0fdf1a803fe77d3c307a2ee103987.tar.bz2
historical-aef52b968ed0fdf1a803fe77d3c307a2ee103987.zip
Move package from dev-util/cvsps to dev-vcs/cvsps
Package-Manager: portage-2.2_rc67/cvs/Linux i686 RepoMan-Options: --force
Diffstat (limited to 'dev-vcs/cvsps/cvsps-2.1-r1.ebuild')
-rw-r--r--dev-vcs/cvsps/cvsps-2.1-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-vcs/cvsps/cvsps-2.1-r1.ebuild b/dev-vcs/cvsps/cvsps-2.1-r1.ebuild
new file mode 100644
index 000000000000..8363b3ba8751
--- /dev/null
+++ b/dev-vcs/cvsps/cvsps-2.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvsps/cvsps-2.1-r1.ebuild,v 1.1 2010/06/19 00:31:55 abcd Exp $
+
+inherit eutils
+
+MY_P="${P/_/}"
+DESCRIPTION="Generates patchset information from a CVS repository"
+HOMEPAGE="http://www.cobite.com/cvsps/"
+SRC_URI="http://www.cobite.com/cvsps/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="sys-libs/zlib"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-solaris.patch
+ # no configure around
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ sed -i -e '/^LDLIBS+=/s/$/ -lsocket/' Makefile || die
+ fi
+}
+
+src_install() {
+ dobin cvsps || die
+ doman cvsps.1
+ dodoc README CHANGELOG
+}