summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-12-27 14:42:55 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-12-27 14:42:55 +0000
commit68abdf99bb31e81f54830ed405fa785ad7f3eeab (patch)
treec01fe2caf93aaf06e8963fc54d7146cd7879e4d3 /dev-util
parentBump, remove old (diff)
downloadhistorical-68abdf99bb31e81f54830ed405fa785ad7f3eeab.tar.gz
historical-68abdf99bb31e81f54830ed405fa785ad7f3eeab.tar.bz2
historical-68abdf99bb31e81f54830ed405fa785ad7f3eeab.zip
clean up and silently propagate ppc64 keyword
Package-Manager: portage-2.1.6.13/cvs/Linux i686
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/bzr/ChangeLog6
-rw-r--r--dev-util/bzr/bzr-1.15.1.ebuild131
-rw-r--r--dev-util/bzr/bzr-1.18.ebuild129
-rw-r--r--dev-util/bzr/bzr-2.0.0.ebuild124
-rw-r--r--dev-util/bzr/bzr-2.1.0_beta1.ebuild4
-rw-r--r--dev-util/bzrtools/Manifest18
6 files changed, 18 insertions, 394 deletions
diff --git a/dev-util/bzr/ChangeLog b/dev-util/bzr/ChangeLog
index bcd5b9943b19..390debc92321 100644
--- a/dev-util/bzr/ChangeLog
+++ b/dev-util/bzr/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/bzr
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/ChangeLog,v 1.118 2009/12/27 14:37:37 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/ChangeLog,v 1.119 2009/12/27 14:42:55 fauli Exp $
+
+ 27 Dec 2009; Christian Faulhammer <fauli@gentoo.org> -bzr-1.15.1.ebuild,
+ -bzr-1.18.ebuild, -bzr-2.0.0.ebuild, bzr-2.1.0_beta1.ebuild:
+ clean up and silently propagate ppc64 keyword
*bzr-2.0.3 (27 Dec 2009)
diff --git a/dev-util/bzr/bzr-1.15.1.ebuild b/dev-util/bzr/bzr-1.15.1.ebuild
deleted file mode 100644
index 681d1f56d69f..000000000000
--- a/dev-util/bzr/bzr-1.15.1.ebuild
+++ /dev/null
@@ -1,131 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/bzr-1.15.1.ebuild,v 1.6 2009/09/29 23:48:02 jer Exp $
-
-EAPI=1
-
-NEED_PYTHON=2.4
-
-inherit distutils bash-completion elisp-common eutils versionator
-
-MY_PV=${PV/_rc/rc}
-MY_P=${PN}-${MY_PV}
-SERIES=$(get_version_component_range 1-2)
-
-DESCRIPTION="Bazaar is a next generation distributed version control system."
-HOMEPAGE="http://bazaar-vcs.org/"
-#SRC_URI="http://bazaar-vcs.org/releases/src/${MY_P}.tar.gz"
-SRC_URI="http://launchpad.net/bzr/${SERIES}/${MY_PV}/+download/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ~ia64 ppc sparc x86 ~x86-fbsd"
-IUSE="curl doc emacs +sftp test"
-
-RDEPEND="|| ( >=dev-lang/python-2.5 dev-python/celementtree )
- curl? ( dev-python/pycurl )
- sftp? ( dev-python/paramiko )"
-
-DEPEND="emacs? ( virtual/emacs )
- test? (
- $RDEPEND
- dev-python/medusa
- )"
-
-S="${WORKDIR}/${MY_P}"
-PYTHON_MODNAME="bzrlib"
-SITEFILE=71bzr-gentoo.el
-DOCS="doc/*.txt"
-
-src_unpack() {
- distutils_src_unpack
-
- # Don't regenerate .c files from .pyx when pyrex is found.
- epatch "${FILESDIR}/${PN}-1.8-no-pyrex.patch"
- # Don't run lock permission tests when running as root
- epatch "${FILESDIR}/${PN}-0.90-tests-fix_root.patch"
- # Fix permission errors when run under directories with setgid set.
- epatch "${FILESDIR}/${PN}-0.90-tests-sgid.patch"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use emacs; then
- elisp-compile contrib/emacs/bzr-mode.el || die "Emacs modules failed!"
- fi
-}
-
-src_install() {
- distutils_src_install --install-data /usr/share
-
- if use doc; then
- docinto developers
- dodoc doc/developers/* || die "dodoc failed"
- for doc in mini-tutorial tutorials user-{guide,reference}; do
- docinto $doc
- dodoc doc/en/$doc/* || die "dodoc failed"
- done
- fi
-
- if use emacs; then
- elisp-install ${PN} contrib/emacs/*.el* || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die "elisp-site-file-install failed"
-
- # don't add automatically to the load-path, so the sitefile
- # can do a conditional loading
- touch "${D}${SITELISP}/${PN}/.nosearch"
- fi
-
- insinto /usr/share/zsh/site-functions
- doins contrib/zsh/_bzr
- dobashcompletion contrib/bash/bzr
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- bash-completion_pkg_postinst
-
- if use emacs; then
- elisp-site-regen
- elog "If you are using a GNU Emacs version greater than 22.1, bzr support"
- elog "is already included. This ebuild does not automatically activate bzr support"
- elog "in versions below, but prepares it in a way you can load it from your ~/.emacs"
- elog "file by adding"
- elog " (load \"bzr-mode\")"
- fi
-}
-
-pkg_postrm() {
- distutils_pkg_postrm
- use emacs && elisp-site-regen
-}
-
-src_test() {
- export LC_ALL=C
- # Define tests which are known to fail below.
- local skip_tests="("
- # https://bugs.launchpad.net/bzr/+bug/306264
- skip_tests+="test_http.SmartHTTPTunnellingTest*|"
- skip_tests+="test_http.TestWallServer.test_http_*|"
- skip_tests+="blackbox.test_too_much.SFTPTestsRelative.test_*|"
- # https://bugs.launchpad.net/bzr/+bug/383920
- skip_tests+="test_transport_implementations.TransportTests.test_get*|"
- # This tests were fixed in trunk. Drop in 1.15.x or 1.16
- skip_tests+="bzrlib.tests.test_http.TestActivity*|"
- #skip_tests+="bzrlib.tests.tree_implementations.test_get_file_mtime*|"
- #skip_tests+="test_source.TestSource.test_no_asserts*|"
- #https://bugs.launchpad.net/bzr/+bug/341648
- skip_tests+="test_osutils.TestWalkDirs.test_walkdirs_os_error"
- skip_tests+=")"
- # Some tests expect the usual pyc compiling behaviour.
- python_enable_pyc
- if [[ -n ${skip_tests} ]]; then
- einfo "Skipping tests known to fail: ${skip_tests}"
- "${python}" bzr --no-plugins selftest -x ${skip_tests} || die "bzr selftest failed"
- else
- "${python}" bzr --no-plugins selftest || die "bzr selftest failed"
- fi
- # Just to make sure we don't hit any errors on later stages.
- python_disable_pyc
-}
diff --git a/dev-util/bzr/bzr-1.18.ebuild b/dev-util/bzr/bzr-1.18.ebuild
deleted file mode 100644
index a435966a58bd..000000000000
--- a/dev-util/bzr/bzr-1.18.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/bzr-1.18.ebuild,v 1.2 2009/09/29 23:48:02 jer Exp $
-
-EAPI=1
-
-NEED_PYTHON=2.4
-
-inherit distutils bash-completion elisp-common eutils versionator
-
-MY_PV=${PV/_rc/rc}
-MY_P=${PN}-${MY_PV}
-SERIES=$(get_version_component_range 1-2)
-
-DESCRIPTION="Bazaar is a next generation distributed version control system."
-HOMEPAGE="http://bazaar-vcs.org/"
-#SRC_URI="http://bazaar-vcs.org/releases/src/${MY_P}.tar.gz"
-SRC_URI="http://launchpad.net/bzr/${SERIES}/${MY_PV}/+download/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
-IUSE="curl doc emacs +sftp test"
-
-RDEPEND="|| ( >=dev-lang/python-2.5 dev-python/celementtree )
- curl? ( dev-python/pycurl )
- sftp? ( dev-python/paramiko )"
-
-DEPEND="emacs? ( virtual/emacs )
- test? (
- $RDEPEND
- dev-python/medusa
- )"
-
-S="${WORKDIR}/${MY_P}"
-PYTHON_MODNAME="bzrlib"
-SITEFILE=71bzr-gentoo.el
-DOCS="doc/*.txt"
-
-src_unpack() {
- distutils_src_unpack
-
- # Don't regenerate .c files from .pyx when pyrex is found.
- epatch "${FILESDIR}/${PN}-1.8-no-pyrex.patch"
- # Don't run lock permission tests when running as root
- epatch "${FILESDIR}/${PN}-0.90-tests-fix_root.patch"
- # Fix permission errors when run under directories with setgid set.
- epatch "${FILESDIR}/${PN}-0.90-tests-sgid.patch"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use emacs; then
- elisp-compile contrib/emacs/bzr-mode.el || die "Emacs modules failed!"
- fi
-}
-
-src_install() {
- distutils_src_install --install-data /usr/share
-
- if use doc; then
- docinto developers
- dodoc doc/developers/* || die "dodoc failed"
- for doc in mini-tutorial tutorials user-{guide,reference}; do
- docinto $doc
- dodoc doc/en/$doc/* || die "dodoc failed"
- done
- fi
-
- if use emacs; then
- elisp-install ${PN} contrib/emacs/*.el* || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die "elisp-site-file-install failed"
-
- # don't add automatically to the load-path, so the sitefile
- # can do a conditional loading
- touch "${D}${SITELISP}/${PN}/.nosearch"
- fi
-
- insinto /usr/share/zsh/site-functions
- doins contrib/zsh/_bzr
- dobashcompletion contrib/bash/bzr
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- bash-completion_pkg_postinst
-
- if use emacs; then
- elisp-site-regen
- elog "If you are using a GNU Emacs version greater than 22.1, bzr support"
- elog "is already included. This ebuild does not automatically activate bzr support"
- elog "in versions below, but prepares it in a way you can load it from your ~/.emacs"
- elog "file by adding"
- elog " (load \"bzr-mode\")"
- fi
-}
-
-pkg_postrm() {
- distutils_pkg_postrm
- use emacs && elisp-site-regen
-}
-
-src_test() {
- export LC_ALL=C
- # Define tests which are known to fail below.
- local skip_tests="("
- # https://bugs.launchpad.net/bzr/+bug/306264
- skip_tests+="test_http.SmartHTTPTunnellingTest*|"
- skip_tests+="test_http.TestWallServer.test_http_*|"
- skip_tests+="blackbox.test_too_much.SFTPTestsRelative.test_*|"
- # !!! FIXED in 1.17 https://bugs.launchpad.net/bzr/+bug/383920
- skip_tests+="test_transport_implementations.TransportTests.test_get*|"
- # https://bugs.launchpad.net/bzr/+bug/392127
- skip_tests+="test_http.*|"
- #https://bugs.launchpad.net/bzr/+bug/341648
- skip_tests+="test_osutils.TestWalkDirs.test_walkdirs_os_error"
- skip_tests+=")"
- # Some tests expect the usual pyc compiling behaviour.
- python_enable_pyc
- if [[ -n ${skip_tests} ]]; then
- einfo "Skipping tests known to fail: ${skip_tests}"
- "${python}" bzr --no-plugins selftest -x ${skip_tests} || die "bzr selftest failed"
- else
- "${python}" bzr --no-plugins selftest || die "bzr selftest failed"
- fi
- # Just to make sure we don't hit any errors on later stages.
- python_disable_pyc
-}
diff --git a/dev-util/bzr/bzr-2.0.0.ebuild b/dev-util/bzr/bzr-2.0.0.ebuild
deleted file mode 100644
index 910ffae58c1d..000000000000
--- a/dev-util/bzr/bzr-2.0.0.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/bzr-2.0.0.ebuild,v 1.3 2009/10/06 17:30:34 pva Exp $
-
-EAPI=1
-
-NEED_PYTHON=2.4
-
-inherit distutils bash-completion elisp-common eutils versionator
-
-MY_PV=${PV/_rc/rc}
-MY_P=${PN}-${MY_PV}
-SERIES=$(get_version_component_range 1-2)
-
-DESCRIPTION="Bazaar is a next generation distributed version control system."
-HOMEPAGE="http://bazaar-vcs.org/"
-#SRC_URI="http://bazaar-vcs.org/releases/src/${MY_P}.tar.gz"
-SRC_URI="http://launchpad.net/bzr/${SERIES}/${MY_PV}/+download/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
-IUSE="curl doc emacs +sftp test"
-
-RDEPEND="|| ( >=dev-lang/python-2.5 dev-python/celementtree )
- curl? ( dev-python/pycurl )
- sftp? ( dev-python/paramiko )"
-
-DEPEND="emacs? ( virtual/emacs )
- test? (
- $RDEPEND
- dev-python/medusa
- )"
-
-S="${WORKDIR}/${MY_P}"
-PYTHON_MODNAME="bzrlib"
-SITEFILE=71bzr-gentoo.el
-DOCS="doc/*.txt"
-
-src_unpack() {
- distutils_src_unpack
-
- # Don't regenerate .c files from .pyx when pyrex is found.
- epatch "${FILESDIR}/${PN}-1.8-no-pyrex.patch"
- # Don't run lock permission tests when running as root
- epatch "${FILESDIR}/${PN}-0.90-tests-fix_root.patch"
- # Fix permission errors when run under directories with setgid set.
- epatch "${FILESDIR}/${PN}-0.90-tests-sgid.patch"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use emacs; then
- elisp-compile contrib/emacs/bzr-mode.el || die "Emacs modules failed!"
- fi
-}
-
-src_install() {
- distutils_src_install --install-data /usr/share
-
- if use doc; then
- docinto developers
- dodoc doc/developers/* || die "dodoc failed"
- for doc in mini-tutorial tutorials user-{guide,reference}; do
- docinto $doc
- dodoc doc/en/$doc/* || die "dodoc failed"
- done
- fi
-
- if use emacs; then
- elisp-install ${PN} contrib/emacs/*.el* || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die "elisp-site-file-install failed"
-
- # don't add automatically to the load-path, so the sitefile
- # can do a conditional loading
- touch "${D}${SITELISP}/${PN}/.nosearch"
- fi
-
- insinto /usr/share/zsh/site-functions
- doins contrib/zsh/_bzr
- dobashcompletion contrib/bash/bzr
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- bash-completion_pkg_postinst
-
- if use emacs; then
- elisp-site-regen
- elog "If you are using a GNU Emacs version greater than 22.1, bzr support"
- elog "is already included. This ebuild does not automatically activate bzr support"
- elog "in versions below, but prepares it in a way you can load it from your ~/.emacs"
- elog "file by adding"
- elog " (load \"bzr-mode\")"
- fi
-}
-
-pkg_postrm() {
- distutils_pkg_postrm
- use emacs && elisp-site-regen
-}
-
-src_test() {
- export LC_ALL=C
- # Define tests which are known to fail below.
- local skip_tests="("
- # Not reproducible in current dev version, so check and drop with version
- # bump
- skip_tests+="bzrlib.tests.test_osutils.TestWalkDirs|"
- # https://bugs.launchpad.net/bzr/+bug/392127
- skip_tests+="test_http.*"
- skip_tests+=")"
- # Some tests expect the usual pyc compiling behaviour.
- python_enable_pyc
- if [[ -n ${skip_tests} ]]; then
- einfo "Skipping tests known to fail: ${skip_tests}"
- "${python}" bzr --no-plugins selftest -x ${skip_tests} || die "bzr selftest failed"
- else
- "${python}" bzr --no-plugins selftest || die "bzr selftest failed"
- fi
- # Just to make sure we don't hit any errors on later stages.
- python_disable_pyc
-}
diff --git a/dev-util/bzr/bzr-2.1.0_beta1.ebuild b/dev-util/bzr/bzr-2.1.0_beta1.ebuild
index e14dd40755fa..19f49106a898 100644
--- a/dev-util/bzr/bzr-2.1.0_beta1.ebuild
+++ b/dev-util/bzr/bzr-2.1.0_beta1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/bzr-2.1.0_beta1.ebuild,v 1.1 2009/10/20 17:05:38 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/bzr-2.1.0_beta1.ebuild,v 1.2 2009/12/27 14:42:55 fauli Exp $
EAPI=1
@@ -20,7 +20,7 @@ SRC_URI="http://launchpad.net/bzr/${SERIES}/${MY_PV}/+download/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="curl doc emacs +sftp test"
RDEPEND="|| ( >=dev-lang/python-2.5 dev-python/celementtree )
diff --git a/dev-util/bzrtools/Manifest b/dev-util/bzrtools/Manifest
index d28de370b5f8..7dbe9188b5a7 100644
--- a/dev-util/bzrtools/Manifest
+++ b/dev-util/bzrtools/Manifest
@@ -1,11 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
AUX bzrtools-1.15.0-test_fetch_ghosts.patch 1168 RMD160 eb321dfbbf4160e17bf5437cfbca00112f328801 SHA1 e970a60e70db627477776b25c984d64a2c279f6c SHA256 04fa9459f7e4a14c19b8ba04425ec907a9772bad8738069f1bb8b3c9c11e7c6b
-DIST bzrtools-1.15.0.tar.gz 69839 RMD160 8b75fb9d43fac5c5fdfa56a1885afa1a1358e952 SHA1 4009b1197a502836973236efbbcf11a18ca54ff8 SHA256 53dd25d35c726230897f823d5b130e768fb31a77ae2d153b2221080f4ffce6b7
-DIST bzrtools-1.18.0.tar.gz 71110 RMD160 d488c066b5d51685ddc29d27b00c25da15d73ba8 SHA1 9bdaef12a71a3b00839ba1f35da3ba3f2b4aef30 SHA256 2841228544ce6169d347c75a25d3c9b26fa3c406e1197c21236bcec8b59ec523
-DIST bzrtools-2.0.0.tar.gz 71146 RMD160 f3103354268516756ff918ad2b945530a53c5a9b SHA1 40582a00ffd164d5c3e955b2551043dbfbe74e46 SHA256 11ef4838ed3619903d22e6b73b66e441e6894db15043ca2fe435df0c4d883676
DIST bzrtools-2.0.1.tar.gz 71371 RMD160 9350f23f6d8ab3ed0d38e30499b4574b9af004c8 SHA1 3f980e50bc8d458e26cbad23ae8c979a56bc4893 SHA256 0dffad46808490b0825c201719f61c77d91a360853abaf229c4ca5c05ab24d54
-EBUILD bzrtools-1.15.0.ebuild 1512 RMD160 b3ad69425e60476308829a563d5c65a568e9ecbe SHA1 77783bb119cbd036defdc6e646bbde80c6cfda87 SHA256 56723b8974af86745bf46638de2a3cbee3dabd3ab55b461e38fbf9dde768ca4c
-EBUILD bzrtools-1.18.0.ebuild 1443 RMD160 cdb531803f87b9f2e27878fb8d9c1b876395c8de SHA1 281f81e0e08e77b077ad465b334dd257ea3632bf SHA256 e07884bb46d6b50a82325ad884b2f5b2a5bebf1dc43e2ab02b6d75faf62901ba
-EBUILD bzrtools-2.0.0.ebuild 1438 RMD160 bb208c0c97662fd025aacb8125cb4c5a399436ee SHA1 bbf171fc292bd0c7cf03d5a8be3edf63ff30dcb3 SHA256 cba8761e456d25c9d184e090d9eb8955c8d952b9f848da7cf7443070473148f7
EBUILD bzrtools-2.0.1.ebuild 1484 RMD160 1f307e371112f321f992c08faa9ff888c29796b7 SHA1 39bd8b9f5f3e38947a0de70ce140294393ec2269 SHA256 1b4b0e1f249332ed278a7072608c3c37f6584e4f6ac9a2dc89f8251043e933ac
-MISC ChangeLog 9822 RMD160 45fc20054a6176f3d7b5ad63838df6378473cfd0 SHA1 5670e6d6f2c55c197f6f5acc77b272cd85184524 SHA256 c6cd1212a73054d784ad33ebcbe4d1b95d7dd72103b1a55272f4a5d59ca13fc9
+MISC ChangeLog 9963 RMD160 257b9d8f4759da57eb62738364c860bdcc5556d0 SHA1 a1b16cfe937898dfb9bf6d7cf820f7a6540ce46b SHA256 a13ef134de497a1606e96ea9f32399c7cb65d2695a99472ee4258ef02b7aff62
MISC metadata.xml 361 RMD160 d77927c9c34f5be7b754769f90913041627e96ac SHA1 1e201037cbce92208e6b0cbd129963e59b2a6cd5 SHA256 44e6fd2572b23364bbb2fc284d1c4edb708452f2fbe93f9f6465d5dcc10c28ec
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.11 (GNU/Linux)
+
+iEYEARECAAYFAks3c30ACgkQNQqtfCuFneNnjQCeKMOTma7DPiTBTicMaOs1VNXn
+nQ0An3f6QVomHupoyW6l8uzugVO7VahQ
+=+tjX
+-----END PGP SIGNATURE-----