summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-06-28 07:07:03 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-06-28 07:07:03 +0000
commit56fb14af4ec7b552aaa56436f21862a545f7c13a (patch)
treee36b9b4cc2ada4c3bf7768517a9c5fb1f194d7f2 /dev-util/wiggle/wiggle-0.6-r1.ebuild
parentAdded ~amd64. (diff)
downloadhistorical-56fb14af4ec7b552aaa56436f21862a545f7c13a.tar.gz
historical-56fb14af4ec7b552aaa56436f21862a545f7c13a.tar.bz2
historical-56fb14af4ec7b552aaa56436f21862a545f7c13a.zip
revision bump, cleanup.
Diffstat (limited to 'dev-util/wiggle/wiggle-0.6-r1.ebuild')
-rw-r--r--dev-util/wiggle/wiggle-0.6-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-util/wiggle/wiggle-0.6-r1.ebuild b/dev-util/wiggle/wiggle-0.6-r1.ebuild
new file mode 100644
index 000000000000..308417a1eb74
--- /dev/null
+++ b/dev-util/wiggle/wiggle-0.6-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/wiggle/wiggle-0.6-r1.ebuild,v 1.1 2004/06/28 07:07:03 robbat2 Exp $
+
+inherit eutils
+
+IUSE=""
+
+S=${WORKDIR}/${P}
+
+PATCHDATE=20040627
+PATCHBALL=${P}-patches-${PATCHDATE}
+
+DESCRIPTION="Wiggle is a program for applying patches that patch cannot apply because of conflicting changes"
+HOMEPAGE="http://cgi.cse.unsw.edu.au/~neilb/source/wiggle/"
+SRC_URI="http://cgi.cse.unsw.edu.au/~neilb/source/wiggle/${P}.tar.gz
+ mirror://gentoo/${PATCHBALL}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+# The 'p' tool does support bitkeeper, but I'm against just dumping it in here
+# due to it's size. I've explictly listed every other dependancy here due to
+# the nature of the shell program 'p'
+RDEPEND="dev-util/diffstat
+ dev-util/patchutils
+ sys-apps/diffutils
+ sys-apps/findutils
+ sys-apps/gawk
+ sys-apps/grep
+ sys-apps/less
+ sys-apps/sed
+ sys-apps/coreutils
+ sys-devel/patch"
+
+DEPEND="${RDEPEND}
+ sys-apps/groff
+ sys-apps/time"
+
+PATCHLIST="001NoQuietTime 002SpecFile 003Recommit 004ExtractFix 005Pchanges"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ for i in ${PATCHLIST}; do
+ epatch ${WORKDIR}/${PATCHBALL}/${i}
+ done;
+}
+
+src_compile() {
+ emake OptDbg="${CFLAGS}" || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ into /usr
+ dobin p
+ dodoc ANNOUNCE COPYING INSTALL TODO DOC/diff.ps p.help notes
+}