summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2006-09-17 16:49:18 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2006-09-17 16:49:18 +0000
commitdea625e7e15bd9e82a1ef76a367f29cfaea5f11c (patch)
tree1ec691df9fbfe901d1daa341a638c8a8b1d33a84 /dev-util/valgrind/valgrind-3.2.1.ebuild
parent* bump, stabilization (diff)
downloadhistorical-dea625e7e15bd9e82a1ef76a367f29cfaea5f11c.tar.gz
historical-dea625e7e15bd9e82a1ef76a367f29cfaea5f11c.tar.bz2
historical-dea625e7e15bd9e82a1ef76a367f29cfaea5f11c.zip
Added valgrind-3.2.1, fixed bug #147904 and added ~ppc64.
Package-Manager: portage-2.1.2_pre1
Diffstat (limited to 'dev-util/valgrind/valgrind-3.2.1.ebuild')
-rw-r--r--dev-util/valgrind/valgrind-3.2.1.ebuild86
1 files changed, 86 insertions, 0 deletions
diff --git a/dev-util/valgrind/valgrind-3.2.1.ebuild b/dev-util/valgrind/valgrind-3.2.1.ebuild
new file mode 100644
index 000000000000..99fd81ea1c27
--- /dev/null
+++ b/dev-util/valgrind/valgrind-3.2.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/valgrind-3.2.1.ebuild,v 1.1 2006/09/17 16:49:18 griffon26 Exp $
+
+inherit autotools eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="An open-source memory debugger for GNU/Linux"
+HOMEPAGE="http://www.valgrind.org"
+SRC_URI="http://www.valgrind.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="X"
+
+# bug #49147 (bogus stacktrace in gdb with --db-attach=yes) does not seem to be applicable anymore
+#RESTRICT="strip"
+
+RDEPEND="!dev-util/callgrind"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # make sure our CFLAGS are respected
+ einfo "Changing configure.in to respect CFLAGS"
+ sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.in
+
+ # undefined references to __guard and __stack_smash_handler in VEX (bug #114347)
+ einfo "Changing Makefile.flags.am to disable SSP"
+ sed -i -e 's:^AM_CFLAGS_BASE = :AM_CFLAGS_BASE = -fno-stack-protector :' Makefile.flags.am
+
+ # Correct hard coded doc location
+ sed -i -e "s:doc/valgrind:doc/${P}:" docs/Makefile.am
+
+ # Fix undefined reference to @VG_PLATFORM@ (bug #147904)
+ epatch "${FILESDIR}/${P}-pkg-config.patch"
+
+ # Remove defaulting to ppc32-linux on ppc64 without multilib
+ # "valgrind: failed to start tool 'memcheck' for platform 'ppc32-linux':
+ # No such file or directory"
+ if use ppc64 && ! has_multilib_profile; then
+ epatch "${FILESDIR}/${P}-only64bit.patch"
+ fi
+
+ # Regenerate autotools files
+ eautoreconf
+}
+
+src_compile() {
+ local myconf
+
+ # -fomit-frame-pointer "Assembler messages: Error: junk `8' after expression"
+ # while compiling insn_sse.c in none/tests/x86
+ # -fpie valgrind seemingly hangs when built with pie on
+ # amd64 (bug #102157)
+ # -fstack-protector more undefined references to __guard and __stack_smash_handler
+ # because valgrind doesn't link to glibc (bug #114347)
+ # -ggdb3 segmentation fault on startup
+ filter-flags -fomit-frame-pointer
+ filter-flags -fpie
+ filter-flags -fstack-protector
+ replace-flags -ggdb3 -ggdb2
+
+ # gcc 3.3.x fails to compile valgrind with -O3 (bug #129776)
+ if [ "$(gcc-version)" == "3.3" ] && is-flagq -O3; then
+ ewarn "GCC 3.3 cannot compile valgrind with -O3 in CFLAGS, using -O2 instead."
+ replace-flags -O3 -O2
+ fi
+
+ # Optionally build in X suppression files
+ use X && myconf="--with-x" || myconf="--with-x=no"
+
+ if use amd64 || use ppc64; then
+ ! has_multilib_profile && myconf="${myconf} --enable-only64bit"
+ fi
+
+ econf ${myconf} || die "Configure failed!"
+ emake || die "Make failed!"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Install failed!"
+ dodoc ACKNOWLEDGEMENTS AUTHORS FAQ.txt NEWS README*
+}
+