summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-07-17 08:37:26 +0000
committerNick Hadaway <raker@gentoo.org>2003-07-17 08:37:26 +0000
commit5cc1a63092a65b91e262e510bf7209efef0ff5b0 (patch)
tree1978d664bedb051fc34cc2fa7ecc007fcf1c411c /dev-util/source-highlight/source-highlight-1.7.ebuild
parentfixed scribus download location (diff)
downloadhistorical-5cc1a63092a65b91e262e510bf7209efef0ff5b0.tar.gz
historical-5cc1a63092a65b91e262e510bf7209efef0ff5b0.tar.bz2
historical-5cc1a63092a65b91e262e510bf7209efef0ff5b0.zip
New ebuild.
Diffstat (limited to 'dev-util/source-highlight/source-highlight-1.7.ebuild')
-rw-r--r--dev-util/source-highlight/source-highlight-1.7.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/source-highlight/source-highlight-1.7.ebuild b/dev-util/source-highlight/source-highlight-1.7.ebuild
new file mode 100644
index 000000000000..6179e4166326
--- /dev/null
+++ b/dev-util/source-highlight/source-highlight-1.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/source-highlight/source-highlight-1.7.ebuild,v 1.1 2003/07/17 08:37:26 raker Exp $
+
+IUSE=""
+
+DESCRIPTION="Generate highlighted source code as an (x)html document"
+SRC_URI="ftp://ftp.gnu.org/gnu/source-highlight/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/src-highlite/source-highlight.html"
+
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+
+DEPEND="virtual/glibc"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install () {
+ cd ${S}/src
+ dobin source-highlight cpp2html java2html source-highlight-cgi
+ dodir /usr/share/source-highlight
+ insinto /usr/share/source-highlight
+ doins tags.j2h tags2.j2h
+
+ cd ${S}/doc
+ dohtml *.html *.css *.java
+ doman source-highlight.1
+
+ dodoc AUTHORS ChangeLog COPYING CREDITS INSTALL \
+ NEWS README THANKS TODO.txt
+}
+