summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-14 10:19:20 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-14 10:19:20 +0000
commitbf81cf1568ce7e43533672ecd3c27a31202eb045 (patch)
treee1488ec1a03bfb0ebfd9e75909cb0c2710569425 /dev-util/nvidia-cuda-sdk/nvidia-cuda-sdk-4.1.ebuild
parentsci-libs/vtk: Solve problems with USE=examples, #447146 (diff)
downloadhistorical-bf81cf1568ce7e43533672ecd3c27a31202eb045.tar.gz
historical-bf81cf1568ce7e43533672ecd3c27a31202eb045.tar.bz2
historical-bf81cf1568ce7e43533672ecd3c27a31202eb045.zip
dev-util/nvidia-cuda-sdk: Version Bump; drop old
Package-Manager: portage-2.2.0_alpha151/cvs/Linux x86_64 Manifest-Sign-Key: 0x70EB7916
Diffstat (limited to 'dev-util/nvidia-cuda-sdk/nvidia-cuda-sdk-4.1.ebuild')
-rw-r--r--dev-util/nvidia-cuda-sdk/nvidia-cuda-sdk-4.1.ebuild92
1 files changed, 0 insertions, 92 deletions
diff --git a/dev-util/nvidia-cuda-sdk/nvidia-cuda-sdk-4.1.ebuild b/dev-util/nvidia-cuda-sdk/nvidia-cuda-sdk-4.1.ebuild
deleted file mode 100644
index 6720501827ee..000000000000
--- a/dev-util/nvidia-cuda-sdk/nvidia-cuda-sdk-4.1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/nvidia-cuda-sdk/nvidia-cuda-sdk-4.1.ebuild,v 1.3 2012/02/05 16:39:02 spock Exp $
-
-EAPI=2
-
-inherit unpacker toolchain-funcs
-
-DESCRIPTION="NVIDIA CUDA Software Development Kit"
-HOMEPAGE="http://developer.nvidia.com/cuda"
-
-CUDA_V=${PV//_/-}
-DIR_V=${CUDA_V//./_}
-DIR_V=${DIR_V//beta/Beta}
-
-SRC_URI="http://developer.download.nvidia.com/compute/cuda/${DIR_V}/rel/sdk/gpucomputingsdk_${CUDA_V}.28_linux.run"
-LICENSE="CUDPP"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug +doc +examples opencl +cuda"
-
-RDEPEND=">=dev-util/nvidia-cuda-toolkit-4.1
- examples? ( >=x11-drivers/nvidia-drivers-260.19.21 )
- media-libs/freeglut"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}"
-
-RESTRICT="binchecks"
-
-pkg_setup() {
- if use cuda || use opencl && [ $(gcc-major-version) -lt 4 -o $(gcc-minor-version) -lt 5 ]; then
- eerror "This package requires >=sys-devel/gcc-4.5 to build sucessfully."
- eerror "Please use gcc-config to switch to a compatible GCC version."
- die ">=sys-devel/gcc-4.4 required"
- fi
- echo $(gcc-major-version) $(gcc-minor-version)
-}
-
-src_compile() {
- if ! use examples; then
- return
- fi
- local myopts=""
-
- if use debug; then
- myopts="${myopts} dbg=1"
- fi
-
- cd "${S}/sdk"
-
- if use cuda; then
- cd C
- emake cuda-install=/opt/cuda ${myopts} || die
- cd ..
- fi
-
- if use opencl; then
- cd OpenCL
- emake || die
- cd ..
- fi
-}
-
-src_install() {
- cd "${S}/sdk"
-
- if ! use doc; then
- rm -rf *.txt doc */doc */Samples.htm */releaseNotesData
- fi
-
- if ! use examples; then
- rm -rf bin */bin */tools
- fi
-
- for f in $(find .); do
- local t="$(dirname ${f})"
- if [[ "${t/obj\/}" != "${t}" || "${t##*.}" == "a" ]]; then
- continue
- fi
-
- if [[ ! -d "${f}" ]]; then
- if [[ -x "${f}" ]]; then
- exeinto "/opt/cuda/sdk/${t}"
- doexe "${f}"
- else
- insinto "/opt/cuda/sdk/${t}"
- doins "${f}"
- fi
- fi
- done
-}