summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-02-25 13:49:22 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-02-25 13:49:22 +0000
commit1ea509ead6bf61e89e76e8725f233963337432fa (patch)
treede3783daee2cc62ef6a579a51e9aa22c0732fee7 /dev-util/monodevelop-debugger-gdb
parentRemoved old version (diff)
downloadhistorical-1ea509ead6bf61e89e76e8725f233963337432fa.tar.gz
historical-1ea509ead6bf61e89e76e8725f233963337432fa.tar.bz2
historical-1ea509ead6bf61e89e76e8725f233963337432fa.zip
Bump
Package-Manager: portage-2.2_rc63/cvs/Linux x86_64
Diffstat (limited to 'dev-util/monodevelop-debugger-gdb')
-rw-r--r--dev-util/monodevelop-debugger-gdb/ChangeLog12
-rw-r--r--dev-util/monodevelop-debugger-gdb/monodevelop-debugger-gdb-2.2.1.ebuild38
-rw-r--r--dev-util/monodevelop-debugger-gdb/monodevelop-debugger-gdb-2.2.ebuild38
3 files changed, 86 insertions, 2 deletions
diff --git a/dev-util/monodevelop-debugger-gdb/ChangeLog b/dev-util/monodevelop-debugger-gdb/ChangeLog
index 9aede6097028..3742c6a64c5b 100644
--- a/dev-util/monodevelop-debugger-gdb/ChangeLog
+++ b/dev-util/monodevelop-debugger-gdb/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/monodevelop-debugger-gdb
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monodevelop-debugger-gdb/ChangeLog,v 1.4 2009/10/18 12:18:02 loki_val Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monodevelop-debugger-gdb/ChangeLog,v 1.5 2010/02/25 13:48:41 patrick Exp $
+
+*monodevelop-debugger-gdb-2.2.1 (25 Feb 2010)
+*monodevelop-debugger-gdb-2.2 (25 Feb 2010)
+
+ 25 Feb 2010; Patrick Lauer <patrick@gentoo.org>
+ +monodevelop-debugger-gdb-2.2.ebuild,
+ +monodevelop-debugger-gdb-2.2.1.ebuild:
+ Bump
*monodevelop-debugger-gdb-2.1.1 (18 Oct 2009)
diff --git a/dev-util/monodevelop-debugger-gdb/monodevelop-debugger-gdb-2.2.1.ebuild b/dev-util/monodevelop-debugger-gdb/monodevelop-debugger-gdb-2.2.1.ebuild
new file mode 100644
index 000000000000..57fb41b3c86f
--- /dev/null
+++ b/dev-util/monodevelop-debugger-gdb/monodevelop-debugger-gdb-2.2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monodevelop-debugger-gdb/monodevelop-debugger-gdb-2.2.1.ebuild,v 1.1 2010/02/25 13:48:41 patrick Exp $
+
+EAPI=2
+
+inherit mono multilib
+
+DESCRIPTION="GDB Extension for MonoDevelop"
+HOMEPAGE="http://www.monodevelop.com/"
+SRC_URI="http://ftp.novell.com/pub/mono/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-lang/mono-2.4
+ =dev-util/monodevelop-${PV}*
+ sys-devel/gdb"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.23"
+
+src_configure() {
+ ./configure \
+ --prefix=/usr \
+ || die "configure failed"
+}
+
+src_compile() {
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "install failed"
+ mono_multilib_comply
+}
diff --git a/dev-util/monodevelop-debugger-gdb/monodevelop-debugger-gdb-2.2.ebuild b/dev-util/monodevelop-debugger-gdb/monodevelop-debugger-gdb-2.2.ebuild
new file mode 100644
index 000000000000..bde27ae1d8a5
--- /dev/null
+++ b/dev-util/monodevelop-debugger-gdb/monodevelop-debugger-gdb-2.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monodevelop-debugger-gdb/monodevelop-debugger-gdb-2.2.ebuild,v 1.1 2010/02/25 13:48:41 patrick Exp $
+
+EAPI=2
+
+inherit mono multilib
+
+DESCRIPTION="GDB Extension for MonoDevelop"
+HOMEPAGE="http://www.monodevelop.com/"
+SRC_URI="http://ftp.novell.com/pub/mono/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-lang/mono-2.4
+ =dev-util/monodevelop-${PV}*
+ sys-devel/gdb"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.23"
+
+src_configure() {
+ ./configure \
+ --prefix=/usr \
+ || die "configure failed"
+}
+
+src_compile() {
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "install failed"
+ mono_multilib_comply
+}