summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-04-28 20:58:38 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-04-28 20:58:38 +0000
commit7b76bf5ebe180eb4d8b133b26a8ae3a0ddb5600b (patch)
tree8ce5ef314243d605634b604291e650b31106b61d /dev-util/gource/gource-0.38.ebuild
parentFix ChangeLog header after package move. (diff)
downloadhistorical-7b76bf5ebe180eb4d8b133b26a8ae3a0ddb5600b.tar.gz
historical-7b76bf5ebe180eb4d8b133b26a8ae3a0ddb5600b.tar.bz2
historical-7b76bf5ebe180eb4d8b133b26a8ae3a0ddb5600b.zip
Version bump, thanks to Enrico.
Package-Manager: portage-2.2.0_alpha101/cvs/Linux x86_64
Diffstat (limited to 'dev-util/gource/gource-0.38.ebuild')
-rw-r--r--dev-util/gource/gource-0.38.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/dev-util/gource/gource-0.38.ebuild b/dev-util/gource/gource-0.38.ebuild
new file mode 100644
index 000000000000..7e2c1e319ba3
--- /dev/null
+++ b/dev-util/gource/gource-0.38.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gource/gource-0.38.ebuild,v 1.1 2012/04/28 20:58:37 flameeyes Exp $
+
+EAPI=2
+
+inherit autotools flag-o-matic versionator
+
+MY_P=${P/_p/-}
+MY_P=${MY_P/_/-}
+MY_DATE=${PV/*_p}
+
+DESCRIPTION="A software version control visualization tool"
+HOMEPAGE="http://code.google.com/p/gource/"
+SRC_URI="http://gource.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=media-libs/libsdl-1.2.10[opengl,X]
+ >=media-libs/sdl-image-1.2[jpeg,png]
+ dev-libs/libpcre:3
+ >=media-libs/libpng-1.2
+ virtual/jpeg
+ media-libs/mesa
+ media-fonts/freefont-ttf
+ >=media-libs/glew-1.5
+ dev-libs/tinyxml
+ >=dev-libs/boost-1.46
+ "
+DEPEND="
+ ${RDEPEND}
+ dev-util/pkgconfig
+ media-libs/freetype:2
+ >=media-libs/glm-0.9.3
+ "
+
+case ${PV} in
+ *_beta*)
+ my_v=$(get_version_component_range 1-3)
+ my_v=${my_v//_/-}
+ S="${WORKDIR}/${PN}-${my_v}" ;;
+ *)
+ S="${WORKDIR}/${PN}-$(get_version_component_range 1-2)" ;;
+esac
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ # fix bug #386525
+ # this enable gource to be compiled against dev-libs/tinyxml[stl]
+ if has_version dev-libs/tinyxml[stl]; then
+ append-cppflags -DTIXML_USE_STL;
+ fi
+ econf --enable-ttf-font-dir=/usr/share/fonts/freefont-ttf/ \
+ --with-tinyxml
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc README ChangeLog THANKS || die "dodoc failed"
+}