summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-08-03 04:19:45 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-08-03 04:19:45 +0000
commitc9ea30ae32287fccd77553f2850366baee808fab (patch)
tree7a04507800efe0f104d43230c80b1365dad0fddb /dev-util/cutils/cutils-1.6.ebuild
parentremoved commented out lam-mpi entry and commed out netbeans (both checked (diff)
downloadhistorical-c9ea30ae32287fccd77553f2850366baee808fab.tar.gz
historical-c9ea30ae32287fccd77553f2850366baee808fab.tar.bz2
historical-c9ea30ae32287fccd77553f2850366baee808fab.zip
new package - c utils
Diffstat (limited to 'dev-util/cutils/cutils-1.6.ebuild')
-rw-r--r--dev-util/cutils/cutils-1.6.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/cutils/cutils-1.6.ebuild b/dev-util/cutils/cutils-1.6.ebuild
new file mode 100644
index 000000000000..caf55ea5bbac
--- /dev/null
+++ b/dev-util/cutils/cutils-1.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cutils/cutils-1.6.ebuild,v 1.1 2002/08/03 04:19:45 george Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="C language utilities"
+HOMEPAGE="http://www.sigala.it/sandro/software.html#cutils"
+SRC_URI="http://www.sigala.it/sandro/files/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="x86"
+LICENSE="as-is"
+
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ patch -p0 <${FILESDIR}/${PF}-gentoo.diff || die
+}
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=${DESTTREE} \
+ --infodir=${DESTTREE}/share/info \
+ --mandir=${DESTTREE}/share/man || die
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc COPYRIGHT CREDITS HISTORY INSTALL NEWS README
+}