summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2003-10-03 06:17:46 +0000
committerJoshua Kinard <kumba@gentoo.org>2003-10-03 06:17:46 +0000
commit977eabf79faff704d5931a3f388bcf8d9c12db9a (patch)
treebef408d177a4c2c47445301fe9497d0d7979a106 /dev-util/comparator/comparator-2.2.ebuild
parentNew revision of ESR's comparator utility (diff)
downloadhistorical-977eabf79faff704d5931a3f388bcf8d9c12db9a.tar.gz
historical-977eabf79faff704d5931a3f388bcf8d9c12db9a.tar.bz2
historical-977eabf79faff704d5931a3f388bcf8d9c12db9a.zip
New revision of ESR's comparator utility
Diffstat (limited to 'dev-util/comparator/comparator-2.2.ebuild')
-rw-r--r--dev-util/comparator/comparator-2.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/comparator/comparator-2.2.ebuild b/dev-util/comparator/comparator-2.2.ebuild
new file mode 100644
index 000000000000..a0d868bc669b
--- /dev/null
+++ b/dev-util/comparator/comparator-2.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/comparator/comparator-2.2.ebuild,v 1.1 2003/10/03 06:17:43 kumba Exp $
+
+
+DESCRIPTION="ESR's utility for making fast comparisons among large source trees"
+HOMEPAGE="http://www.catb.org/~esr/comparator/"
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ http://www.catb.org/~esr/comparator/${P}.tar.gz"
+LICENSE="as-is GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~mips"
+IUSE=""
+DEPEND=""
+
+
+src_compile() {
+
+ # Fix the Makefile to accept our CFLAGS
+ mv ${S}/Makefile ${S}/Makefile.orig
+ sed -e "s/CFLAGS = -O3/CFLAGS = ${CFLAGS}/" ${S}/Makefile.orig > ${S}/Makefile
+ emake || die
+}
+
+src_install() {
+ dobin comparator
+ dobin filterator
+ doman comparator.1
+}