summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-08-15 18:25:12 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-08-15 18:25:12 +0000
commitaf4eb6c01e8fe5e251906326023861b93c8aecc3 (patch)
tree816b6e1150316e0167a3e44849bc475f8710ed64 /dev-util/argouml/argouml-0.16.ebuild
parentadd note about moronic watermarking (diff)
downloadhistorical-af4eb6c01e8fe5e251906326023861b93c8aecc3.tar.gz
historical-af4eb6c01e8fe5e251906326023861b93c8aecc3.tar.bz2
historical-af4eb6c01e8fe5e251906326023861b93c8aecc3.zip
Version bump. Closes #59393"
Diffstat (limited to 'dev-util/argouml/argouml-0.16.ebuild')
-rw-r--r--dev-util/argouml/argouml-0.16.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/argouml/argouml-0.16.ebuild b/dev-util/argouml/argouml-0.16.ebuild
new file mode 100644
index 000000000000..2e2d2862b330
--- /dev/null
+++ b/dev-util/argouml/argouml-0.16.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/argouml/argouml-0.16.ebuild,v 1.1 2004/08/15 18:25:12 zx Exp $
+
+inherit java-pkg
+
+DESCRIPTION="ArgoUML is a modelling tool that helps you do your design using UML."
+HOMEPAGE="http://argouml.tigris.org"
+SRC_URI="http://argouml.tigris.org/files/documents/4/0/${P}/ArgoUML-${PV}.tar.gz
+ http://argouml.tigris.org/files/documents/4/0/${P}/ArgoUML-${PV}-modules.tar.gz
+ doc? ( http://argouml.tigris.org/files/documents/4/0/${P}/argomanual-${PV}.pdf
+ http://argouml.tigris.org/files/documents/4/0/${P}/quickguide-${PV}.pdf
+ http://argouml.tigris.org/files/documents/4/0/${P}/cookbook-${PV}.pdf )"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+RESTRICT="nomirror"
+IUSE="doc"
+RDEPEND=">=virtual/jre-1.2*"
+S=${WORKDIR}
+
+src_compile() { :; }
+
+src_install() {
+ dodir /opt/${PN}
+ cp -a . ${D}/opt/${PN}/lib/
+ chmod -R 755 ${D}/opt/${PN}
+ touch ${D}/opt/${PN}/lib/argouml.log
+ chmod a+w ${D}/opt/${PN}/lib/argouml.log
+
+ echo "#!/bin/sh" > ${PN}
+ echo "cd /opt/${PN}/lib" >> ${PN}
+ echo '"${JAVA_HOME}"/bin/java -jar argouml.jar' >> ${PN}
+ into /opt
+ dobin ${PN}
+
+ dodoc README.txt
+
+ if use doc ; then
+ insinto /usr/share/doc/${P}
+ doins ${DISTDIR}/argomanual-${PV}.pdf
+ doins ${DISTDIR}/quickguide-${PV}.pdf
+ doins ${DISTDIR}/cookbook-${PV}.pdf
+ fi
+}