summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2010-05-23 11:03:14 +0000
committerAlex Legler <a3li@gentoo.org>2010-05-23 11:03:14 +0000
commit1acae5cfeb65d7131a389511163e8a4007b84095 (patch)
treea19eca66fbd2572ffd178708dc5793f248ddddf4 /dev-ruby
parentAdded optional graphicsmagick dependency (bug #314427) (diff)
downloadhistorical-1acae5cfeb65d7131a389511163e8a4007b84095.tar.gz
historical-1acae5cfeb65d7131a389511163e8a4007b84095.tar.bz2
historical-1acae5cfeb65d7131a389511163e8a4007b84095.zip
Add REE18 support
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionmailer/ChangeLog5
-rw-r--r--dev-ruby/actionmailer/actionmailer-2.3.5-r1.ebuild4
-rw-r--r--dev-ruby/rails/ChangeLog7
-rw-r--r--dev-ruby/rails/rails-2.3.5-r3.ebuild80
4 files changed, 92 insertions, 4 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index ac9928d5bbad..ff5980aa0136 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.140 2010/05/23 10:50:38 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.141 2010/05/23 11:01:12 a3li Exp $
+
+ 23 May 2010; Alex Legler <a3li@gentoo.org> actionmailer-2.3.5-r1.ebuild:
+ Add REE18 support
23 May 2010; Alex Legler <a3li@gentoo.org> actionmailer-2.3.5-r1.ebuild:
Add REE18 support
diff --git a/dev-ruby/actionmailer/actionmailer-2.3.5-r1.ebuild b/dev-ruby/actionmailer/actionmailer-2.3.5-r1.ebuild
index 5375d76b5455..dbedb4448a84 100644
--- a/dev-ruby/actionmailer/actionmailer-2.3.5-r1.ebuild
+++ b/dev-ruby/actionmailer/actionmailer-2.3.5-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-2.3.5-r1.ebuild,v 1.10 2010/05/23 10:50:38 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-2.3.5-r1.ebuild,v 1.11 2010/05/23 11:01:12 a3li Exp $
EAPI=2
-USE_RUBY="ruby18 jruby"
+USE_RUBY="ruby18 ree18 jruby"
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index 5eadf4f7f519..fb0868f0e858 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.173 2010/05/22 14:36:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.174 2010/05/23 11:03:14 a3li Exp $
+
+*rails-2.3.5-r3 (23 May 2010)
+
+ 23 May 2010; Alex Legler <a3li@gentoo.org> +rails-2.3.5-r3.ebuild:
+ Add REE18 support
22 May 2010; Diego E. Pettenò <flameeyes@gentoo.org> rails-2.3.5.ebuild,
-rails-2.3.5-r1.ebuild, rails-2.3.5-r2.ebuild:
diff --git a/dev-ruby/rails/rails-2.3.5-r3.ebuild b/dev-ruby/rails/rails-2.3.5-r3.ebuild
new file mode 100644
index 000000000000..ec5f1945ccc9
--- /dev/null
+++ b/dev-ruby/rails/rails-2.3.5-r3.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-2.3.5-r3.ebuild,v 1.1 2010/05/23 11:03:14 a3li Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_EXTRAINSTALL="builtin configs doc dispatches environments fresh_rakefile helpers html README"
+RUBY_FAKEGEM_EXTRADOC="README CHANGELOG"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+# gem lacks tests
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-rails-0.15"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.3
+ ~dev-ruby/activerecord-${PV} >=dev-ruby/activerecord-${PV}-r1
+ ~dev-ruby/activeresource-${PV} >=dev-ruby/activeresource-${PV}-r1
+ ~dev-ruby/activesupport-${PV} >=dev-ruby/activesupport-${PV}-r1
+ ~dev-ruby/actionmailer-${PV} >=dev-ruby/actionmailer-${PV}-r1
+ ~dev-ruby/actionpack-${PV} >=dev-ruby/actionpack-${PV}-r1"
+ruby_add_bdepend "
+ doc? ( dev-ruby/redcloth )
+ test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -i -e '/horo/d' Rakefile || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ # fails for missing template when using the gem distribution
+ #if use doc; then
+ # pushd guides
+ # ruby rails_guides.rb || die "guide generation failed"
+ # popd
+ #fi
+}
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rails rails-${PV}
+
+ if use doc; then
+ #pushd guides/output
+ #docinto guides
+ #dohtml -r *
+ #popd
+
+ pushd doc
+ docinto api
+ dohtml -r *
+ popd
+ fi
+}
+
+pkg_postinst() {
+ elog "To select between slots of rails, use:"
+ elog "\teselect rails"
+
+ eselect rails update
+}
+
+pkg_postrm() {
+ eselect rails update
+}