summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-11-05 00:36:34 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-11-05 00:36:34 +0000
commit0de8ce7d59bcfd7213057e6fb83c83c950b90ff4 (patch)
tree212c9df124bd21fcddf161027746d1681b2aacc3 /dev-ruby/textpow/textpow-1.3.1-r1.ebuild
parentAdd ruby20 target. Cleanup old. (diff)
downloadhistorical-0de8ce7d59bcfd7213057e6fb83c83c950b90ff4.tar.gz
historical-0de8ce7d59bcfd7213057e6fb83c83c950b90ff4.tar.bz2
historical-0de8ce7d59bcfd7213057e6fb83c83c950b90ff4.zip
Add ruby20 target. Cleanup old.
Package-Manager: portage-2.2.7/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/textpow/textpow-1.3.1-r1.ebuild')
-rw-r--r--dev-ruby/textpow/textpow-1.3.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/textpow/textpow-1.3.1-r1.ebuild b/dev-ruby/textpow/textpow-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..78597557977a
--- /dev/null
+++ b/dev-ruby/textpow/textpow-1.3.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/textpow/textpow-1.3.1-r1.ebuild,v 1.1 2013/11/05 00:36:29 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library to parse and process Textmate bundles."
+HOMEPAGE="http://textpow.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/plist-3.0.1"
+
+USE_RUBY=ruby18 ruby_add_bdepend "test? ( >=dev-ruby/oniguruma-1.1.0 )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' textpow.gemspec || die
+}