summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2003-05-13 14:33:38 +0000
committerTom William Payne <twp@gentoo.org>2003-05-13 14:33:38 +0000
commitc9910ab9e28fcbb67b9bc5064559aba9ddf1c140 (patch)
tree69bc59af847d77131421b47c5b779f337324fea9 /dev-ruby/ruby-tcpwrap
parentInitial release (diff)
downloadhistorical-c9910ab9e28fcbb67b9bc5064559aba9ddf1c140.tar.gz
historical-c9910ab9e28fcbb67b9bc5064559aba9ddf1c140.tar.bz2
historical-c9910ab9e28fcbb67b9bc5064559aba9ddf1c140.zip
Initial release
Diffstat (limited to 'dev-ruby/ruby-tcpwrap')
-rw-r--r--dev-ruby/ruby-tcpwrap/Manifest4
-rw-r--r--dev-ruby/ruby-tcpwrap/files/digest-ruby-tcpwrap-0.51
-rw-r--r--dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.5.ebuild26
3 files changed, 29 insertions, 2 deletions
diff --git a/dev-ruby/ruby-tcpwrap/Manifest b/dev-ruby/ruby-tcpwrap/Manifest
index 8ed1b310c75f..dd1abbcc36d6 100644
--- a/dev-ruby/ruby-tcpwrap/Manifest
+++ b/dev-ruby/ruby-tcpwrap/Manifest
@@ -1,3 +1,3 @@
-MD5 84c62bc80045fc743759a6d055025fb9 ruby-tcpwrap-0.5.ebuild 552
-MD5 d605c04067ccc218739d536f8d0e11d1 .ruby-tcpwrap-0.5.ebuild.swp 16384
+MD5 6907db9260bce3e4dc8c4aab35ed026e ruby-tcpwrap-0.5.ebuild 708
+MD5 99e45a654d9a09c3c42947c760868dcb ChangeLog 388
MD5 a82c7f3f05166f1f662746bf4882646f files/digest-ruby-tcpwrap-0.5 66
diff --git a/dev-ruby/ruby-tcpwrap/files/digest-ruby-tcpwrap-0.5 b/dev-ruby/ruby-tcpwrap/files/digest-ruby-tcpwrap-0.5
new file mode 100644
index 000000000000..4d338ca03213
--- /dev/null
+++ b/dev-ruby/ruby-tcpwrap/files/digest-ruby-tcpwrap-0.5
@@ -0,0 +1 @@
+MD5 fc0380da56a76d20038a9492be34cfba ruby-tcpwrap-0.5.tar.gz 4219
diff --git a/dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.5.ebuild b/dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.5.ebuild
new file mode 100644
index 000000000000..44f991e7d8d5
--- /dev/null
+++ b/dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.5.ebuild,v 1.1 2003/05/13 14:33:19 twp Exp $
+
+DESCRIPTION="A TCP wrappers library for Ruby"
+HOMEPAGE="http://raa.ruby-lang.org/list.rhtml?name=ruby-tcpwrap"
+SRC_URI="http://shugo.net/archive/ruby-tcpwrap/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~arm ~hppa ~mips ~sparc ~x86"
+DEPEND="dev-lang/ruby
+ net-libs/libident
+ sys-apps/tcp-wrappers"
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ ruby extconf.rb || die
+ emake || die
+}
+
+src_install() {
+ einstall
+ dodoc README*
+ insinto /usr/share/doc/${PF}/html
+ doins doc/*
+}