summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-11-01 18:00:53 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-11-01 18:00:53 +0000
commita2ef82467a235da3266ff77eb72026e37b312c00 (patch)
treeeea40f1fc6b8e11bfb9a3ab352c39d72cf6acd37 /dev-ruby/ruby-postgres
parentAdd patch to fix building of C-based extensions, see bug #143974. Thanks to J... (diff)
downloadhistorical-a2ef82467a235da3266ff77eb72026e37b312c00.tar.gz
historical-a2ef82467a235da3266ff77eb72026e37b312c00.tar.bz2
historical-a2ef82467a235da3266ff77eb72026e37b312c00.zip
Revbump the snapshot, and let it depend on rubygems 0.9.0-r1 so to fix bug #143974 for everyone. Also change dependency on libpq rather than full blown postgresql, thanks to Matt Michalowski in bug #153642.
Package-Manager: portage-2.1.2_rc1-r2
Diffstat (limited to 'dev-ruby/ruby-postgres')
-rw-r--r--dev-ruby/ruby-postgres/ChangeLog11
-rw-r--r--dev-ruby/ruby-postgres/files/digest-ruby-postgres-0.7.1.20051221-r13
-rw-r--r--dev-ruby/ruby-postgres/ruby-postgres-0.7.1.20051221-r1.ebuild20
-rw-r--r--dev-ruby/ruby-postgres/ruby-postgres-0.7.1.ebuild4
4 files changed, 35 insertions, 3 deletions
diff --git a/dev-ruby/ruby-postgres/ChangeLog b/dev-ruby/ruby-postgres/ChangeLog
index 89c329acb1e2..0cdd947e1519 100644
--- a/dev-ruby/ruby-postgres/ChangeLog
+++ b/dev-ruby/ruby-postgres/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-ruby/ruby-postgres
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ChangeLog,v 1.11 2006/08/07 12:00:02 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ChangeLog,v 1.12 2006/11/01 18:00:53 flameeyes Exp $
+
+*ruby-postgres-0.7.1.20051221-r1 (01 Nov 2006)
+
+ 01 Nov 2006; Diego Pettenò <flameeyes@gentoo.org>
+ ruby-postgres-0.7.1.ebuild, -ruby-postgres-0.7.1.20051221.ebuild,
+ +ruby-postgres-0.7.1.20051221-r1.ebuild:
+ Revbump the snapshot, and let it depend on rubygems 0.9.0-r1 so to fix bug
+ #143974 for everyone. Also change dependency on libpq rather than full blown
+ postgresql, thanks to Matt Michalowski in bug #153642.
*ruby-postgres-0.7.1.20051221 (07 Aug 2006)
diff --git a/dev-ruby/ruby-postgres/files/digest-ruby-postgres-0.7.1.20051221-r1 b/dev-ruby/ruby-postgres/files/digest-ruby-postgres-0.7.1.20051221-r1
new file mode 100644
index 000000000000..c2c6a6ee5d97
--- /dev/null
+++ b/dev-ruby/ruby-postgres/files/digest-ruby-postgres-0.7.1.20051221-r1
@@ -0,0 +1,3 @@
+MD5 5b53d6baf4c6a73377f1169fbcf7ab54 ruby-postgres-0.7.1.2005.12.21.gem 45568
+RMD160 dcc4c1c8580fa27476e662c791456679e9435ae5 ruby-postgres-0.7.1.2005.12.21.gem 45568
+SHA256 a4dff24a1a2ebb0c34a935e6377cf826a61da03329c8c79a3ea509200759ec7a ruby-postgres-0.7.1.2005.12.21.gem 45568
diff --git a/dev-ruby/ruby-postgres/ruby-postgres-0.7.1.20051221-r1.ebuild b/dev-ruby/ruby-postgres/ruby-postgres-0.7.1.20051221-r1.ebuild
new file mode 100644
index 000000000000..8363f1f13590
--- /dev/null
+++ b/dev-ruby/ruby-postgres/ruby-postgres-0.7.1.20051221-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ruby-postgres-0.7.1.20051221-r1.ebuild,v 1.1 2006/11/01 18:00:53 flameeyes Exp $
+
+inherit ruby gems
+
+MY_P=ruby-postgres-0.7.1.2005.12.21.gem
+
+DESCRIPTION="An extension library to access a PostgreSQL database from Ruby"
+HOMEPAGE="http://ruby.scripting.ca/postgres"
+SRC_URI="http://ruby.scripting.ca/postgres/archive/$MY_P"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+USE_RUBY="ruby18"
+
+RDEPEND=">=dev-db/libpq-6.4"
+DEPEND="${RDEPEND}
+ >=dev-ruby/rubygems-0.9.0-r1"
diff --git a/dev-ruby/ruby-postgres/ruby-postgres-0.7.1.ebuild b/dev-ruby/ruby-postgres/ruby-postgres-0.7.1.ebuild
index 24b28f73c27f..d02a0aea0557 100644
--- a/dev-ruby/ruby-postgres/ruby-postgres-0.7.1.ebuild
+++ b/dev-ruby/ruby-postgres/ruby-postgres-0.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ruby-postgres-0.7.1.ebuild,v 1.12 2006/06/06 16:53:42 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ruby-postgres-0.7.1.ebuild,v 1.13 2006/11/01 18:00:53 flameeyes Exp $
inherit ruby
@@ -12,4 +12,4 @@ SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 mips ppc sparc x86 ~x86-fbsd"
IUSE=""
USE_RUBY="ruby18"
-DEPEND=">=dev-db/postgresql-6.4"
+DEPEND=">=dev-db/libpq-6.4"