summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@gentoo.org>2011-06-18 10:10:00 +0000
committerStanislav Ochotnicky <sochotnicky@gentoo.org>2011-06-18 10:10:00 +0000
commit95dc9a1966ce8f932f838937d02e534bb8852382 (patch)
tree5c1f22752128213da2e917ea865ddef9296a4c7d /dev-ruby/rcsparse/rcsparse-0_pre45-r1.ebuild
parentAdded "|| die" to few commands to prevent possible problems (diff)
downloadhistorical-95dc9a1966ce8f932f838937d02e534bb8852382.tar.gz
historical-95dc9a1966ce8f932f838937d02e534bb8852382.tar.bz2
historical-95dc9a1966ce8f932f838937d02e534bb8852382.zip
Added "|| die" to few commands to prevent possible problems
Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/rcsparse/rcsparse-0_pre45-r1.ebuild')
-rw-r--r--dev-ruby/rcsparse/rcsparse-0_pre45-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-ruby/rcsparse/rcsparse-0_pre45-r1.ebuild b/dev-ruby/rcsparse/rcsparse-0_pre45-r1.ebuild
index 2b996dc75296..49736722cef5 100644
--- a/dev-ruby/rcsparse/rcsparse-0_pre45-r1.ebuild
+++ b/dev-ruby/rcsparse/rcsparse-0_pre45-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcsparse/rcsparse-0_pre45-r1.ebuild,v 1.1 2011/06/18 10:01:46 sochotnicky Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcsparse/rcsparse-0_pre45-r1.ebuild,v 1.2 2011/06/18 10:10:00 sochotnicky Exp $
EAPI=4
@@ -32,8 +32,8 @@ src_prepare() {
# this is a workaround because combination of ruby-ng and mercurial is
# not working correctly for unpacking
for rubyv in ${USE_RUBY} all;do
- mkdir "${WORKDIR}/${rubyv}"
- cp -prl "${S}" "${WORKDIR}/${rubyv}/${RUBY_S}"
+ mkdir "${WORKDIR}/${rubyv}" || die
+ cp -prl "${S}" "${WORKDIR}/${rubyv}/${RUBY_S}" || die
done
}