summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJerry Alexandratos <jerry@gentoo.org>2000-11-17 08:22:05 +0000
committerJerry Alexandratos <jerry@gentoo.org>2000-11-17 08:22:05 +0000
commitd01c0e7d3c14b9cfebbfbfa02beedb797d1c6f42 (patch)
tree3e988ba41efa6a928903a4af57cc30759807180d /dev-ruby/racc
parentInitial import of Ruby, the OO scripting lang, into the portage tree. (diff)
downloadhistorical-d01c0e7d3c14b9cfebbfbfa02beedb797d1c6f42.tar.gz
historical-d01c0e7d3c14b9cfebbfbfa02beedb797d1c6f42.tar.bz2
historical-d01c0e7d3c14b9cfebbfbfa02beedb797d1c6f42.zip
Initial import of a slew or Ruby modules. This is the base for
generating RD (similar to Perl's POD) files. Hey, we might as well start with the ability to document the code we write. 8) The modules installed are: amstd -- standard libraries for Ruby optparse -- an option parser racc -- lexical parser strscan -- fast string formatter/scanner rdtool -- RD doc formatter
Diffstat (limited to 'dev-ruby/racc')
-rw-r--r--dev-ruby/racc/files/digest-racc-1.2.41
-rw-r--r--dev-ruby/racc/racc-1.2.4.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/racc/files/digest-racc-1.2.4 b/dev-ruby/racc/files/digest-racc-1.2.4
new file mode 100644
index 000000000000..bbdb6b29c555
--- /dev/null
+++ b/dev-ruby/racc/files/digest-racc-1.2.4
@@ -0,0 +1 @@
+MD5 70f6983f8bb04dd3403aa6b34efa8b18 racc-1.2.4.tar.gz
diff --git a/dev-ruby/racc/racc-1.2.4.ebuild b/dev-ruby/racc/racc-1.2.4.ebuild
new file mode 100644
index 000000000000..d58e307ac807
--- /dev/null
+++ b/dev-ruby/racc/racc-1.2.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/racc-1.2.4.ebuild,v 1.1 2000/11/17 08:22:04 jerry Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="LALR parser generator for Ruby"
+SRC_URI="http://www1.u-netsurf.ne.jp/~brew/mine/soft/${A}"
+HOMEPAGE="http://www1.u-netsurf.ne.jp/~brew/mine/en/index.html"
+
+DEPEND=">=dev-lang/ruby-1.6.1
+ >=dev-ruby/amstd-1.9.5"
+
+src_compile() {
+ cd ${S}
+ try ruby setup.rb config --without=amstd
+ try ruby setup.rb setup
+}
+
+src_install () {
+ cd ${S}
+ try ruby setup.rb install --bin-dir=${D}/usr/bin \
+ --rb-dir=${D}/usr/lib/ruby/site_ruby/1.6 \
+ --so-dir=${D}/usr/lib/ruby/site_ruby/1.6/i686-linux-gnu
+}