summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-09-14 07:35:02 +0000
committerHans de Graaff <graaff@gentoo.org>2011-09-14 07:35:02 +0000
commit01d90fb6a6ee172dcf46e12e15ef15de50e349ca (patch)
treef9f08d5005a4915fc041cc9762a241d0c6ae7cb7 /dev-ruby/multi_xml
parentVersion bump simpleparse to 2.1.1. (diff)
downloadhistorical-01d90fb6a6ee172dcf46e12e15ef15de50e349ca.tar.gz
historical-01d90fb6a6ee172dcf46e12e15ef15de50e349ca.tar.bz2
historical-01d90fb6a6ee172dcf46e12e15ef15de50e349ca.zip
Version bump.
Package-Manager: portage-2.1.10.11/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/multi_xml')
-rw-r--r--dev-ruby/multi_xml/ChangeLog7
-rw-r--r--dev-ruby/multi_xml/multi_xml-0.4.0.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-ruby/multi_xml/ChangeLog b/dev-ruby/multi_xml/ChangeLog
index cb696be413a8..29a4d64c2057 100644
--- a/dev-ruby/multi_xml/ChangeLog
+++ b/dev-ruby/multi_xml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/multi_xml
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_xml/ChangeLog,v 1.2 2011/08/12 18:17:31 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_xml/ChangeLog,v 1.3 2011/09/14 07:35:02 graaff Exp $
+
+*multi_xml-0.4.0 (14 Sep 2011)
+
+ 14 Sep 2011; Hans de Graaff <graaff@gentoo.org> +multi_xml-0.4.0.ebuild:
+ Version bump.
*multi_xml-0.3.0 (12 Aug 2011)
diff --git a/dev-ruby/multi_xml/multi_xml-0.4.0.ebuild b/dev-ruby/multi_xml/multi_xml-0.4.0.ebuild
new file mode 100644
index 000000000000..f6d50d747217
--- /dev/null
+++ b/dev-ruby/multi_xml/multi_xml-0.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_xml/multi_xml-0.4.0.ebuild,v 1.1 2011/09/14 07:35:02 graaff Exp $
+
+EAPI=4
+
+# jruby is no longer supported by upstream starting with 0.3.0
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC="doc:yard"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A generic swappable back-end for XML parsing"
+HOMEPAGE="http://rdoc.info/gems/multi_xml"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.5:2 )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile spec/helper.rb || die
+ sed -i -e '/[Ss]imple[Cc]ov/d' spec/helper.rb || die
+}