summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-09-11 06:10:03 +0000
committerHans de Graaff <graaff@gentoo.org>2011-09-11 06:10:03 +0000
commit2c454eb81931cb8b72a390a033021d29d54f80c6 (patch)
tree9676fef5290520ff5d2c7030be0f0ae2a0a1cc1f /dev-ruby/json
parentRemove old versions. (diff)
downloadhistorical-2c454eb81931cb8b72a390a033021d29d54f80c6.tar.gz
historical-2c454eb81931cb8b72a390a033021d29d54f80c6.tar.bz2
historical-2c454eb81931cb8b72a390a033021d29d54f80c6.zip
Version bump.
Package-Manager: portage-2.1.10.11/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/json')
-rw-r--r--dev-ruby/json/ChangeLog7
-rw-r--r--dev-ruby/json/json-1.5.4.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-ruby/json/ChangeLog b/dev-ruby/json/ChangeLog
index 7b61b6b67ab7..be0357a29164 100644
--- a/dev-ruby/json/ChangeLog
+++ b/dev-ruby/json/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/json
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.65 2011/09/11 06:00:04 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.66 2011/09/11 06:05:13 graaff Exp $
+
+*json-1.5.4 (11 Sep 2011)
+
+ 11 Sep 2011; Hans de Graaff <graaff@gentoo.org> +json-1.5.4.ebuild:
+ Version bump.
11 Sep 2011; Hans de Graaff <graaff@gentoo.org> -json-1.5.1.ebuild,
-json-1.5.2.ebuild:
diff --git a/dev-ruby/json/json-1.5.4.ebuild b/dev-ruby/json/json-1.5.4.ebuild
new file mode 100644
index 000000000000..ae874b93bdbf
--- /dev/null
+++ b/dev-ruby/json/json-1.5.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.5.4.ebuild,v 1.1 2011/09/11 06:05:13 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README.rdoc README-json-jruby.markdown"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A JSON implementation as a Ruby extension."
+HOMEPAGE="http://json.rubyforge.org/"
+LICENSE="|| ( Ruby GPL-2 )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${RDEPEND}"
+DEPEND="${DEPEND}
+ dev-util/ragel"
+
+ruby_add_bdepend "dev-ruby/rake
+ test? ( virtual/ruby-test-unit )"
+
+all_ruby_prepare() {
+ # Avoid building the extension twice!
+ # And use rdoc instead of sdoc which we don't have packaged
+ sed -i \
+ -e 's| => :compile||' \
+ -e 's| => :clean||' \
+ -e 's|sdoc|rdoc|' \
+ Rakefile || die "rakefile fix failed"
+}
+
+each_ruby_compile() {
+ # Since 1.5.0 a Java extension is provided but it does not compile.
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ ${RUBY} -S rake compile || die "extension compile failed"
+ fi
+}
+
+each_ruby_test() {
+ JSON=pure \
+ ${RUBY} -Iext:lib -S testrb tests/*.rb || die "pure ruby tests failed"
+
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ JSON=ext \
+ ${RUBY} -Iext:lib -S testrb tests/*.rb || die "ext ruby tests failed"
+ fi
+}
+
+each_ruby_install() {
+ each_fakegem_install
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ ruby_fakegem_newins ext/json/ext/generator$(get_modname) lib/json/ext/generator$(get_modname)
+ ruby_fakegem_newins ext/json/ext/parser$(get_modname) lib/json/ext/parser$(get_modname)
+ fi
+}