summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-10-05 10:09:28 +0000
committerHans de Graaff <graaff@gentoo.org>2012-10-05 10:09:28 +0000
commit3051ea7bdb43ecbcedf3061967b9069da93f3eac (patch)
treed744948a3573d75bfb6b361ca73022bbcba23618 /dev-ruby/file-tail
parentFlip dependencies around in || ( ) atom wrt #436672 (diff)
downloadhistorical-3051ea7bdb43ecbcedf3061967b9069da93f3eac.tar.gz
historical-3051ea7bdb43ecbcedf3061967b9069da93f3eac.tar.bz2
historical-3051ea7bdb43ecbcedf3061967b9069da93f3eac.zip
Version bump.
Package-Manager: portage-2.1.11.9/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/file-tail')
-rw-r--r--dev-ruby/file-tail/ChangeLog7
-rw-r--r--dev-ruby/file-tail/file-tail-1.0.12.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-ruby/file-tail/ChangeLog b/dev-ruby/file-tail/ChangeLog
index 58f2b76e320e..b1e066e05880 100644
--- a/dev-ruby/file-tail/ChangeLog
+++ b/dev-ruby/file-tail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/file-tail
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/file-tail/ChangeLog,v 1.8 2012/08/21 16:51:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/file-tail/ChangeLog,v 1.9 2012/10/05 10:07:55 graaff Exp $
+
+*file-tail-1.0.12 (05 Oct 2012)
+
+ 05 Oct 2012; Hans de Graaff <graaff@gentoo.org> +file-tail-1.0.12.ebuild:
+ Version bump.
*file-tail-1.0.11 (21 Aug 2012)
diff --git a/dev-ruby/file-tail/file-tail-1.0.12.ebuild b/dev-ruby/file-tail/file-tail-1.0.12.ebuild
new file mode 100644
index 000000000000..4182ac3458d7
--- /dev/null
+++ b/dev-ruby/file-tail/file-tail-1.0.12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/file-tail/file-tail-1.0.12.ebuild,v 1.1 2012/10/05 10:07:55 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOC_SOURCES="lib README.rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A small ruby library that allows it to 'tail' files in Ruby"
+HOMEPAGE="http://flori.github.com/file-tail"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/tins-0.5"
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib tests/*_test.rb
+}