summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-06-13 17:44:02 +0000
committerHans de Graaff <graaff@gentoo.org>2012-06-13 17:44:02 +0000
commitad877cf9af2fe6f76f3bca06dd0dde907f27b3c6 (patch)
tree8b5abc2e08bfb9c10046e762cb0deedb98bf63d1 /dev-ruby/activemodel
parentStabilise new dict and name fr_FR the default one as proposed by bicatali and... (diff)
downloadhistorical-ad877cf9af2fe6f76f3bca06dd0dde907f27b3c6.tar.gz
historical-ad877cf9af2fe6f76f3bca06dd0dde907f27b3c6.tar.bz2
historical-ad877cf9af2fe6f76f3bca06dd0dde907f27b3c6.zip
Version bump for Rails 3.0.15.
Package-Manager: portage-2.1.10.49/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/activemodel')
-rw-r--r--dev-ruby/activemodel/ChangeLog7
-rw-r--r--dev-ruby/activemodel/activemodel-3.0.15.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
index 32f144ee1ccb..a16aed5c0221 100644
--- a/dev-ruby/activemodel/ChangeLog
+++ b/dev-ruby/activemodel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activemodel
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.29 2012/06/13 06:23:54 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.30 2012/06/13 17:41:03 graaff Exp $
+
+*activemodel-3.0.15 (13 Jun 2012)
+
+ 13 Jun 2012; Hans de Graaff <graaff@gentoo.org> +activemodel-3.0.15.ebuild:
+ Version bump for Rails 3.0.15.
*activemodel-3.2.6 (13 Jun 2012)
diff --git a/dev-ruby/activemodel/activemodel-3.0.15.ebuild b/dev-ruby/activemodel/activemodel-3.0.15.ebuild
new file mode 100644
index 000000000000..4d7fa89543f6
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-3.0.15.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-3.0.15.ebuild,v 1.1 2012/06/13 17:41:03 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activemodel"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-2.1.2
+ >=dev-ruby/i18n-0.5.0:0.5"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/ruby-debug
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}