summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-16 15:20:40 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-16 15:20:40 +0000
commitcca761ae362eea07b87194a68d3a51c5106950bd (patch)
tree68526f02126c8d8b56c1e534518bb0a51439ee74 /dev-ruby/activeldap
parentRemove mask on net-misc/ssh-installkeys - package removed wrt bug #315843. (diff)
downloadhistorical-cca761ae362eea07b87194a68d3a51c5106950bd.tar.gz
historical-cca761ae362eea07b87194a68d3a51c5106950bd.tar.bz2
historical-cca761ae362eea07b87194a68d3a51c5106950bd.zip
Remove old; drop FAKEGEM_NAME; add proper dependency over test-unit:2 (even if restricted); only depend on hoe for doc building or tests.
Package-Manager: portage-2.2.0_alpha120/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/activeldap')
-rw-r--r--dev-ruby/activeldap/ChangeLog10
-rw-r--r--dev-ruby/activeldap/activeldap-1.2.2-r1.ebuild19
-rw-r--r--dev-ruby/activeldap/activeldap-3.1.1-r1.ebuild3
-rw-r--r--dev-ruby/activeldap/activeldap-3.1.1.ebuild51
4 files changed, 17 insertions, 66 deletions
diff --git a/dev-ruby/activeldap/ChangeLog b/dev-ruby/activeldap/ChangeLog
index 91a8fc9b4ed7..7ba7384b3edc 100644
--- a/dev-ruby/activeldap/ChangeLog
+++ b/dev-ruby/activeldap/ChangeLog
@@ -1,6 +1,11 @@
-# ChangeLog for dev-ruby/ruby-activeldap
+# ChangeLog for dev-ruby/activeldap
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeldap/ChangeLog,v 1.1 2012/08/16 03:43:18 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeldap/ChangeLog,v 1.2 2012/08/16 15:20:40 flameeyes Exp $
+
+ 16 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> -activeldap-3.1.1.ebuild,
+ activeldap-1.2.2-r1.ebuild, activeldap-3.1.1-r1.ebuild:
+ Remove old; drop FAKEGEM_NAME; add proper dependency over test-unit:2 (even if
+ restricted); only depend on hoe for doc building or tests.
*ruby-activeldap-3.1.1-r1 (02 Jul 2012)
@@ -159,4 +164,3 @@
19 Aug 2005; Rob Holland <tigger@gentoo.org> +metadata.xml,
+ruby-activeldap-0.5.7.ebuild:
Initial version.
-
diff --git a/dev-ruby/activeldap/activeldap-1.2.2-r1.ebuild b/dev-ruby/activeldap/activeldap-1.2.2-r1.ebuild
index a1f3881e363b..6f99ec68c30e 100644
--- a/dev-ruby/activeldap/activeldap-1.2.2-r1.ebuild
+++ b/dev-ruby/activeldap/activeldap-1.2.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeldap/activeldap-1.2.2-r1.ebuild,v 1.1 2012/08/16 03:43:18 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeldap/activeldap-1.2.2-r1.ebuild,v 1.2 2012/08/16 15:20:40 flameeyes Exp $
EAPI="2"
USE_RUBY="ruby18"
@@ -9,14 +9,11 @@ RUBY_FAKEGEM_TASK_DOC="docs"
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="CHANGES README TODO"
RUBY_FAKEGEM_EXTRAINSTALL="data po rails rails_generators"
-RUBY_FAKEGEM_NAME="activeldap"
inherit ruby-fakegem
-MY_P="${P/ruby-/}"
DESCRIPTION="Ruby/ActiveLDAP provides an activerecord inspired object oriented interface to LDAP"
HOMEPAGE="http://ruby-activeldap.rubyforge.org/doc/"
-SRC_URI="mirror://rubygems/${MY_P}.gem"
LICENSE="GPL-2"
SLOT="0"
@@ -26,8 +23,12 @@ IUSE=""
# Most tests require a live LDAP server to run.
RESTRICT="test"
-ruby_add_bdepend "dev-ruby/hoe"
-ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+ruby_add_bdepend "
+ doc? ( dev-ruby/hoe )
+ test? (
+ dev-ruby/hoe
+ dev-ruby/test-unit:2
+ )"
ruby_add_rdepend "
=dev-ruby/activerecord-2.3*
@@ -44,9 +45,7 @@ all_ruby_prepare() {
}
each_ruby_test() {
- # Tests use test-unit-2 which is currently masked in tree.
- # Version 2.0.6 is bundled so use that for now.
- RUBYLIB=test-unit/lib ${RUBY} -S rake test || die "Tests failed."
+ ${RUBY} -S rake test || die "Tests failed."
}
all_ruby_install() {
diff --git a/dev-ruby/activeldap/activeldap-3.1.1-r1.ebuild b/dev-ruby/activeldap/activeldap-3.1.1-r1.ebuild
index 49787275a162..0e15a79e04fd 100644
--- a/dev-ruby/activeldap/activeldap-3.1.1-r1.ebuild
+++ b/dev-ruby/activeldap/activeldap-3.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeldap/activeldap-3.1.1-r1.ebuild,v 1.1 2012/08/16 03:43:18 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeldap/activeldap-3.1.1-r1.ebuild,v 1.2 2012/08/16 15:20:40 flameeyes Exp $
EAPI=4
USE_RUBY="ruby18 ruby19"
@@ -8,7 +8,6 @@ USE_RUBY="ruby18 ruby19"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="README.textile TODO"
RUBY_FAKEGEM_EXTRAINSTALL="po"
-RUBY_FAKEGEM_NAME="activeldap"
inherit ruby-fakegem
diff --git a/dev-ruby/activeldap/activeldap-3.1.1.ebuild b/dev-ruby/activeldap/activeldap-3.1.1.ebuild
deleted file mode 100644
index afef5fb65152..000000000000
--- a/dev-ruby/activeldap/activeldap-3.1.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeldap/activeldap-3.1.1.ebuild,v 1.1 2012/08/16 03:43:18 flameeyes Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ruby19"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.textile TODO"
-RUBY_FAKEGEM_EXTRAINSTALL="po"
-RUBY_FAKEGEM_NAME="activeldap"
-
-inherit ruby-fakegem
-
-MY_P="${P/ruby-/}"
-DESCRIPTION="Ruby/ActiveLDAP provides an activerecord inspired object oriented interface to LDAP"
-HOMEPAGE="https://github.com/activeldap/activeldap"
-
-LICENSE="GPL-2"
-SLOT="3"
-KEYWORDS="~amd64"
-IUSE=""
-
-# Most tests require a live LDAP server to run.
-RESTRICT="test"
-
-ruby_add_bdepend "dev-ruby/hoe"
-ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
-
-ruby_add_rdepend "
- >=dev-ruby/activemodel-3.1.0
- dev-ruby/locale
- dev-ruby/fast_gettext
- dev-ruby/gettext_i18n_rails
- || ( >=dev-ruby/ruby-ldap-0.8.2 dev-ruby/ruby-net-ldap )"
-
-all_ruby_prepare() {
- # Comment out Gettext setup because it does not work with fast_gettext. This
- # patch probably breaks ruby_gettext usage. See
- # https://github.com/activeldap/activeldap/issues/33
- sed -i -e '/GetText\./ s:^:#:' lib/active_ldap/get_text_support.rb || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- dodoc doc/text/*
-
- insinto /usr/share/doc/${PF}
- doins -r examples
-}