summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2010-03-11 16:17:58 +0000
committerDirkjan Ochtman <djc@gentoo.org>2010-03-11 16:17:58 +0000
commitd018855f2e5c60506febde06590efe06596aa879 (patch)
tree08ec470b50bf4b9d081e7b143617e50f6eedd2d3 /dev-python
parentPorted ebuild to EAPI-2. See bug #266839. (diff)
downloadhistorical-d018855f2e5c60506febde06590efe06596aa879.tar.gz
historical-d018855f2e5c60506febde06590efe06596aa879.tar.bz2
historical-d018855f2e5c60506febde06590efe06596aa879.zip
Version bump dev-python/simplejson to 2.1.0.
Package-Manager: portage-2.1.7.17/cvs/Linux x86_64
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/simplejson/ChangeLog9
-rw-r--r--dev-python/simplejson/Manifest4
-rw-r--r--dev-python/simplejson/simplejson-2.1.0.ebuild38
3 files changed, 48 insertions, 3 deletions
diff --git a/dev-python/simplejson/ChangeLog b/dev-python/simplejson/ChangeLog
index 6a8402e6c17b..7e580cf08bbb 100644
--- a/dev-python/simplejson/ChangeLog
+++ b/dev-python/simplejson/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/simplejson
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.20 2009/12/20 10:47:44 grobian Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.21 2010/03/11 16:17:58 djc Exp $
+
+*simplejson-2.1.0 (11 Mar 2010)
+
+ 11 Mar 2010; Dirkjan Ochtman <djc@gentoo.org> +simplejson-2.1.0.ebuild:
+ Version bump to 2.1.0.
20 Dec 2009; Fabian Groffen <grobian@gentoo.org>
simplejson-2.0.9-r1.ebuild:
diff --git a/dev-python/simplejson/Manifest b/dev-python/simplejson/Manifest
index 1bc5c3ee1b16..53c43f6176ed 100644
--- a/dev-python/simplejson/Manifest
+++ b/dev-python/simplejson/Manifest
@@ -1,4 +1,6 @@
DIST simplejson-2.0.9.tar.gz 115443 RMD160 814a0b7aa11a361ba5eda0be93e30505c44409ad SHA1 b5b26059adbe677b06c299bed30557fcb0c7df8c SHA256 abcdf460778beff48ba13faf5b5810cf3803e5c8d872b5fc529226aa56ec93ee
+DIST simplejson-2.1.0.tar.gz 131317 RMD160 41997ae2e309dc538deda50e056119b01afbf23d SHA1 218819e6f8c1aaf6a27d6560eac53ff67613b3e7 SHA256 11bb12aacb646dcccc0d5a3d0e44e5662caf0e71d2f58c7ace8d2ec03cda903b
EBUILD simplejson-2.0.9-r1.ebuild 929 RMD160 d3883891044e0ec5d74fc3737cf9fa57c112b9dc SHA1 cadb9f8a2ccdc98d7fe29159e27eb703d9ed4c65 SHA256 b7eb18f985d2b6edb490195d22ef24f97825d1f01e0b2654d57b9ff093410bcf
-MISC ChangeLog 3041 RMD160 18cc59326116e4c6214bcfd7166513322b79a5fc SHA1 ae05aa429d057635e142c620701e54ecb8684de0 SHA256 bf27acaceb94673382b18555323fd5bd08eab4f9cecf0d68b719538b855e2e0a
+EBUILD simplejson-2.1.0.ebuild 1004 RMD160 21c405ddf0fb8db3ff9ce0b8ab8d5fb0a7771d27 SHA1 cd620b5da8b6adc40c056865f26869dee29f90d5 SHA256 b3ec32e0d7d1165d6875619aa1a5f8dfaefbc080a2dc49125c6073e71f7da8da
+MISC ChangeLog 3170 RMD160 2a5180e6208ec62fd93955b8f31a811f72921dde SHA1 2f54991e4a210464915e14ecd0e42bb15d404885 SHA256 5d341e6ba55696ab3875bf39f916ae21b328a16095c3eadf564f3c40b87ac671
MISC metadata.xml 159 RMD160 900a8c55d7a7d2f6312594769aaf941bf9e99c7f SHA1 c8e604d56dae898258b5254d78cfeac0b981e288 SHA256 9f01104d3484792496faff4805eed0ecea2352a897151f3397d49a13800037b4
diff --git a/dev-python/simplejson/simplejson-2.1.0.ebuild b/dev-python/simplejson/simplejson-2.1.0.ebuild
new file mode 100644
index 000000000000..433e5852aba2
--- /dev/null
+++ b/dev-python/simplejson/simplejson-2.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-2.1.0.ebuild,v 1.1 2010/03/11 16:17:58 djc Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DESCRIPTION="A simple, fast, complete, correct and extensible JSON encoder and decoder."
+HOMEPAGE="http://undefined.org/python/#simplejson"
+SRC_URI="http://cheeseshop.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+RESTRICT_PYTHON_ABIS="3*"
+
+# failures reported as http://code.google.com/p/simplejson/issues/detail?id=73
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" simplejson/tests/__init__.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/*
+ fi
+}