summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-30 21:46:17 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-30 21:46:17 +0000
commit9b11e8eb5a0e23b68f55eddf4146a4a3f08ed7ba (patch)
tree3f48e0c7955e8d672f242e41cc13f25870d676f7 /dev-python
parentDelete older ebuild. (diff)
downloadhistorical-9b11e8eb5a0e23b68f55eddf4146a4a3f08ed7ba.tar.gz
historical-9b11e8eb5a0e23b68f55eddf4146a4a3f08ed7ba.tar.bz2
historical-9b11e8eb5a0e23b68f55eddf4146a4a3f08ed7ba.zip
Version bump.
Package-Manager: portage-2.2.0_alpha19_p24/cvs/Linux x86_64
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/chaco/ChangeLog10
-rw-r--r--dev-python/chaco/Manifest6
-rw-r--r--dev-python/chaco/chaco-3.4.0.ebuild97
3 files changed, 108 insertions, 5 deletions
diff --git a/dev-python/chaco/ChangeLog b/dev-python/chaco/ChangeLog
index 22ea72f1b621..41856fd66a4a 100644
--- a/dev-python/chaco/ChangeLog
+++ b/dev-python/chaco/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/chaco
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/chaco/ChangeLog,v 1.9 2010/10/18 14:51:00 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chaco/ChangeLog,v 1.10 2011/01/30 21:46:17 arfrever Exp $
+
+*chaco-3.4.0 (30 Jan 2011)
+
+ 30 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -chaco-3.3.2.ebuild, +chaco-3.4.0.ebuild:
+ Version bump.
*chaco-3.3.2 (18 Oct 2010)
diff --git a/dev-python/chaco/Manifest b/dev-python/chaco/Manifest
index b7d249c4bbb9..47cf79d4b0c5 100644
--- a/dev-python/chaco/Manifest
+++ b/dev-python/chaco/Manifest
@@ -1,4 +1,4 @@
-DIST Chaco-3.3.2.tar.gz 15607820 RMD160 06ad58baf2887d757cae8b239da421a464f49569 SHA1 ea902ffe0e07d87b1add5d0df4b93d74d7c23054 SHA256 f786b315615e5f938cadb256e7c77a4774c258fabb6997790dd6fb226db6c957
-EBUILD chaco-3.3.2.ebuild 2021 RMD160 8e3f2861114bd8bd8bb066ad9569734d40d145b3 SHA1 3766b9e6936428998e3e153d7a22e521758d1b72 SHA256 d8b3a9eeb9d24cb7f671d641e564f5dc1ff4b5cfa264a91e7151da8a3e1fc2f5
-MISC ChangeLog 1399 RMD160 bacb9cc848fcc740bd6a319a9049be4565685353 SHA1 ced325a1c90e225f436da0aad3219e0182695d7b SHA256 f6c77ca1e88a06a17736363bf6f4084c06ca7f23d2ec5f511786fc8139ad7018
+DIST Chaco-3.4.0.tar.gz 9009267 RMD160 b4998115841bd55ad0fdfa2e16ecef32a9dc991a SHA1 89ea37dbcf6bb01cfab060b20de3b69850c6a5f9 SHA256 074d86eb22162bd99a3c04e8792a6de49872af5c824340f15cdf40c76d4c7d95
+EBUILD chaco-3.4.0.ebuild 2252 RMD160 92e8332cca4051a9c356a39fe68eaafa9d906fa9 SHA1 f0ec5ffbf5c0bcca2035f86bb20262b09797912f SHA256 feac30e3f000967fa20e9b4af1b1c54f5b75b104bd12118b3800e02bda09d0e8
+MISC ChangeLog 1562 RMD160 78845ebb0b6720946417eb3bf5cab810fcd5bfcf SHA1 6afef954110e12a61268b5fb0eaabfa45e766b84 SHA256 ef9bd2393814b13599a692f109bac939139fb7e2abb39b8873403fe42cd26f86
MISC metadata.xml 745 RMD160 c98a49ac7d9f7b981a7d841106e6ba7db136ad61 SHA1 c68d90b1b245dad040602511a81ec440fc2c44e1 SHA256 37568990f348368b3caf7e34896a9021ce2f8a2d1e86ede2357583e72da1225c
diff --git a/dev-python/chaco/chaco-3.4.0.ebuild b/dev-python/chaco/chaco-3.4.0.ebuild
new file mode 100644
index 000000000000..d0747db85ee9
--- /dev/null
+++ b/dev-python/chaco/chaco-3.4.0.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chaco/chaco-3.4.0.ebuild,v 1.1 2011/01/30 21:46:17 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils virtualx
+
+MY_PN="Chaco"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Interactive plotting toolkit"
+HOMEPAGE="http://code.enthought.com/projects/chaco/ http://pypi.python.org/pypi/Chaco"
+SRC_URI="http://www.enthought.com/repo/ETS/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/enable-3.4.0
+ >=dev-python/enthoughtbase-3.1.0
+ dev-python/numpy"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ doc? (
+ dev-python/sphinx
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ x11-apps/xhost
+ )
+ test? (
+ dev-python/coverage
+ dev-python/nose
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ x11-apps/xhost
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="docs/*.txt"
+PYTHON_MODNAME="enthought"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # "${S}/enthought/chaco2/tests and "${S}/enthought/chaco2/shell/tests" do not exist.
+ sed \
+ -e "s:,enthought/chaco2/tests::" \
+ -e "s:,enthought/chaco2/shell/tests::" \
+ -i setup.cfg || die "sed setup.cfg failed"
+
+ # Disable failing test.
+ sed -e "s/test_draw_border_simple/_&/" -i enthought/chaco/tests/border_test_case.py
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ pushd docs > /dev/null
+ doc_generation() {
+ emake html || die "Generation of documentation failed"
+ }
+ maketype="doc_generation" virtualmake
+ popd > /dev/null
+ fi
+}
+
+src_test() {
+ maketype="distutils_src_test" virtualmake
+}
+
+src_install() {
+ find -name "*LICENSE.txt" -delete
+ distutils_src_install
+
+ if use doc; then
+ pushd docs/build/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _images _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/* || die "Installation of examples failed"
+ fi
+}