summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2008-09-14 17:34:45 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2008-09-14 17:34:45 +0000
commit7b949d101fa281d78351cf45a86ecde9ab6ce120 (patch)
tree267b9aad6f7dd14d3e25df1f3e17577ba5b16285 /dev-python
parentVersion bump, #235313 (diff)
downloadhistorical-7b949d101fa281d78351cf45a86ecde9ab6ce120.tar.gz
historical-7b949d101fa281d78351cf45a86ecde9ab6ce120.tar.bz2
historical-7b949d101fa281d78351cf45a86ecde9ab6ce120.zip
Initial import of split gnome-python-desktop. This package installs bindings for the Metacity window manager. Dropped arm/sh/ppc/ppc64/x86-fbsd keywords - require metacity to be keyworded.
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.26.2 i686
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/metacity-python/ChangeLog11
-rw-r--r--dev-python/metacity-python/Manifest5
-rw-r--r--dev-python/metacity-python/metacity-python-2.22.0.ebuild27
-rw-r--r--dev-python/metacity-python/metadata.xml5
4 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/metacity-python/ChangeLog b/dev-python/metacity-python/ChangeLog
new file mode 100644
index 000000000000..74e8e3ea7afe
--- /dev/null
+++ b/dev-python/metacity-python/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-python/metacity-python
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/metacity-python/ChangeLog,v 1.1 2008/09/14 17:34:45 ford_prefect Exp $
+
+*metacity-python-2.22.0 (14 Sep 2008)
+
+ 14 Sep 2008; Arun Raghavan <ford_prefect@gentoo.org> +metadata.xml,
+ +metacity-python-2.22.0.ebuild:
+ Initial import of split gnome-python-desktop. This package installs
+ bindings for the Metacity window manager.
+ Dropped arm/sh/ppc/ppc64/x86-fbsd keywords - require metacity to be keyworded.
diff --git a/dev-python/metacity-python/Manifest b/dev-python/metacity-python/Manifest
new file mode 100644
index 000000000000..4510c5f77a94
--- /dev/null
+++ b/dev-python/metacity-python/Manifest
@@ -0,0 +1,5 @@
+DIST gnome-python-desktop-2.22.0-split.patch.gz 3213 RMD160 be9f3a27050443421e2a710be41539bd8df90a21 SHA1 bad5f80d233a2034768bd1437772914fc96f1453 SHA256 3fcaf681767ee4814c3148627f8ac49a83fad47398c96ace2e28cc8ccaca40c2
+DIST gnome-python-desktop-2.22.0.tar.bz2 571816 RMD160 4a9bc36c379f5fbb6549506c8b8e8bdb63bf0d62 SHA1 6f1a93aacfc256ca878f8f3636a0270580d2354b SHA256 116213b0b0fc3f1fa6771589eab86ccdf5d5024c30a987f3b912da0902be9d37
+EBUILD metacity-python-2.22.0.ebuild 747 RMD160 e88ba0618143a00769ad69ca255f8da361beb769 SHA1 caeeb5fec8b3285c8735e6db09947011214bf073 SHA256 724f54889993bb985cff24880874de352e4a6243b9e5598711938c45ee8e813d
+MISC ChangeLog 569 RMD160 0b8ec05352bfbeedb5fa0a1edc570bef5d97b896 SHA1 4a0f6f1a55d5c55d683a01f3d132241736a7d1da SHA256 080fa507b3434c838c20bc7336b8a719f17d3f1415dfe51e7e377be7cd110e47
+MISC metadata.xml 158 RMD160 c0e2bae8e91bb6be8922bac5e4f597302e06587e SHA1 38f78e9790bcd4382b4a49aa226aa6dda1d3a3d7 SHA256 3a7dbca0fdc557de69783e0663e2d76ddab129ea8a19b2d0ef6d3e5d1b947ce1
diff --git a/dev-python/metacity-python/metacity-python-2.22.0.ebuild b/dev-python/metacity-python/metacity-python-2.22.0.ebuild
new file mode 100644
index 000000000000..32117ba684f0
--- /dev/null
+++ b/dev-python/metacity-python/metacity-python-2.22.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/metacity-python/metacity-python-2.22.0.ebuild,v 1.1 2008/09/14 17:34:45 ford_prefect Exp $
+
+G_PY_PN="gnome-python-desktop"
+
+inherit gnome-python-common
+
+DESCRIPTION="Python bindings for the Metacity window manager"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~sparc ~x86"
+IUSE=""
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/${G_PY_PN}-${PV}-split.patch.gz"
+
+RDEPEND=">=x11-wm/metacity-2.21.5
+ !<dev-python/gnome-python-desktop-2.22.0-r10"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ gnome-python-common_src_unpack
+ cd "${S}"
+ epatch "${WORKDIR}/${G_PY_PN}-${PV}-split.patch"
+ eautoreconf
+}
diff --git a/dev-python/metacity-python/metadata.xml b/dev-python/metacity-python/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/dev-python/metacity-python/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>