summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-12-06 03:52:21 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-12-06 03:52:21 +0000
commit3500af66e7b41b054b8bd78fdfbeaccc84cae50d (patch)
tree8bf31f3cbd550bde36185df1c27a704bac008a45 /dev-python
parentfix togl problems with tk8.4.4 (diff)
downloadhistorical-3500af66e7b41b054b8bd78fdfbeaccc84cae50d.tar.gz
historical-3500af66e7b41b054b8bd78fdfbeaccc84cae50d.tar.bz2
historical-3500af66e7b41b054b8bd78fdfbeaccc84cae50d.zip
fix togl problems with tk8.4.4
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyOpenGL/Manifest7
-rw-r--r--dev-python/PyOpenGL/PyOpenGL-2.0.0.44.ebuild37
-rw-r--r--dev-python/PyOpenGL/files/PyOpenGL-2.0.0.44-disable_togl.patch13
3 files changed, 27 insertions, 30 deletions
diff --git a/dev-python/PyOpenGL/Manifest b/dev-python/PyOpenGL/Manifest
index b6289b8d1da3..a58ca0314b16 100644
--- a/dev-python/PyOpenGL/Manifest
+++ b/dev-python/PyOpenGL/Manifest
@@ -1,7 +1,6 @@
-MD5 545335114e89f53b3640f871dec3a5a3 ChangeLog 1123
-MD5 464b7ade08245f08d15a210f27685725 PyOpenGL-2.0.0.44.ebuild 861
-MD5 464b7ade08245f08d15a210f27685725 PyOpenGL-2.0.1.07.ebuild 861
+MD5 ca20830bb327ee741a36dc19822f7e2f ChangeLog 1454
+MD5 b60cb72fe35fdc00aff38e4d56be064f PyOpenGL-2.0.0.44.ebuild 911
MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
+MD5 6c1efcd8d08f3e9f122c32c05c9d7f62 files/PyOpenGL-2.0.0.44-disable_togl.patch 483
MD5 67d2ad027cfd6d411a585b0e346606a8 files/config.diff 1175
MD5 9feca450998c720327067463fea8cdc0 files/digest-PyOpenGL-2.0.0.44 70
-MD5 216e09affd35ec2d807b3256bf36d899 files/digest-PyOpenGL-2.0.1.07 70
diff --git a/dev-python/PyOpenGL/PyOpenGL-2.0.0.44.ebuild b/dev-python/PyOpenGL/PyOpenGL-2.0.0.44.ebuild
index c5598c45b966..de206f918c11 100644
--- a/dev-python/PyOpenGL/PyOpenGL-2.0.0.44.ebuild
+++ b/dev-python/PyOpenGL/PyOpenGL-2.0.0.44.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyOpenGL/PyOpenGL-2.0.0.44.ebuild,v 1.12 2003/06/22 12:15:59 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyOpenGL/PyOpenGL-2.0.0.44.ebuild,v 1.13 2003/12/06 03:52:16 liquidx Exp $
-inherit virtualx
+inherit distutils virtualx
S="${WORKDIR}/${P}"
@@ -15,39 +15,24 @@ SLOT="0"
KEYWORDS="x86 ~ppc ~sparc alpha"
DEPEND="virtual/python
- >=media-libs/glut-3.7-r2
+ >=media-libs/glut-3.7-r2
x11-base/xfree
virtual/opengl"
src_unpack() {
-
unpack ${A}
- cd ${S}
- patch -p1 < ${FILESDIR}/config.diff || die "patch failed"
-
+ EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/config.diff
+ EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/${P}-disable_togl.patch
}
src_compile() {
-
-# IN_X=`env | grep DISPLAY | wc -l`
-# if [ "$IN_X" -eq "0" ]; then
-# einfo "******************************"
-# einfo "You must have XWindows running"
-# einfo "in order to compile PyOpenGL. "
-# einfo "******************************"
-# die "please start xwindows before emerging"
-# fi
-
- export maketype="python setup.py build"
- virtualmake "$*" || die
-# python setup.py build || die "build failed"
-
+ export maketype="python"
+ export python="virtualmake"
+ distutils_src_compile
}
src_install () {
-
- export maketype="python setup.py install --prefix=${D}/usr"
- virtualmake "$*" || die
- #python setup.py install --prefix=${D}/usr || die "install failed"
-
+ export maketype="python"
+ export python="virtualmake"
+ distutils_src_install
}
diff --git a/dev-python/PyOpenGL/files/PyOpenGL-2.0.0.44-disable_togl.patch b/dev-python/PyOpenGL/files/PyOpenGL-2.0.0.44-disable_togl.patch
new file mode 100644
index 000000000000..08b6b39b77f2
--- /dev/null
+++ b/dev-python/PyOpenGL/files/PyOpenGL-2.0.0.44-disable_togl.patch
@@ -0,0 +1,13 @@
+--- setup.py 2001-08-30 19:42:41.000000000 +0100
++++ setup.py.new 2003-12-06 02:33:12.874811216 +0000
+@@ -97,8 +97,8 @@
+ 'build_doc':build_doc,
+ # 'build_clib':build_clib,
+ 'build_py':build_py,
+- 'build_ext':togl_build,
+- 'install':togl_install,
++# 'build_ext':togl_build,
++# 'install':togl_install,
+ # the next line is very important
+ # because we use another format for data_files
+ 'install_data': my_install_data},