summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-30 17:01:59 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-30 17:01:59 +0000
commit0fe097ecab32d9942ea9474cbd191a5782e2ecb4 (patch)
tree0a4eed936225a3440a9bb919a72ccc4e2f4a78a1 /dev-python
parentAdd ~alpha/~ia64/~sparc wrt #347744 (diff)
downloadhistorical-0fe097ecab32d9942ea9474cbd191a5782e2ecb4.tar.gz
historical-0fe097ecab32d9942ea9474cbd191a5782e2ecb4.tar.bz2
historical-0fe097ecab32d9942ea9474cbd191a5782e2ecb4.zip
Delete older ebuild.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/enable/enable-3.3.2.ebuild90
-rw-r--r--dev-python/enable/files/enable-3.0.2-nofreetype.patch99
2 files changed, 0 insertions, 189 deletions
diff --git a/dev-python/enable/enable-3.3.2.ebuild b/dev-python/enable/enable-3.3.2.ebuild
deleted file mode 100644
index efa0dff51966..000000000000
--- a/dev-python/enable/enable-3.3.2.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/enable-3.3.2.ebuild,v 1.1 2010/10/18 14:16:23 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-DISTUTILS_SRC_TEST="setup.py"
-
-inherit distutils eutils virtualx
-
-MY_PN="Enable"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Enthought Tool Suite drawing and interaction packages"
-HOMEPAGE="http://code.enthought.com/projects/enable http://pypi.python.org/pypi/Enable"
-SRC_URI="http://www.enthought.com/repo/ETS/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-RDEPEND=">=dev-python/enthoughtbase-3.0.6
- dev-python/numpy
- dev-python/reportlab
- >=dev-python/traitsgui-3.5.0[wxwidgets]
- >=media-libs/freetype-2
- virtual/opengl
- x11-libs/libX11"
-DEPEND="${RDEPEND}
- dev-lang/swig
- dev-python/cython
- dev-python/setuptools
- doc? ( dev-python/setupdocs )
- test? (
- dev-python/coverage
- >=dev-python/nose-0.10.3
- media-fonts/font-cursor-misc
- media-fonts/font-misc-misc
- x11-apps/xhost
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-PYTHON_MODNAME="enthought"
-
-src_prepare() {
- distutils_src_prepare
-
- # "${S}/enthought/enable2/tests" does not exist.
- sed -e "s:,enthought/enable2/tests::" -i setup.cfg || die "sed setup.cfg failed"
-
- sed \
- -e "s/self.run_command('build_docs')/pass/" \
- -e "/setupdocs>=1.0/d" \
- -i setup.py || die "sed setup.py failed"
-
- epatch "${FILESDIR}/${PN}-3.3.0-nofreetype.patch"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- "$(PYTHON -f)" setup.py build_docs --formats=html,pdf || die "Generation of documentation failed"
- fi
-}
-
-src_test() {
- maketype="distutils_src_test" virtualmake
-}
-
-src_install() {
- find "${S}" -name "*LICENSE.txt" -delete
- distutils_src_install
- dodoc docs/*.txt
- insinto /usr/share/doc/${PF}
- if use doc; then
- doins -r build/docs/html || die
- doins build/docs/latex/*.pdf || die
- fi
- if use examples; then
- doins -r examples || die
- fi
-}
diff --git a/dev-python/enable/files/enable-3.0.2-nofreetype.patch b/dev-python/enable/files/enable-3.0.2-nofreetype.patch
deleted file mode 100644
index 53a6f8dffe9e..000000000000
--- a/dev-python/enable/files/enable-3.0.2-nofreetype.patch
+++ /dev/null
@@ -1,99 +0,0 @@
-Index: python-enable-3.0.1/enthought/kiva/agg/setup.py
-===================================================================
---- python-enable-3.0.1.orig/enthought/kiva/agg/setup.py 2008-09-27 00:07:39.000000000 -0400
-+++ python-enable-3.0.1/enthought/kiva/agg/setup.py 2008-09-27 00:11:45.000000000 -0400
-@@ -5,39 +5,6 @@
- import platform
-
-
--
--
--freetype2_sources =['autohint/autohint.c',
-- 'base/ftbase.c','base/ftsystem.c','base/ftinit.c',
-- 'base/ftglyph.c','base/ftmm.c','base/ftbdf.c',
-- 'base/ftbbox.c','base/ftdebug.c','base/ftxf86.c',
-- 'base/fttype1.c','bdf/bdf.c',
-- 'cff/cff.c',
-- 'cid/type1cid.c',
-- 'pcf/pcf.c','pfr/pfr.c',
-- 'psaux/psaux.c',
-- 'pshinter/pshinter.c',
-- 'psnames/psnames.c',
-- 'raster/raster.c',
-- 'sfnt/sfnt.c',
-- 'smooth/smooth.c',
-- 'truetype/truetype.c',
-- 'type1/type1.c',
-- 'type42/type42.c',
-- 'winfonts/winfnt.c',
-- 'gzip/ftgzip.c',
-- 'base/ftmac.c',
-- ]
--
--freetype2_dirs = [
-- 'base','bdf','cache','cff','cid','pcf','pfr',
-- 'psaux','pshinter','psnames','raster','sfnt',
-- 'smooth','truetype','type1','type42','winfonts',
-- 'gzip'
-- ]
--
--
--
- def configuration(parent_package='',top_path=None):
- from numpy.distutils.misc_util import Configuration
- from numpy.distutils.system_info import dict_append, get_info
-@@ -68,35 +35,10 @@
-
-
- #-------------------------------------------------------------------------
-- # Add the freetype library (agg 2.4 links against this)
-- #-------------------------------------------------------------------------
--
-- prefix = config.paths('freetype2/src')[0]
-- freetype_lib = 'freetype2_src'
--
-- def get_ft2_sources((lib_name, build_info), build_dir):
-- sources = [prefix + "/" + s for s in freetype2_sources]
-- if sys.platform=='darwin':
-- return sources[:]
-- return sources[:-1]
--
-- ft2_incl_dirs = ['freetype2/src/' + s for s in freetype2_dirs] \
-- + ['freetype2/include', 'freetype2/src']
-- ft2_incl_dirs = config.paths(*ft2_incl_dirs)
-- if sys.platform == 'darwin':
-- ft2_incl_dirs.append("/Developer/Headers/FlatCarbon")
--
-- config.add_library(freetype_lib,
-- sources = [get_ft2_sources],
-- include_dirs = ft2_incl_dirs,
-- depends = ['freetype2']
-- )
--
-- #-------------------------------------------------------------------------
- # Add the Agg sources
- #-------------------------------------------------------------------------
-
-- agg_include_dirs = [agg_dir+'/include',agg_dir+'/font_freetype'] + ft2_incl_dirs
-+ agg_include_dirs = [agg_dir+'/include',agg_dir+'/font_freetype'] + ["/usr/include/freetype2/"]
- agg_sources = [agg_dir+'/src/*.cpp',
- agg_dir+'/font_freetype/*.cpp']
- config.add_library(agg_lib,
-@@ -110,7 +52,7 @@
- if sys.platform == 'darwin':
- define_macros = [('__DARWIN__', None)]
- macros = [('__DARWIN__', None)]
-- extra_link_args = ['-framework', 'Carbon']
-+ extra_link_args = ['-framework', 'Carbon', '-Wl,-search_paths_first']
- else:
- define_macros = []
- macros = []
-@@ -163,7 +105,7 @@
-
- build_info = {}
- kiva_lib = 'kiva_src'
-- build_libraries = [kiva_lib, agg_lib, freetype_lib]
-+ build_libraries = [kiva_lib, agg_lib, "freetype"]
- if sys.platform == "win32":
- build_libraries += ["opengl32", "glu32"]
- elif sys.platform == "darwin":