summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2003-09-13 13:58:10 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2003-09-13 13:58:10 +0000
commit5abbf8d78ed42b7c33686b80c1f6447f1b7fcb9d (patch)
tree06847ffe8d324ac8b89b411142eecd1bc436d236 /dev-python/twisted
parentversion bump (diff)
downloadhistorical-5abbf8d78ed42b7c33686b80c1f6447f1b7fcb9d.tar.gz
historical-5abbf8d78ed42b7c33686b80c1f6447f1b7fcb9d.tar.bz2
historical-5abbf8d78ed42b7c33686b80c1f6447f1b7fcb9d.zip
version bump
Diffstat (limited to 'dev-python/twisted')
-rw-r--r--dev-python/twisted/Manifest4
-rw-r--r--dev-python/twisted/files/digest-twisted-1.0.71
-rw-r--r--dev-python/twisted/twisted-1.0.7.ebuild43
3 files changed, 46 insertions, 2 deletions
diff --git a/dev-python/twisted/Manifest b/dev-python/twisted/Manifest
index 54b68e548763..0ee6b570cf8b 100644
--- a/dev-python/twisted/Manifest
+++ b/dev-python/twisted/Manifest
@@ -1,8 +1,8 @@
MD5 890a242f603b2a6bedfa33b97a3f3d76 twisted-1.0.6.ebuild 1219
MD5 59755b7789d4ef04a04c902b9b01d3be twisted-1.0.7_rc1.ebuild 1262
-MD5 b1d637b358d3a8154a18acefa899fbc3 ChangeLog 6401
+MD5 cdf3981a48ea8bd4708f61f8b55124de ChangeLog 6524
MD5 19df39ef54fc4a8677998f19bb6046ac metadata.xml 218
-MD5 890a242f603b2a6bedfa33b97a3f3d76 twisted-1.0.7.ebuild 1219
+MD5 2489975a899a1d3dc7468c8e84613431 twisted-1.0.7.ebuild 1218
MD5 7b72afa2517437dbde778c70b4e19af2 files/digest-twisted-1.0.6 67
MD5 c4224a2ac969db93d73848f95579cbab files/digest-twisted-1.0.7 67
MD5 784d7af8d65cba1fa9405b7072ada41b files/digest-twisted-1.0.7_rc1 70
diff --git a/dev-python/twisted/files/digest-twisted-1.0.7 b/dev-python/twisted/files/digest-twisted-1.0.7
new file mode 100644
index 000000000000..f73225d6979c
--- /dev/null
+++ b/dev-python/twisted/files/digest-twisted-1.0.7
@@ -0,0 +1 @@
+MD5 f180e39731317aaf9b9b36497018ad9c Twisted-1.0.7.tar.bz2 5229998
diff --git a/dev-python/twisted/twisted-1.0.7.ebuild b/dev-python/twisted/twisted-1.0.7.ebuild
new file mode 100644
index 000000000000..971e95e69584
--- /dev/null
+++ b/dev-python/twisted/twisted-1.0.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.0.7.ebuild,v 1.1 2003/09/13 13:58:03 lordvan Exp $
+
+inherit distutils
+
+DESCRIPTION="collection of servers and clients, which can be used either by developers of new applications or directly. Documentation included."
+HOMEPAGE="http://www.twistedmatrix.com/"
+SRC_URI="http://twisted.sourceforge.net/Twisted-${PV}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86 alpha sparc"
+IUSE="gtk2 doc"
+
+DEPEND=">=dev-lang/python-2.2*
+ >=dev-python/pycrypto-1.9_alpha4
+ gtk? ( =dev-python/pygtk-0.6* )
+ gtk2? ( >=dev-python/pygtk-1.99* )"
+
+S=${WORKDIR}/Twisted-${PV}
+
+src_install() {
+ distutils_src_install
+
+ # of course it's documentation!
+ doman doc/man/*.[0-9n]
+ rm -rf doc/man # don't dupe the man pages
+
+ # next few lines will install docs: 9.4 megs!
+ if [ -n "`use doc`" ]; then
+ cd ${S}/doc
+ dodir /usr/share/doc/${PF}
+ cp -r . ${D}/usr/share/doc/${PF}
+ fi
+
+ # use gtk2 if they so wish
+ if [ -n "`use gtk2`" ]; then
+ sed -e 's/import manhole/import manhole2/' \
+ -e 's/manhole\.run()/manhole2.run()/' \
+ -i ${D}/usr/bin/manhole
+ fi
+}