summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-12-03 16:09:34 +0000
committerMike Gilbert <floppym@gentoo.org>2014-12-03 16:09:34 +0000
commit59d3bca5d329f010d3b788412d6036dbe0102bea (patch)
tree439f90994f3f89fd940d85494cc63816ce304044 /dev-python/sphinx/sphinx-1.2.3.ebuild
parentVersion bump (diff)
downloadhistorical-59d3bca5d329f010d3b788412d6036dbe0102bea.tar.gz
historical-59d3bca5d329f010d3b788412d6036dbe0102bea.tar.bz2
historical-59d3bca5d329f010d3b788412d6036dbe0102bea.zip
Fix build failure when DISTUTILS_NO_PARALLEL_BUILD=1, bug 531534.
Package-Manager: portage-2.2.14/cvs/Linux x86_64 Manifest-Sign-Key: 0x0BBEEA1FEA4843A4
Diffstat (limited to 'dev-python/sphinx/sphinx-1.2.3.ebuild')
-rw-r--r--dev-python/sphinx/sphinx-1.2.3.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/sphinx/sphinx-1.2.3.ebuild b/dev-python/sphinx/sphinx-1.2.3.ebuild
index 0ef5cb379a13..3bb6235702bd 100644
--- a/dev-python/sphinx/sphinx-1.2.3.ebuild
+++ b/dev-python/sphinx/sphinx-1.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-1.2.3.ebuild,v 1.4 2014/11/23 16:36:00 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-1.2.3.ebuild,v 1.5 2014/12/03 16:09:32 floppym Exp $
EAPI=5
@@ -43,9 +43,10 @@ python_compile() {
# Note that the tests usually do it for us. However, I don't want
# to trust USE=test really running all the tests, especially
# with FEATURES=test-fail-continue.
- cd "${BUILD_DIR}"/lib || die
+ pushd "${BUILD_DIR}"/lib > /dev/null || die
"${PYTHON}" -m sphinx.pycode.__init__ \
|| die "Grammar generation failed."
+ popd > /dev/null || die
}
python_compile_all() {