summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2005-10-15 05:41:59 +0000
committerRob Cakebread <pythonhead@gentoo.org>2005-10-15 05:41:59 +0000
commit3ffccc077ead2e6c182e3c59e6825a857bbb1a72 (patch)
tree0c3a8e509ca26f3c3b621793d7cfb16a786153bb /dev-python/setuptools
parentversion bump - old version removal (diff)
downloadhistorical-3ffccc077ead2e6c182e3c59e6825a857bbb1a72.tar.gz
historical-3ffccc077ead2e6c182e3c59e6825a857bbb1a72.tar.bz2
historical-3ffccc077ead2e6c182e3c59e6825a857bbb1a72.zip
Initial commit. Thank you Geoffrey Clements <geoff@electron.me.uk> and Thomas Fullhart <kayos@genetikayos.com> for the ebuild. bug #108227
Package-Manager: portage-1.589-cvs
Diffstat (limited to 'dev-python/setuptools')
-rw-r--r--dev-python/setuptools/ChangeLog11
-rw-r--r--dev-python/setuptools/Manifest4
-rw-r--r--dev-python/setuptools/files/digest-setuptools-0.6_alpha51
-rw-r--r--dev-python/setuptools/metadata.xml5
-rw-r--r--dev-python/setuptools/setuptools-0.6_alpha5.ebuild31
5 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/setuptools/ChangeLog b/dev-python/setuptools/ChangeLog
new file mode 100644
index 000000000000..3e374e281577
--- /dev/null
+++ b/dev-python/setuptools/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-python/setuptools
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/ChangeLog,v 1.1 2005/10/15 05:41:59 pythonhead Exp $
+
+*setuptools-0.6_alpha5 (15 Oct 2005)
+
+ 15 Oct 2005; Rob Cakebread <pythonhead@gentoo.org> +metadata.xml,
+ +setuptools-0.6_alpha5.ebuild:
+ Initial commit. Thank you Geoffrey Clements <geoff@electron.me.uk> and
+ Thomas Fullhart <kayos@genetikayos.com> for the ebuild. bug #108227
+
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
new file mode 100644
index 000000000000..437c472d5b14
--- /dev/null
+++ b/dev-python/setuptools/Manifest
@@ -0,0 +1,4 @@
+MD5 11345df562d028a9089cb4c73602bfd9 setuptools-0.6_alpha5.ebuild 991
+MD5 9ac4199ebe7cd3e7e311274994767f82 metadata.xml 160
+MD5 8c62de7e19c249039c102bd3bca2f4ce ChangeLog 502
+MD5 00a23217d512848371e81f66adfda033 files/digest-setuptools-0.6_alpha5 65
diff --git a/dev-python/setuptools/files/digest-setuptools-0.6_alpha5 b/dev-python/setuptools/files/digest-setuptools-0.6_alpha5
new file mode 100644
index 000000000000..975a6fcc23eb
--- /dev/null
+++ b/dev-python/setuptools/files/digest-setuptools-0.6_alpha5
@@ -0,0 +1 @@
+MD5 ae3e44e29c7d5296ed4b2042ba1108ce setuptools-0.6a5.zip 194836
diff --git a/dev-python/setuptools/metadata.xml b/dev-python/setuptools/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/dev-python/setuptools/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/setuptools/setuptools-0.6_alpha5.ebuild b/dev-python/setuptools/setuptools-0.6_alpha5.ebuild
new file mode 100644
index 000000000000..69ed15799df7
--- /dev/null
+++ b/dev-python/setuptools/setuptools-0.6_alpha5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/setuptools-0.6_alpha5.ebuild,v 1.1 2005/10/15 05:41:59 pythonhead Exp $
+
+inherit distutils
+
+MY_P=${P/_alpha/a}
+DESCRIPTION="A collection of enhancements to the Python distutils including easy install"
+HOMEPAGE="http://peak.telecommunity.com/"
+SRC_URI="http://cheeseshop.python.org/packages/source/s/setuptools/${MY_P}.zip"
+LICENSE="PSF-2.2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+S="${WORKDIR}/${MY_P}"
+
+DEPEND=">=dev-lang/python-2.4.2
+ app-arch/zip"
+
+src_install() {
+ DOCS="EasyInstall.txt api_tests.txt pkg_resources.txt setuptools.txt"
+ distutils_src_install
+ distutils_python_version
+
+ # create .pth file in site-packages so the setuptools egg is added to
+ # the module search path
+ insinto /usr/lib/python${PYVER}/site-packages
+ echo "${MY_P}-py${PYVER}.egg" > "${MY_P}-py${PYVER}.pth"
+ doins "${MY_P}-py${PYVER}.pth"
+}
+