summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-04-09 08:56:22 +0000
committerIan Delaney <idella4@gentoo.org>2013-04-09 08:56:22 +0000
commitab92523bba92f52d6f84e76b5872191a6809c09c (patch)
treef58ceacfa269d0dffdcebf6a42b174fcd12bac2c /dev-python/ruledispatch/ruledispatch-0.5_pre2306-r2.ebuild
parentAdd blocker on incompatible cache installations (diff)
downloadhistorical-ab92523bba92f52d6f84e76b5872191a6809c09c.tar.gz
historical-ab92523bba92f52d6f84e76b5872191a6809c09c.tar.bz2
historical-ab92523bba92f52d6f84e76b5872191a6809c09c.zip
migration revbump
Package-Manager: portage-2.1.11.60/cvs/Linux x86_64 Manifest-Sign-Key: 0xB8072B0D
Diffstat (limited to 'dev-python/ruledispatch/ruledispatch-0.5_pre2306-r2.ebuild')
-rw-r--r--dev-python/ruledispatch/ruledispatch-0.5_pre2306-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/ruledispatch/ruledispatch-0.5_pre2306-r2.ebuild b/dev-python/ruledispatch/ruledispatch-0.5_pre2306-r2.ebuild
new file mode 100644
index 000000000000..796fc9467e36
--- /dev/null
+++ b/dev-python/ruledispatch/ruledispatch-0.5_pre2306-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ruledispatch/ruledispatch-0.5_pre2306-r2.ebuild,v 1.1 2013/04/09 08:55:34 idella4 Exp $
+
+EAPI="5"
+# For now, only py2.7 handles _d_speedups.pyx
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils versionator flag-o-matic
+
+MY_PN="RuleDispatch"
+MY_P="${MY_PN}-$(get_version_component_range 1-2)a0.dev-$(get_version_component_range 3-)"
+MY_P="${MY_P/pre/r}"
+
+DESCRIPTION="Rule-based Dispatching and Generic Functions"
+HOMEPAGE="http://peak.telecommunity.com/"
+# http://svn.eby-sarna.com/RuleDispatch/
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+LICENSE="|| ( PSF-2.4 ZPL )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=">=dev-python/pyprotocols-1.0_pre2306"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_PN}"
+
+PATCHES=( "${FILESDIR}/${PN}_as_syntax_fix.patch" )
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+}
+
+python_test() {
+ esetup.py && einfo "Tests effective under python2.7" || die "Tests failed under ${EPYTHON}"
+}